source: projects/specs/trunk/lib/libv/libvdpau/libvdpau-vl.spec @ 521

Revision 521, 4.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           libvdpau
4Version:        0.4
5Release:        1%{?_dist_release}
6Summary:        Wrapper library for the Video Decode and Presentation API for unix
7Summary(ja):    VDPAU (Video Decode and Presentation API for unix) 用のラッパーライブラリ
8
9Group:          System Environment/Libraries
10License:        MIT
11URL:            http://freedesktop.org/wiki/Software/VDPAU
12Source0:        http://people.freedesktop.org/~aplattner/vdpau/libvdpau-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires:  libX11-devel
16
17Packager:       kazutaka
18
19%description
20VDPAU is the Video Decode and Presentation API for UNIX.
21It provides an interface to video decode acceleration and presentation
22hardware present in modern GPUs.
23
24%description -l ja
25VDPAU は Video Decode and Presentation API for UNIX の略で、
26GPU が提供するハードウェアによる動画の再生支援機能を利用する
27ためのインターフェース (API) を提供します。
28
29
30%package devel
31Summary:        Development files for %{name}
32Summary(ja):    %{name} の開発用ファイル
33Group:          Development/Libraries
34Requires:       %{name} = %{version}-%{release}
35Requires:       libX11-devel
36Requires:       pkgconfig
37
38%description devel
39The %{name}-devel package contains libraries and header files for
40developing applications that use %{name}.
41
42%description devel -l ja
43%{name}-devel パッケージは、%{name} を使用するアプリケーションの
44開発に必要なライブラリやヘッダファイルを含んでいます。
45
46# compat32
47%package -n compat32-%{name}
48Summary:        Wrapper library for the Video Decode and Presentation API for unix
49Summary(ja):    VDPAU (Video Decode and Presentation API for unix) 用のラッパーライブラリ
50Group:          System Environment/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description -n compat32-%{name}
54VDPAU is the Video Decode and Presentation API for UNIX.
55It provides an interface to video decode acceleration and presentation
56hardware present in modern GPUs.
57
58%description -l ja -n compat32-%{name}
59VDPAU は Video Decode and Presentation API for UNIX の略で、
60GPU が提供するハードウェアによる動画の再生支援機能を利用する
61ためのインターフェース (API) を提供します。
62
63%package -n compat32-%{name}-devel
64Summary:        Development files for compat32-%{name}
65Summary(ja):    compat32-%{name} の開発用ファイル
66Group:          Development/Libraries
67Requires:       compat32-%{name} = %{version}-%{release}
68Requires:       compat32-%{name}-devel = %{version}-%{release}
69
70%description -n compat32-%{name}-devel
71The %{name}-devel package contains libraries and header files for
72developing applications that use %{name}.
73
74%description -n compat32-%{name}-devel -l ja
75%{name}-devel パッケージは、%{name} を使用するアプリケーションの
76開発に必要なライブラリやヘッダファイルを含んでいます。
77
78
79%prep
80%setup -q
81
82
83%build
84%configure --disable-static
85%{__make} %{?_smp_mflags}
86
87
88%install
89%{__rm} -rf $RPM_BUILD_ROOT
90%{__make} install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
91find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
92
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102
103%files
104%defattr(-,root,root,-)
105%doc AUTHORS COPYING
106%{_libdir}/*.so.*
107%{_libdir}/vdpau/libvdpau_trace.so.*
108
109%files devel
110%defattr(-,root,root,-)
111%{_includedir}/vdpau/
112%{_libdir}/libvdpau.so
113%{_libdir}/vdpau/libvdpau_trace.so
114%{_libdir}/pkgconfig/vdpau.pc
115
116%if %{build_compat32}
117%files -n compat32-%{name}
118%defattr(-,root,root,-)
119%{_libdir}/*.so.*
120%{_libdir}/vdpau/*.so.*
121
122%files -n compat32-%{name}-devel
123%defattr(-,root,root,-)
124%{_libdir}/libvdpau.so
125%{_libdir}/vdpau/libvdpau_trace.so
126%{_libdir}/pkgconfig/vdpau.pc
127%endif
128
129
130%changelog
131* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-1
132- new upstream release
133- add compat32 package
134
135* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.2-1
136- initial build for Vine Linux based of fedora development
137- add japanese description and summary
138
139* Thu Sep 17 2009 kwizart < kwizart at gmail.com > - 0.2-1
140- Update to 0.2
141- Disable ExclusiveArch
142
143* Mon Sep  7 2009 kwizart < kwizart at gmail.com > - 0.1-0.6.20090904git
144- Update to gitdate 20090904git
145
146* Wed Sep  2 2009 kwizart < kwizart at gmail.com > - 0.1-0.5git20090902
147- Update to gitdate 20090902 with merged patches
148
149* Mon Jun 15 2009 kwizart < kwizart at gmail.com > - 0.1-0.3git20090318
150- Add missing -ldl at link time
151
152* Fri Mar 22 2009 kwizart < kwizart at gmail.com > - 0.1-0.2git20090318
153- Backport fix thread_2
154
155* Fri Mar  6 2009 kwizart < kwizart at gmail.com > - 0.1-0.1git20090318
156- Initial spec file
157
Note: See TracBrowser for help on using the repository browser.