source: projects/specs/trunk/lib/libu/libuv/libuv-vl.spec @ 9459

Revision 9459, 1.5 KB checked in by iwaim, 9 years ago (diff)

new: libuv

Line 
1%define ver 1.4.2
2%define rel 1
3
4Summary: a multi-platform support library with a focus on asynchronous I/O
5Name: libuv
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: Node's license and so on (See LICENSE file)
9Group: System Environment/Libraries
10URL: https://github.com/libuv/libuv
11Source0: http://libuv.org/dist/v%{version}/%{name}-v%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14Vendor: Project Vine
15Distribution: Vine Linux
16Packager: iwaim
17
18%description
19libuv is a multi-platform support library with a focus on asynchronous I/O.
20It was primarily developed for use by Node.js, but it's also used by Luvit,
21Julia, pyuv, and others.
22
23%package devel
24Summary: Development libraries and headers for libuv
25Group: Development/Libraries
26Requires: %{name} = %{version}-%{release}
27
28%description devel
29Development libraries and headers for libuv.
30
31%prep
32%setup -q -n %{name}-v%{version}
33./autogen.sh
34%configure
35
36%build
37%__make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%makeinstall
42%__rm -f %{buildroot}%{_libdir}/*.{la,a}
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%check
48make check
49
50%files
51%defattr(-,root,root,-)
52%doc LICENSE AUTHORS CONTRIBUTING.md ChangeLog README.md
53%{_libdir}/%{name}*.so.*
54
55%files devel
56%defattr(-,root,root,-)
57%doc LICENSE AUTHORS CONTRIBUTING.md ChangeLog README.md
58%doc img docs samples
59%{_libdir}/%{name}*.so
60%{_libdir}/pkgconfig/*.pc
61%{_includedir}/*.h
62
63%changelog
64* Mon Mar 23 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.2-1
65- Initial build.
Note: See TracBrowser for help on using the repository browser.