source: projects/specs/trunk/lib/libu/libutempter/libutempter-vl.spec @ 521

Revision 521, 9.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define utempter_compat_ver 0.5.5
2
3Summary: A privileged helper for utmp/wtmp updates
4Name: libutempter
5Version: 1.1.5
6Release: 3%{?_dist_release}
7License: LGPLv2
8Group: System Environment/Libraries
9URL: ftp://ftp.altlinux.org/pub/people/ldv/utempter
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11
12Source0: ftp://ftp.altlinux.org/pub/people/ldv/utempter/%{name}-%{version}.tar.bz2
13
14Requires(pre): shadow-utils
15Requires(post): /sbin/ldconfig
16Requires(postun): /sbin/ldconfig
17
18Provides: utempter = %{utempter_compat_ver}
19Obsoletes: utempter
20
21%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
22
23%description
24This library provides interface for terminal emulators such as
25screen and xterm to record user sessions to utmp and wtmp files.
26
27%package devel
28Summary: Development environment for utempter
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33This package contains development files required to build
34utempter-based software.
35
36
37%package -n compat32-%{name}
38Summary:   A privileged helper for utmp/wtmp updates.
39Group:     System Environment/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description -n compat32-%{name}
43Utempter is a utility which allows some non-privileged programs to
44have required root access without compromising system
45security. Utempter accomplishes this feat by acting as a buffer
46between root and the programs.
47
48%package -n compat32-%{name}-devel
49Summary: Development environment for utempter
50Group: Development/Libraries
51Requires: compat32-%{name} = %{version}
52Requires: %{name}-devel = %{version}
53
54%description -n compat32-%{name}-devel
55This package contains development files required to build
56utempter-based software.
57
58
59%prep
60%setup -q
61
62%build
63make CFLAGS="$RPM_OPT_FLAGS" libdir="%{_libdir}" libexecdir="%{_libexecdir}"
64
65%install
66rm -rf $RPM_BUILD_ROOT
67
68make install DESTDIR="$RPM_BUILD_ROOT" libdir="%{_libdir}" libexecdir="%{_libexecdir}"
69
70# FIXME: We might need to enable this part for backward compat with the
71# Red Hat / Fedora 'utempter' package:
72#
73# mkdir -p %{_sbindir}
74# ln -sf %{helperdir}/utempter %{_sbindir}/utempter
75
76
77# NOTE: Static lib intentionally disabled.
78rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%pre
84{
85    %{_sbindir}/groupadd -g 22 -r -f utmp || :
86    %{_sbindir}/groupadd -g 35 -r -f utempter || :
87}
88
89%post
90{
91    /sbin/ldconfig
92    for file in /var/log/wtmp /var/run/utmp ; do
93        if [ -f $file ]; then
94            chown root:utmp $file
95            chmod 664 $file
96        fi
97    done
98}
99
100%postun -p /sbin/ldconfig
101
102%if %{build_compat32}
103%post -n compat32-%{name} -p /sbin/ldconfig
104%postun -n compat32-%{name} -p /sbin/ldconfig
105%endif
106
107%files
108%defattr(-,root,root,-)
109%doc COPYING README
110%{_libdir}/libutempter.so.*
111%dir %attr(755,root,utempter) %{_libexecdir}/utempter
112%attr(2711,root,utmp) %{_libexecdir}/utempter/utempter
113# FIXME: If a symlink is needed for compat here, uncomment the code in the
114# install section and this as well:
115#%{_sbindir}/utempter
116
117%files devel
118%defattr(-,root,root,-)
119%{_includedir}/utempter.h
120%{_libdir}/libutempter.so
121
122%if %{build_compat32}
123%files -n compat32-%{name}
124%defattr(-,root,root)
125%{_libdir}/libutempter.so.*
126
127%files -n compat32-%{name}-devel
128%defattr(-,root,root)
129%{_libdir}/libutempter.so
130%endif
131
132%changelog
133* Sun Jul 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.5-3
134- initial build for Vine Linux
135- replaced utempter
136  * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 0.5.5-6vl2
137  - added compat32- packages for x86_64 architecture support
138  * Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.5-6vl1
139  - based on Fedora 0.5.5-6
140    * Mon Apr 19 2004 Mike A. Harris <mharris@redhat.com> 0.5.5-1
141    - [SECURITY] Fix CAN-2004-0233 utempter directory traversal symlink attack
142      issue for immediate erratum release.
143    - Build all-arch test package 0.5.5-1 in dist-fc2-scratch
144    * Mon Feb 23 2004 Mike A. Harris <mharris@redhat.com> 0.5.4-1
145    - Rewrote post install script to be a bit cleaner and rebuilt in rawhide to
146      pick up twaugh's chown change
147    - Added 'srpm-x' target to Makefile for package maintainer SRPM building
148    * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
149    - Use ':' instead of '.' as separator for chown.
150  * Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.3-2vl1
151  - based on Redhat Rawhide 0.5.3-2
152    * Fri May 30 2003 Mike A. Harris <mharris@redhat.com> 0.5.3-1
153    - Bump version and release and rebuild to strip debug info into .debuginfo
154      package, as the Red Hat Linux 9 package shipped unstripped (#91664)
155    - Updated license field to reflect dual license MIT style + LGPL
156    - Changed spec file Copyright tag to proper License tag
157    - Removed stupid crackrock "version" macro define
158    * Thu Jun 20 2002 Elliot Lee <sopwith@redhat.com> 0.5.2-9
159    - Don't strip binary
160    - Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
161    - added LGPL notice
162  * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-4vl2
163  - rebuild to remove rpmlib dependancy
164  * Tue May 29 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
165  - 0.5.2-4vl1
166  - rebuilt for Vine Linux
167
168* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.5-2
169- Autorebuild for GCC 4.3
170
171* Wed Nov 07 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
172- 1.1.5-1
173- version upgrade
174- fix #246063
175
176* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.1.4-4
177- Rebuild for build id
178
179* Thu Jul 27 2006 Mike A. Harris <mharris@redhat.com> 1.1.4-3.fc6
180- Create 'utempter' group with official allocated GID==35 (from setup package).
181
182* Tue Jul 25 2006 Mike A. Harris <mharris@redhat.com> 1.1.4-2.fc6
183- Removed usage of rpm macros inside the spec changelog (#200051)
184- Removed non-UTF-8 chars from changelog.
185
186* Mon Jul 24 2006 Mike A. Harris <mharris@redhat.com> 1.1.4-1.fc6
187- Initial build of Dimitry's libutempter replacement for Fedora Core.
188- Reworked the upstream spec file for Fedora packaging compliance.
189- Removed static lib subpackage as we dont ship those.
190
191* Fri Dec 09 2005 Dmitry V. Levin <ldv@altlinux.org> 1.1.4-alt1
192- Enabled almost all diagnostics supported by gcc and fixed all
193  issues found by gcc-3.4.4-alt3.
194- Added FreeBSD support, based on patches from Gentoo/FreeBSD.
195- Makefile:
196  + Fixed few portability issues reported by Gentoo developers.
197- libutempter: Linked with -Wl,-z,defs.
198- utempter:
199  + Fixed struct utmp initialization on 64-bit architectures
200    with 32-bit backwards compatibility enabled (like x86_64).
201  + Linked with -Wl,-z,now, i.e., marked it to tell the dynamic
202    linker to resolve all symbols when the program is started.
203    Suggested by Gentoo developers.
204
205* Thu Aug 18 2005 Dmitry V. Levin <ldv@altlinux.org> 1.1.3-alt1
206- Restricted list of global symbols exported by the library.
207- Updated FSF postal address.
208
209* Sun Sep 05 2004 Dmitry V. Levin <ldv@altlinux.org> 1.1.2-alt1
210- Added multilib support.
211
212* Fri Feb 14 2003 Dmitry V. Levin <ldv@altlinux.org> 1.1.1-alt1
213- iface.c: don't block SIGCHLD; redefine signal handler instead.
214
215* Mon Dec 23 2002 Dmitry V. Levin <ldv@altlinux.org> 1.1.0-alt1
216- Changed soname back to libutempter.so.0, introduced versioning.
217
218* Tue Sep 24 2002 Dmitry V. Levin <ldv@altlinux.org> 1.0.7-alt1
219- If helper execution fails, try saved group ID.
220
221* Tue May 21 2002 Dmitry V. Levin <ldv@altlinux.org> 1.0.6-alt1
222- New function: utempter_set_helper.
223
224* Mon Dec 10 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.5-alt1
225- iface.c: block SIGCHLD instead of redefine signal handler.
226
227* Wed Nov 21 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.4-alt1
228- utempter.h: do not use "__attribute ((unused))".
229
230* Tue Nov 13 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.3-alt1
231- Added compatibility declarations to ease upgrade of old applications.
232- Added small README file.
233- Corrected provides.
234
235* Thu Nov 08 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.2-alt1
236- Added compatibility library to ease upgrade of old applications.
237
238* Mon Nov 05 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.1-alt1
239- Indented code a bit (Solar request).
240
241* Mon Oct 15 2001 Dmitry V. Levin <ldv@alt-linux.org> 1.0.0-alt1
242- Rewritten the code completely.
243- Renamed to libutempter.
244- Corrected the package description.
245- FHSificated (yes, there are no more {_sbindir}/utempter).
246- Libificated.
247
248* Fri Oct 12 2001 Dmitry V. Levin <ldv@altlinux.ru> 0.5.2-alt4
249- {_libdir}/utempter sounds better so use it as helper directory.
250
251* Thu Oct 11 2001 Dmitry V. Levin <ldv@altlinux.ru> 0.5.2-alt3
252- Specfile cleanup.
253- Owl-compatible changes:
254  + added utempter group;
255  + utempter binary moved to {_libdir}/utempter.d,
256    owned by group utempter with 710 permissions.
257
258* Thu Jun 28 2001 Sergie Pugachev <fd_rag@altlinux.ru> 0.5.2-alt1
259- new version
260
261* Tue Dec 05 2000 AEN <aen@logic.ru>
262- build for RE
263
264* Tue Jul 25 2000 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.5.1-4mdk
265- BM
266
267* Fri May 19 2000 Pixel <pixel@mandrakesoft.com> 0.5.1-3mdk
268- add -devel
269- add soname
270- spec helper cleanup
271
272* Sat Apr 08 2000 Christopher Molnar <molnarc@mandrakesoft.com> 0.5.1-2mdk
273- changed group
274
275* Tue Oct 26 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
276- 0.5.1
277- fix utmp as group 22.
278- strip utempter.
279- defattr to root.
280
281* Thu Jun 10 1999 Bernhard Rosenkraenzer <bero@mandrakesoft.com>
282- Mandrake adaptions
283
284* Fri Jun  4 1999 Jeff Johnson <jbj@redhat.com>
285- ignore SIGCHLD while processing utmp.
Note: See TracBrowser for help on using the repository browser.