source: projects/specs/trunk/lib/libu/libuser/libuser-vl.spec @ 521

Revision 521, 18.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define WITH_SELINUX 0
2%define python %(python -c 'import sys;print(sys.version[0:3])')
3
4
5Name: libuser
6Version: 0.56.9
7Release: 3%{?_dist_release}
8Summary: A user and group account administration library.
9Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
10Group: System Environment/Base
11License: LGPL
12URL: https://fedorahosted.org/libuser/
13Source: libuser-%{version}.tar.bz2
14Patch0: libuser-selinux.patch
15BuildRoot: %{_tmppath}/%{name}-root
16BuildRequires: pam-devel
17BuildRequires: popt
18BuildRequires: python-devel
19BuildRequires: gtk-doc
20BuildRequires: linuxdoc-tools
21BuildRequires: pkgconfig
22BuildRequires: glib2-devel
23BuildRequires: popt-devel
24#BuildPrereq: cyrus-sasl-devel, openldap-devel
25
26%description
27The libuser library implements a standardized interface for manipulating
28and administering user and group accounts.  The library uses pluggable
29back-ends to interface to its data sources.
30
31Sample applications modeled after those included with the shadow password
32suite are included.
33
34%package devel
35Group: Development/Libraries
36Summary: Files needed for developing applications which use libuser.
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The libuser-devel package contains header files, static libraries, and other
41files useful for developing applications with libuser.
42
43%prep
44%setup -q
45%if %{WITH_SELINUX}
46#SELinux
47%patch0 -p1 -b .selinux
48%endif
49
50%build
51CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
52%configure \
53        --with-python-version=%{python} \
54        --with-python-path=%{_includedir}/python%{python} \
55        --with-html-dir=%{_datadir}/gtk-doc/html \
56        --with-pic
57make
58
59%clean
60rm -fr $RPM_BUILD_ROOT
61
62%install
63rm -fr $RPM_BUILD_ROOT
64make install DESTDIR=$RPM_BUILD_ROOT
65
66rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
67
68LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
69export LD_LIBRARY_PATH
70
71# Verify that all python modules load, just in case.
72pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
73python%{python} -c "import libuser"
74popd
75
76# remove .la
77rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
78rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
79         
80
81%find_lang %{name}
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87%files -f %{name}.lang
88%defattr(-,root,root)
89%doc AUTHORS COPYING NEWS README TODO docs/*.txt python/modules.txt
90%config(noreplace) %{_sysconfdir}/libuser.conf
91
92%attr(0755,root,root) %{_bindir}/*
93%attr(0755,root,root) %{_libdir}/python%{python}/site-packages/*.so
94%attr(0755,root,root) %{_libdir}/*.so.*
95%dir %attr(0755,root,root) %{_libdir}/%{name}
96%attr(0755,root,root) %{_libdir}/%{name}/*.so
97#%attr(0644,root,root) %{_libdir}/%{name}/*.la
98%attr(0755,root,root) %{_sbindir}/*
99
100%files devel
101%defattr(-,root,root)
102%attr(0755,root,root) %dir %{_includedir}/libuser
103%attr(0644,root,root) %{_includedir}/libuser/*
104#attr(0644,root,root) %{_libdir}/*.la
105%attr(0755,root,root) %{_libdir}/*.so
106#%attr(0644,root,root) %{_mandir}/man3/*
107%attr(0644,root,root) %{_mandir}/man5/*
108
109%attr(0644,root,root) %{_libdir}/pkgconfig/*
110
111%{_datadir}/gtk-doc/html/*
112%{_mandir}/man1/*
113
114%changelog
115* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
116- add BuildRequires: pkgconfig, glib2-devel, popt-devel
117
118* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
119- rebuild for python-2.6
120
121* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
122- new upstream release
123
124* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
125- rebuilt with python-2.5.2
126- removed *.la
127
128* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
129- applied new versioning policy
130
131* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
132- new upstream release
133
134* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
135- rebuild with python-2.4.1-0vl1
136
137* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
138- rebuild with python-2.3.3-0vl1
139
140* Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
141- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
142
143* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
144- resync to fedora
145
146* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
147- initial build for Vine Linux
148
149* Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
150- degrade gracefully
151- build with --with-pic and -fPIC
152- remove unpackaged man page
153
154* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
155- translation updates
156
157* Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
158- doc updates -- cvs tree moved
159- language updates
160- disallow weird characters in account names
161
162* Sun May 26 2002 Tim Powers <timp@redhat.com>
163- automated rebuild
164
165* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
166- files: ignore blank lines in files
167- libuser: disallow creation of accounts with names containing whitespace,
168  control characters, or non-ASCII characters
169
170* Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
171- refresh translations
172- fix a heap-corruption bug in the python bindings
173
174* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
175- bump version
176- refresh translations
177
178* Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
179- ldap: cache an entity's dn in the entity structure to try to speed things up
180
181* Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
182- rebuild in new environment
183
184* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
185- add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
186- translation refresh
187
188* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
189- fix python bindings of enumerateFull functions
190- adjust prompter wrapping to not error out on successful returns
191
192* Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
193- be more careful about printing error messages
194- fix refreshing after adding of accounts
195- ldap: try to use a search to convert names to DNs, and only fall back to
196  guessing if it turns up nothing
197- files: fix an off-by-one in removal of entries
198
199* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
200- refresh translations
201- fix admin() constructor comments in the python module
202
203* Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
204- automatically refresh entities after add, modify, setpass, removepass,
205  lock, and unlock operations
206- remove debug spewage when creating and removing mail spools
207- files: fix saving of multi-valued attributes
208- rename MEMBERUID attribute for groups to MEMBERNAME
209
210* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
211- files: fix bug in removals
212- ldap: revert attempts at being smart at startup time, because it makes UIs
213  very messy (up the three whole dialogs just to start the ldap stuff!)
214
215* Sun Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
216- fix thinko in dispatch routines
217
218* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
219- lgroupmod: fix thinko
220
221* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
222- rebuild in new environment
223
224* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
225- move shadow initialization for groups to the proper callback
226- rework locking in the files module to not require that files be writable
227
228* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
229- expose lu_strerror()
230- add various typedefs for types used by the library
231
232* Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
233- add removepass() functions
234
235* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
236- lchfn,lchsh,lpasswd - reorder PAM authentication calls
237- include API docs in the package
238
239* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
240- ldap: finish port to new API
241- sasl: finish port to new API (needs test)
242- libuser: don't commit object changes before passing data to service
243  functions which might need differing data sets to figure out what to
244  change (for example, ldap)
245
246* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
247- bind the internal mail spool creation/removal functions for python
248
249* Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
250- renamed the python module
251- revamped internals to use gobject's gvalues and gvaluearrays instead of
252  glists of cached strings
253- add enumeration-with-data functions to the C library
254
255* Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
256- require linuxdoc-tools instead of sgml-tools for rawhide
257
258* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
259- fixup build files to allow building for arbitrary versions of python
260
261* Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
262- link the python module against libpam
263- attempt to import the python modules at build-time to verify dependencies
264
265* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
266- fix a file-parsing bug that popped up in 0.29's mmap modifications
267
268* Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
269- quotaq: fix argument order when reading quota information
270- user_quota: set quota grace periods correctly
271- luseradd: never create home directories for system accounts
272
273* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
274- add da translation files
275- update translations
276
277* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
278- add an explicit build dependency on jade (for the docs)
279
280* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
281- HUP nscd on modifications
282- userutil.c: mmap files we're reading for probable speed gain
283- userutil.c: be conservative with the amount of random data we read
284- docs fixes
285
286* Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
287- apps: print usage on errors
288- lnewusers.c: initialize groups as groups, not users
289- lnewusers.c: set passwords for new accounts
290- luseradd.c: accept group names in addition to IDs for the -g flag
291- luseradd.c: allow the primary GID to be a preexisting group
292
293* Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
294- add ko translation files
295- files.c: fix a heap corruption bug in lock/unlock (#51750)
296- files.c: close a memory leak in reading of files
297
298* Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
299- files.c: remove implementation limits on lengths of lines
300
301* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
302- lusermod: change user name in groups the user is a member of during renames
303- lgroupmod: change primary GID for users who are in the group during renumbers
304- ldap.c: handle new attributes more gracefully if possible
305- add ru translation files
306
307* Tue Aug  7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
308- rename the quota source files to match the library, which clears up a
309  file conflict with older quota packages
310- add ja translation files
311
312* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com>
313- add lu_ent_clear_all() function
314
315* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
316- close up some memory leaks
317- add the ability to include resident versions of modules in the library
318
319* Wed Aug  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
320- fix incorrect Py_BuildValue invocation in python module
321
322* Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
323- stop leaking descriptors in the files module
324- speed up user creation by reordering some checks for IDs being in use
325- update the shadowLastChanged attribute when we set a password
326- adjust usage of getXXXXX_r where needed
327- fix assorted bugs in python binding which break prompting
328
329* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
330- install sv translation
331- make lpasswd prompt for passwords when none are given on the command line
332- make sure all user-visible strings are marked for translation
333- clean up some user-visible strings
334- require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
335
336* Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
337- print uids and gids of users and names in lid app
338- fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
339- implement enumerate_by_group and enumerate_by_user in ldap module
340- fix id-based lookups in the ldap module
341- implement islocked() method in ldap module
342- implement setpass() method in ldap module
343- add lchfn and lchsh apps
344- add %%d substitution to libuser.conf
345
346* Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
347- finish adding a sasldb module which manipulates a sasldb file
348- add users_enumerate_by_group and groups_enumerate_by_users
349
350* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
351- luserdel: remove the user's primary group if it has the same name as
352  the user and has no members configured (-G disables)
353- fixup some configure stuff to make libuser.conf get generated correctly
354  even when execprefix isn't specified
355
356* Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
357- only call the auth module when setting passwords (oops)
358- use GTrees instead of GHashTables for most internal tables
359- files: complain properly about unset attributes
360- files: group passwords are single-valued, not multiple-valued
361- add lpasswd app, make sure all apps start up popt with the right names
362
363* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
364- actually make the new optional arguments optional
365- fix lu_error_new() to actually report errors right
366- fix part of the python bindings
367- include tools in the binary package again
368- fixup modules so that password-changing works right again
369- add a "key" field to prompt structures for use by apps which like to
370  cache these things
371- add an optional "mvhomedir" argument to userModify (python)
372
373* Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
374- finish home directory population
375- implement home directory moving
376- change entity get semantics in the python bindings to allow default values for .get()
377- add lu_ent_has(), and a python has_key() method to Entity types
378- don't include tools in the binary package
379- add translated strings
380
381* Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
382- lib/user.c: catch and ignore errors when running stacks
383- lusermod: fix slightly bogus help messages
384- luseradd: when adding a user and group, use the gid of the group
385  instead of the user's uid as the primary group
386- properly set the password field in user accounts created using
387  auth-only auth modules (shadow needs "x" instead of "!!")
388- implement home directory removal, start on population
389
390* Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
391- fix group password setting in the files module
392- setpass affects both auth and info, so run both stacks
393
394* Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
395- make the testbed apps noinst
396
397* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
398- fix errors due to uninitialized fields in the python bindings
399- add kwargs support to all python wrappers
400- add a mechanism for passing arguments to python callbacks
401
402* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
403- stub out the krb5 and ldap modules so that they'll at least compile again
404 
405* Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
406- don't bail when writing empty fields to colon-delimited files
407- use permissions of the original file when making backup files instead of 0600
408
409* Fri Jul  6 2001 Nalin Dahyabhai <nalin@redhat.com>
410- finish implementing is_locked methods in files/shadow module
411- finish cleanup of the python bindings
412- allow conditional builds of modules so that we can build without
413  all of the prereqs for all of the modules
414
415* Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
416- add error reporting facilities
417- split public header into pieces by function
418- backend cleanups
419
420* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
421- make %%{name}-devel require %%{name} and not %%{name}-devel
422
423* Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
424- clean up quota bindings some more
425- finish most of the ldap bindings
426- fix a subtle bug in the files module that would show up when renaming accounts
427- fix mapping methods for entity structures in python
428
429* Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
430- get bindings for prompts to work correctly
431- clean up some of the add/remove semantics (set source on add)
432- ldap: implement enumeration
433- samples/enum: fix the argument order
434
435* Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
436- clean up python bindings for quota
437
438* Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
439- finish up python bindings for quota support
440
441* Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
442- finish up quota support libs
443
444* Fri Jun  8 2001 Nalin Dahyabhai <nalin@redhat.com>
445- start quota support library to get some type safety
446
447* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
448- start looking at quota manipulation
449
450* Wed Jun  6 2001 Nalin Dahyabhai <nalin@redhat.com>
451- add functions for enumerating users and groups, optionally per-module
452- lusermod.c: -s should specify the shell, not the home directory
453
454* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
455- finish the python bindings and verify that the file backend works again
456
457* Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
458- remove a redundant check which was breaking modifications
459
460* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
461- finish adding setpass methods
462
463* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
464- get a start on some Python bindings
465
466* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
467- make binary-incompatible change in headers
468
469* Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
470- add doxygen docs and a "doc" target for them
471
472* Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
473- add a "quiet" prompter
474- add --interactive flag to sample apps and default to using quiet prompter
475- ldap: attempt a "self" bind if other attempts fail
476- krb5: connect to the password-changing service if the user principal has
477  the NULL instance
478
479* Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
480- the great adding-of-the-copyright-statements
481- take more care when creating backup files in the files module
482
483* Wed Jan  3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
484- add openldap-devel as a buildprereq
485- krb5: use a continuous connection
486- krb5: add "realm" config directive
487- ldap: use a continuous connection
488- ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
489- ldap: actually finish the account deletion function
490- ldap: don't send cleartext passwords to the directory
491- fix naming attribute for users (should be uid, not gid)
492- refine the search-by-id,convert-to-name,search-by-name logic
493- fix handling of defaults when the config file is read in but contains no value
494- implement an LDAP information store
495- try to clean up module naming with libtool
496- luseradd: pass plaintext passwords along
497- luseradd: use symbolic attribute names instead of hard-coded
498- lusermod: pass plaintext passwords along
499- lgroupadd: pass plaintext passwords along
500- lgroupmod: pass plaintext passwords along
501- add libuser as a dependency of libuser-devel
502
503* Tue Jan  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
504- initial packaging
Note: See TracBrowser for help on using the repository browser.