source: projects/specs/trunk/lib/libu/libuser/libuser-vl.spec @ 12335

Revision 12335, 18.8 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

chkconfig-1.3.61-3

diffutils-3.7-1

findutils-4.7.0-1

libmpc-1.1.0-1

libuser-0.62-1

libutempter-1.1.6-2

mpfr-4.0.2-1

mpfr3-3.1.6-1

psmisc-23.2-1

sed-4.8-1

shadow-utils-4.8-1

tcsh-6.22.02-1

texinfo-6.7-1

usermode-1.109-2

Line 
1%define WITH_SELINUX 0
2%define python %(python -c 'import sys;print(sys.version[0:3])')
3
4
5Name: libuser
6Version: 0.62
7Release: 1%{?_dist_release}
8Summary: A user and group account administration library.
9Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
10Group: System Environment/Base
11
12Distribution: Vine Linux
13Vendor: Project Vine
14
15License: LGPL
16URL: https://pagure.io/libuser
17Source: libuser-%{version}.tar.xz
18Patch0: libuser-selinux.patch
19BuildRoot: %{_tmppath}/%{name}-root
20BuildRequires: pam-devel
21BuildRequires: popt
22BuildRequires: python-devel
23BuildRequires: gtk-doc
24BuildRequires: linuxdoc-tools
25BuildRequires: pkgconfig
26BuildRequires: glib2-devel
27BuildRequires: popt-devel
28#BuildPrereq: cyrus-sasl-devel, openldap-devel
29
30%description
31The libuser library implements a standardized interface for manipulating
32and administering user and group accounts.  The library uses pluggable
33back-ends to interface to its data sources.
34
35Sample applications modeled after those included with the shadow password
36suite are included.
37
38%package devel
39Group: Development/Libraries
40Summary: Files needed for developing applications which use libuser.
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The libuser-devel package contains header files, static libraries, and other
45files useful for developing applications with libuser.
46
47%prep
48%setup -q
49%if %{WITH_SELINUX}
50#SELinux
51%patch0 -p1 -b .selinux
52%endif
53
54
55%build
56CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
57%configure \
58        --with-python-version=%{python} \
59        --with-python-path=%{_includedir}/python%{python} \
60        --with-html-dir=%{_datadir}/gtk-doc/html \
61        --with-pic
62make
63
64%clean
65rm -fr $RPM_BUILD_ROOT
66
67%install
68rm -fr $RPM_BUILD_ROOT
69make install DESTDIR=$RPM_BUILD_ROOT
70
71rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
72
73LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
74export LD_LIBRARY_PATH
75
76# Verify that all python modules load, just in case.
77pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
78python%{python} -c "import libuser"
79popd
80
81# remove .la
82rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
83rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
84         
85
86%find_lang %{name}
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%files -f %{name}.lang
93%defattr(-,root,root)
94%license COPYING
95%doc AUTHORS NEWS README TODO docs/*.txt python/modules.txt
96%config(noreplace) %{_sysconfdir}/libuser.conf
97
98%attr(0755,root,root) %{_bindir}/*
99%attr(0755,root,root) %{python_sitearch}/*.so
100%attr(0755,root,root) %{_libdir}/*.so.*
101%dir %attr(0755,root,root) %{_libdir}/%{name}
102%attr(0755,root,root) %{_libdir}/%{name}/*.so
103#%attr(0644,root,root) %{_libdir}/%{name}/*.la
104%attr(0755,root,root) %{_sbindir}/*
105
106%files devel
107%defattr(-,root,root)
108%attr(0755,root,root) %dir %{_includedir}/libuser
109%attr(0644,root,root) %{_includedir}/libuser/*
110#attr(0644,root,root) %{_libdir}/*.la
111%attr(0755,root,root) %{_libdir}/*.so
112#%attr(0644,root,root) %{_mandir}/man3/*
113%attr(0644,root,root) %{_mandir}/man5/*
114
115%attr(0644,root,root) %{_libdir}/pkgconfig/*
116
117%{_datadir}/gtk-doc/html/*
118%{_mandir}/man1/*
119
120%changelog
121* Tue Mar 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62-1
122- new upstream release.
123
124* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.60-1
125- new upstream release
126
127* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-5
128- rebuild with python-2.7.2
129
130* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-4
131- rebuild with rpm-4.8.1 for pkg-config file
132
133* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
134- add BuildRequires: pkgconfig, glib2-devel, popt-devel
135
136* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
137- rebuild for python-2.6
138
139* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
140- new upstream release
141
142* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
143- rebuilt with python-2.5.2
144- removed *.la
145
146* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
147- applied new versioning policy
148
149* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
150- new upstream release
151
152* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
153- rebuild with python-2.4.1-0vl1
154
155* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
156- rebuild with python-2.3.3-0vl1
157
158* Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
159- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
160
161* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
162- resync to fedora
163
164* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
165- initial build for Vine Linux
166
167* Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
168- degrade gracefully
169- build with --with-pic and -fPIC
170- remove unpackaged man page
171
172* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
173- translation updates
174
175* Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
176- doc updates -- cvs tree moved
177- language updates
178- disallow weird characters in account names
179
180* Sun May 26 2002 Tim Powers <timp@redhat.com>
181- automated rebuild
182
183* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
184- files: ignore blank lines in files
185- libuser: disallow creation of accounts with names containing whitespace,
186  control characters, or non-ASCII characters
187
188* Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
189- refresh translations
190- fix a heap-corruption bug in the python bindings
191
192* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
193- bump version
194- refresh translations
195
196* Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
197- ldap: cache an entity's dn in the entity structure to try to speed things up
198
199* Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
200- rebuild in new environment
201
202* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
203- add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
204- translation refresh
205
206* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
207- fix python bindings of enumerateFull functions
208- adjust prompter wrapping to not error out on successful returns
209
210* Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
211- be more careful about printing error messages
212- fix refreshing after adding of accounts
213- ldap: try to use a search to convert names to DNs, and only fall back to
214  guessing if it turns up nothing
215- files: fix an off-by-one in removal of entries
216
217* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
218- refresh translations
219- fix admin() constructor comments in the python module
220
221* Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
222- automatically refresh entities after add, modify, setpass, removepass,
223  lock, and unlock operations
224- remove debug spewage when creating and removing mail spools
225- files: fix saving of multi-valued attributes
226- rename MEMBERUID attribute for groups to MEMBERNAME
227
228* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
229- files: fix bug in removals
230- ldap: revert attempts at being smart at startup time, because it makes UIs
231  very messy (up the three whole dialogs just to start the ldap stuff!)
232
233* Sat Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
234- fix thinko in dispatch routines
235
236* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
237- lgroupmod: fix thinko
238
239* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
240- rebuild in new environment
241
242* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
243- move shadow initialization for groups to the proper callback
244- rework locking in the files module to not require that files be writable
245
246* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
247- expose lu_strerror()
248- add various typedefs for types used by the library
249
250* Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
251- add removepass() functions
252
253* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
254- lchfn,lchsh,lpasswd - reorder PAM authentication calls
255- include API docs in the package
256
257* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
258- ldap: finish port to new API
259- sasl: finish port to new API (needs test)
260- libuser: don't commit object changes before passing data to service
261  functions which might need differing data sets to figure out what to
262  change (for example, ldap)
263
264* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
265- bind the internal mail spool creation/removal functions for python
266
267* Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
268- renamed the python module
269- revamped internals to use gobject's gvalues and gvaluearrays instead of
270  glists of cached strings
271- add enumeration-with-data functions to the C library
272
273* Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
274- require linuxdoc-tools instead of sgml-tools for rawhide
275
276* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
277- fixup build files to allow building for arbitrary versions of python
278
279* Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
280- link the python module against libpam
281- attempt to import the python modules at build-time to verify dependencies
282
283* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
284- fix a file-parsing bug that popped up in 0.29's mmap modifications
285
286* Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
287- quotaq: fix argument order when reading quota information
288- user_quota: set quota grace periods correctly
289- luseradd: never create home directories for system accounts
290
291* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
292- add da translation files
293- update translations
294
295* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
296- add an explicit build dependency on jade (for the docs)
297
298* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
299- HUP nscd on modifications
300- userutil.c: mmap files we're reading for probable speed gain
301- userutil.c: be conservative with the amount of random data we read
302- docs fixes
303
304* Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
305- apps: print usage on errors
306- lnewusers.c: initialize groups as groups, not users
307- lnewusers.c: set passwords for new accounts
308- luseradd.c: accept group names in addition to IDs for the -g flag
309- luseradd.c: allow the primary GID to be a preexisting group
310
311* Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
312- add ko translation files
313- files.c: fix a heap corruption bug in lock/unlock (#51750)
314- files.c: close a memory leak in reading of files
315
316* Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
317- files.c: remove implementation limits on lengths of lines
318
319* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
320- lusermod: change user name in groups the user is a member of during renames
321- lgroupmod: change primary GID for users who are in the group during renumbers
322- ldap.c: handle new attributes more gracefully if possible
323- add ru translation files
324
325* Tue Aug  7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
326- rename the quota source files to match the library, which clears up a
327  file conflict with older quota packages
328- add ja translation files
329
330* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com>
331- add lu_ent_clear_all() function
332
333* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
334- close up some memory leaks
335- add the ability to include resident versions of modules in the library
336
337* Wed Aug  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
338- fix incorrect Py_BuildValue invocation in python module
339
340* Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
341- stop leaking descriptors in the files module
342- speed up user creation by reordering some checks for IDs being in use
343- update the shadowLastChanged attribute when we set a password
344- adjust usage of getXXXXX_r where needed
345- fix assorted bugs in python binding which break prompting
346
347* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
348- install sv translation
349- make lpasswd prompt for passwords when none are given on the command line
350- make sure all user-visible strings are marked for translation
351- clean up some user-visible strings
352- require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
353
354* Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
355- print uids and gids of users and names in lid app
356- fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
357- implement enumerate_by_group and enumerate_by_user in ldap module
358- fix id-based lookups in the ldap module
359- implement islocked() method in ldap module
360- implement setpass() method in ldap module
361- add lchfn and lchsh apps
362- add %%d substitution to libuser.conf
363
364* Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
365- finish adding a sasldb module which manipulates a sasldb file
366- add users_enumerate_by_group and groups_enumerate_by_users
367
368* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
369- luserdel: remove the user's primary group if it has the same name as
370  the user and has no members configured (-G disables)
371- fixup some configure stuff to make libuser.conf get generated correctly
372  even when execprefix isn't specified
373
374* Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
375- only call the auth module when setting passwords (oops)
376- use GTrees instead of GHashTables for most internal tables
377- files: complain properly about unset attributes
378- files: group passwords are single-valued, not multiple-valued
379- add lpasswd app, make sure all apps start up popt with the right names
380
381* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
382- actually make the new optional arguments optional
383- fix lu_error_new() to actually report errors right
384- fix part of the python bindings
385- include tools in the binary package again
386- fixup modules so that password-changing works right again
387- add a "key" field to prompt structures for use by apps which like to
388  cache these things
389- add an optional "mvhomedir" argument to userModify (python)
390
391* Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
392- finish home directory population
393- implement home directory moving
394- change entity get semantics in the python bindings to allow default values for .get()
395- add lu_ent_has(), and a python has_key() method to Entity types
396- don't include tools in the binary package
397- add translated strings
398
399* Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
400- lib/user.c: catch and ignore errors when running stacks
401- lusermod: fix slightly bogus help messages
402- luseradd: when adding a user and group, use the gid of the group
403  instead of the user's uid as the primary group
404- properly set the password field in user accounts created using
405  auth-only auth modules (shadow needs "x" instead of "!!")
406- implement home directory removal, start on population
407
408* Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
409- fix group password setting in the files module
410- setpass affects both auth and info, so run both stacks
411
412* Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
413- make the testbed apps noinst
414
415* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
416- fix errors due to uninitialized fields in the python bindings
417- add kwargs support to all python wrappers
418- add a mechanism for passing arguments to python callbacks
419
420* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
421- stub out the krb5 and ldap modules so that they'll at least compile again
422 
423* Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
424- don't bail when writing empty fields to colon-delimited files
425- use permissions of the original file when making backup files instead of 0600
426
427* Fri Jul  6 2001 Nalin Dahyabhai <nalin@redhat.com>
428- finish implementing is_locked methods in files/shadow module
429- finish cleanup of the python bindings
430- allow conditional builds of modules so that we can build without
431  all of the prereqs for all of the modules
432
433* Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
434- add error reporting facilities
435- split public header into pieces by function
436- backend cleanups
437
438* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
439- make %%{name}-devel require %%{name} and not %%{name}-devel
440
441* Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
442- clean up quota bindings some more
443- finish most of the ldap bindings
444- fix a subtle bug in the files module that would show up when renaming accounts
445- fix mapping methods for entity structures in python
446
447* Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
448- get bindings for prompts to work correctly
449- clean up some of the add/remove semantics (set source on add)
450- ldap: implement enumeration
451- samples/enum: fix the argument order
452
453* Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
454- clean up python bindings for quota
455
456* Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
457- finish up python bindings for quota support
458
459* Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
460- finish up quota support libs
461
462* Fri Jun  8 2001 Nalin Dahyabhai <nalin@redhat.com>
463- start quota support library to get some type safety
464
465* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
466- start looking at quota manipulation
467
468* Wed Jun  6 2001 Nalin Dahyabhai <nalin@redhat.com>
469- add functions for enumerating users and groups, optionally per-module
470- lusermod.c: -s should specify the shell, not the home directory
471
472* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
473- finish the python bindings and verify that the file backend works again
474
475* Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
476- remove a redundant check which was breaking modifications
477
478* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
479- finish adding setpass methods
480
481* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
482- get a start on some Python bindings
483
484* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
485- make binary-incompatible change in headers
486
487* Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
488- add doxygen docs and a "doc" target for them
489
490* Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
491- add a "quiet" prompter
492- add --interactive flag to sample apps and default to using quiet prompter
493- ldap: attempt a "self" bind if other attempts fail
494- krb5: connect to the password-changing service if the user principal has
495  the NULL instance
496
497* Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
498- the great adding-of-the-copyright-statements
499- take more care when creating backup files in the files module
500
501* Wed Jan  3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
502- add openldap-devel as a buildprereq
503- krb5: use a continuous connection
504- krb5: add "realm" config directive
505- ldap: use a continuous connection
506- ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
507- ldap: actually finish the account deletion function
508- ldap: don't send cleartext passwords to the directory
509- fix naming attribute for users (should be uid, not gid)
510- refine the search-by-id,convert-to-name,search-by-name logic
511- fix handling of defaults when the config file is read in but contains no value
512- implement an LDAP information store
513- try to clean up module naming with libtool
514- luseradd: pass plaintext passwords along
515- luseradd: use symbolic attribute names instead of hard-coded
516- lusermod: pass plaintext passwords along
517- lgroupadd: pass plaintext passwords along
518- lgroupmod: pass plaintext passwords along
519- add libuser as a dependency of libuser-devel
520
521* Tue Jan  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
522- initial packaging
Note: See TracBrowser for help on using the repository browser.