source: projects/specs/trunk/lib/libt/libtorrent-rasterbar/libtorrent-rasterbar-vl.spec @ 11402

Revision 11402, 13.3 KB checked in by ara_t, 6 years ago (diff)

libtorrent-rasterbar: update to 1.1.6

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:    libtorrent-rasterbar
5Version: 1.1.6
6Release: 1%{?_dist_release}
7Summary: A C++ BitTorrent library aiming to be the best alternative
8Summary(ja): 最良の代替手段となることを目指す C++ BitTorrent ライブラリ
9
10Group:   System Environment/Libraries
11License: BSD
12URL:     http://www.rasterbar.com/products/libtorrent/
13
14Source0: http://downloads.sourceforge.net/libtorrent/libtorrent-rasterbar-%{version}.tar.gz
15# https://github.com/arvidn/libtorrent/releases/download/libtorrent-1_1/libtorrent-rasterbar-%{version}.tar.gz
16
17Source1: %{name}-COPYING.Boost
18Source2: %{name}-COPYING.zlib
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires: asio-devel
23BuildRequires: libboost-devel libboost-filesystem libboost-program-options libboost-chrono
24BuildRequires: libboost-python libboost-regex libboost-system libboost-thread libboost-random
25BuildRequires: libtool
26BuildRequires: python-devel
27BuildRequires: python-setuptools
28BuildRequires: zlib-devel
29## Necessary for 'rename'...
30BuildRequires: util-linux
31
32## The following is taken from it's website listing...mostly.
33%description
34%{name} is a C++ library that aims to be a good alternative to all
35the other BitTorrent implementations around. It is a library and not a full
36featured client, although it comes with a few working example clients.
37
38Its main goals are to be very efficient (in terms of CPU and memory usage) as
39well as being very easy to use both as a user and developer.
40
41
42%package  devel
43Summary: Development files for %{name}
44Summary(ja): %{name} の開発ファイル
45Group:    Development/Libraries
46License:  BSD and zlib and Boost
47Requires: %{name} = %{version}-%{release}
48Requires: pkgconfig
49## Same include directory. :(
50Conflicts:  libtorrent-devel
51## Needed for various headers used via #include directives...
52Requires: asio-devel
53Requires: libboost-devel
54Requires: openssl-devel
55
56%description  devel
57The %{name}-devel package contains libraries and header files for
58developing applications that use %{name}.
59
60The various source and header files included in this package are licensed
61under the revised BSD, zlib/libpng, and Boost Public licenses. See the various
62COPYING files in the included documentation for the full text of these
63licenses, as well as the comments blocks in the source code for which license
64a given source or header file is released under.
65
66
67%package examples
68Summary: Example clients using %{name}
69Summary(ja): %{name} で使用する模範クライアント
70Group:   Applications/Internet
71License: BSD
72Requires:%{name} = %{version}-%{release}
73
74%description examples
75The %{name}-examples package contains example clients which intend to
76show how to make use of its various features. (Due to potential
77namespace conflicts, a couple of the examples had to be renamed. See the
78included documentation for more details.)
79
80
81%package python
82Summary: Python bindings for %{name}
83Summary(ja): %{name} の Python バインディング
84Group:    System Environment/Libraries
85License:  Boost
86Requires: %{name} = %{version}-%{release}
87
88%description python
89The %{name}-python package contains Python language bindings (the 'libtorrent'
90module) that allow it to be used from within Python applications.
91
92
93%prep
94%setup -q -n "libtorrent-rasterbar-%{version}"
95
96## The RST files are the sources used to create the final HTML files; and are
97## not needed.
98%{__rm} -f docs/*.rst
99
100## Ensure that we get the licenses installed appropriately.
101%{__install} -p -m 0644 COPYING COPYING.BSD
102%{__install} -p -m 0644 %{SOURCE1} COPYING.Boost
103%{__install} -p -m 0644 %{SOURCE2} COPYING.zlib
104
105## Finally, ensure that everything is UTF-8, as it should be.
106iconv -t UTF-8 -f ISO_8859-15 AUTHORS -o AUTHORS.iconv
107%{__mv} AUTHORS.iconv AUTHORS
108
109
110%build
111%configure --disable-static \
112           --enable-examples \
113           --enable-tests \
114           --enable-python-binding \
115           CXXFLAGS="-std=c++11"
116
117# ## Use the system libtool to ensure that we don't get unnecessary RPATH
118# ## hacks in our final build.
119# %{__make} %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
120%{__make} %{?_smp_mflags}
121
122
123%install
124%{__rm} -rf %{buildroot}
125
126# ## Ensure that we preserve our timestamps properly.
127# export CPPROG="%{__cp} -p"
128# %{__make} install DESTDIR=%{buildroot} INSTALL="%{__install} -c -p"
129%{__make} install DESTDIR=%{buildroot}
130%{__rm} %{buildroot}%{_libdir}/*.la
131
132## Do the renaming due to the somewhat limited %%_bindir namespace.
133rename client torrent_client %{buildroot}%{_bindir}/*
134
135%check
136%{__make} check
137
138%clean
139%{__rm} -rf %{buildroot}
140
141%post -p %{_syssbindir}/ldconfig
142
143%postun -p %{_syssbindir}/ldconfig
144
145
146%files
147%defattr(-,root,root,-)
148%doc AUTHORS ChangeLog COPYING
149%{_libdir}/libtorrent-rasterbar.so.*
150
151%files  devel
152%defattr(-,root,root,-)
153%doc COPYING.Boost COPYING.BSD COPYING.zlib docs/
154%{_libdir}/pkgconfig/libtorrent-rasterbar.pc
155%{_includedir}/libtorrent/
156%{_libdir}/libtorrent-rasterbar.so
157
158%files examples
159%{_bindir}/bt_get*
160%{_bindir}/*torrent*
161%{_bindir}/connection_tester
162#%{_bindir}/enum_if
163#%{_bindir}/fragmentation_test
164#%{_bindir}/parse_hash_fails
165# %{_bindir}/parse_request_log
166# %{_bindir}/rss_reader
167%{_bindir}/stats_counters
168%{_bindir}/upnp_test
169#%{_bindir}/utp_test
170
171%files python
172%defattr(-,root,root,-)
173%doc AUTHORS ChangeLog COPYING.Boost bindings/python/{simple_,}client.py
174%{python_sitearch}/python_libtorrent-%{version}-py?.?.egg-info
175%{python_sitearch}/libtorrent.so
176
177
178%changelog
179* Thu Jan 18 2018 Toshiaki Ara <ara_t@384.jp> - 1.1.6-1
180- new upstream release
181- add configure option: --enable-tests and CXXFLAGS="-std=c++11"
182- delete old comments
183
184* Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.9-2
185- rebuild with gcc-5.4.0
186
187* Tue Jun 14 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.9-1
188- new upstream release
189- added Buildrequires: libboost-chrono, libboost-random
190- deleted --with-zlib=system in %%configure
191- fixed -examples %%files
192
193* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.13-3
194- rebuild with openssl-1.0.2
195
196* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.16.13-2
197- moved python subpackage to System Environment/Libraries Group
198
199* Sun Jan 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16.13-1
200- new upstream release
201
202* Mon May 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16.9-1
203- new upstream release
204
205* Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.10-1
206- new upstream release
207- changed BuildRequires: util-linux-ng to util-linux
208
209* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 0.15.4-3
210- rebuilt with libboost-1.45.0
211
212* Mon Jan 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-2
213- rebuilt with openssl-1.0.0c
214- deleted unrecognized configure option (--with-asio)
215
216* Tue Oct 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-1
217- new upstream release
218
219* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.3-2
220- rebuild with rpm-4.8.1 for pkg-config file
221
222* Tue Sep 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.3-1
223- new upstream release
224
225* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.2-1
226- new upstream release
227
228* Sun Jul 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-1
229- new upstream release
230
231* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.0-1
232- new upstream release
233
234* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.9-1
235- new upstream release
236- applied new naming policy to spec
237
238* Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 0.14.8-2
239- rebuilt with new toolchain, python-2.6.4-3
240
241* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.8-1
242- new upstream release
243
244* Thu Dec 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.7-1
245- new upstream release
246
247* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.6-1
248- initial build for VineSeed
249
250* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.14.4-3
251- rebuilt with new openssl
252
253* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.4-2
254- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
255
256* Tue Jun 02 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.4-1
257- Update to new upstream release (0.14.4).
258- Drop outdated Boost patch.
259
260* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-2
261- Rebuild for the Boost 1.39.0 update.
262
263* Mon Apr 27 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-1
264- Update to new upstream bug-fix release (0.14.3).
265
266* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.2-2
267- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
268
269* Fri Feb 20 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.2-1
270- Update to new upstream bug-fix release (0.14.2)
271- Drop Python 2.6 and configure fix patches (fixed upstream):
272  - python26.patch
273  - configure-dont-use-locate.patch
274
275* Fri Jan 16 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-2
276- Rebuild for the soname bump in openssl-0.9.8j
277
278* Mon Jan 05 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-1
279- Update to new upstream release (0.14.1)
280- Add asio-devel as runtime dependency for the devel subpackage (#478589)
281- Add patch to build with Python 2.6:
282  + python26.patch
283- Add patch to make the configure script use the proper python include
284  directory instead of calling locate, as that can cause failures in a chroot
285  with no db file (and is a bit silly in the first place):
286  + configure-dont-use-locate.patch
287- Drop manual setup.py for building the python module (fixed upstream):
288  - setup.py
289- Update Source0 URL back to SourceForge's hosting.
290- Reenable the examples, since the Makefiles are fixed.
291
292* Fri Dec 19 2008 Petr Machata <pmachata@redhat.com> - 0.13.1-7
293- Rebuild for boost-1.37.0.
294
295* Wed Dec 17 2008 Benjamin Kosnik  <bkoz@redhat.com> - 0.13.1-6
296- Rebuild for boost-1.37.0.
297
298* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-5
299- Fix locations for Python 2.6
300
301* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-4
302- Rebuild for Python 2.6
303
304* Thu Nov 20 2008 Peter Gordon <peter@thecodergeek.com>
305- Update Source0 URL, for now.
306
307* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.13.1-3
308- fix license tag
309
310* Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-2
311- Add python bindings in a -python subpackage.
312
313* Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-1
314- Update to new upstream release (0.13.1): Contains an incompatible ABI/API
315  bump.
316- Drop GCC 4.3 patch (fixed upstream):
317  - gcc43.patch
318- Disable building the examples for now. (Attempted builds fail due to missing
319  Makefile support.)
320- Drop the source permissions and pkgconfig file tweaks (fixed upstream).
321
322* Sat Feb 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.12.1-1
323- Update to new upstream bug-fix release (0.12.1)
324- Rebuild for GCC 4.3
325- Drop security fix patch (merged upstream):
326  - svn1968-bdecode_recursive-security-fix.patch
327- Add GCC 4.3 build fixes (based on patch from Adel Gadllah, bug 432778):
328  + gcc43.patch
329
330* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.12-3
331- Add upstream patch (changeset 1968) to fix potential security vulnerability:
332  malformed messages passed through the bdecode_recursive routine could cause
333  a potential stack overflow.
334  + svn1968-bdecode_recursive-security-fix.patch
335
336* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
337- Rebuild against new Boost libraries.
338
339* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
340- Update to new upstream release (0.12 Final)
341- Split examples into a subpackage. Applications that use rb_libtorrent
342  don't need the example binaries installed; and splitting the package in this
343  manner is a bit more friendly to multilib environments. 
344
345* Sun Mar 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-0.rc1
346- Update to new upstream release (0.12 RC).
347- Forcibly use the system libtool to ensure that we remove any RPATH hacks.
348
349* Sun Jan 28 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-5
350- Fix installed pkgconfig file: Strip everything from Libs except for
351  '-ltorrent', as its [libtorrent's] DSO will ensure proper linking to other
352  needed libraries such as zlib and boost_thread. (Thanks to Michael Schwendt
353  and Mamoru Tasaka; bug #221372)
354
355* Sat Jan 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-4
356- Clarify potential licensing issues in the -devel subpackage:
357  + COPYING.zlib
358  + COPYING.Boost
359- Add my name in the Fedora-specific documentation (README-renames.Fedora) and
360  fix some spacing issues in it.
361- Strip the @ZLIB@ (and thus, the extra '-lz' link option) from the installed
362  pkgconfig file, as that is only useful when building a statically-linked
363  libtorrent binary.
364- Fix conflict: The -devel subpackage should conflict with the -devel
365  subpackage of libtorrent, not the main package.
366- Preserve timestamps in %%install.
367
368* Wed Jan 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-3
369- Fix License (GPL -> BSD)
370- Don't package RST (docs sources) files.
371- Only make the -devel subpackage conflict with libtorrent-devel.
372- Rename some of the examples more appropriately; and add the
373  README-renames.Fedora file to %%doc which explains this.
374
375* Fri Jan 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-2
376- Add Requires: pkgconfig to the -devel subpackage since it installs a .pc
377  file.
378
379* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
380- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.