source: projects/specs/trunk/lib/libt/libtorrent-rasterbar/libtorrent-rasterbar-vl.spec @ 10370

Revision 10370, 13.9 KB checked in by kudoh, 8 years ago (diff)

new upstream release

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           libtorrent-rasterbar
5Version:        1.0.9
6Release:        1%{?_dist_release}
7Summary:        A C++ BitTorrent library aiming to be the best alternative
8Summary(ja):    最良の代替手段となることを目指す C++ BitTorrent ライブラリ
9
10Group:          System Environment/Libraries
11License:        BSD
12URL:            http://www.rasterbar.com/products/libtorrent/
13
14Source0:        http://downloads.sourceforge.net/libtorrent/libtorrent-rasterbar-%{version}.tar.gz
15# https://github.com/arvidn/libtorrent/releases/download/libtorrent-1_1/libtorrent-rasterbar-%{version}.tar.gz
16
17Source1:        %{name}-COPYING.Boost
18Source2:        %{name}-COPYING.zlib
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  asio-devel
23BuildRequires:  libboost-devel libboost-filesystem libboost-program-options libboost-chrono
24BuildRequires:  libboost-python libboost-regex libboost-system libboost-thread libboost-random
25BuildRequires:  libtool
26BuildRequires:  python-devel
27BuildRequires:  python-setuptools
28BuildRequires:  zlib-devel
29## Necessary for 'rename'...
30BuildRequires:  util-linux
31
32## The following is taken from it's website listing...mostly.
33%description
34%{name} is a C++ library that aims to be a good alternative to all
35the other BitTorrent implementations around. It is a library and not a full
36featured client, although it comes with a few working example clients.
37
38Its main goals are to be very efficient (in terms of CPU and memory usage) as
39well as being very easy to use both as a user and developer.
40
41
42%package        devel
43Summary:        Development files for %{name}
44Summary(ja):    %{name} の開発ファイル
45Group:          Development/Libraries
46License:        BSD and zlib and Boost
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig
49## Same include directory. :(
50Conflicts:      libtorrent-devel
51## Needed for various headers used via #include directives...
52Requires:       asio-devel
53Requires:       libboost-devel
54Requires:       openssl-devel
55
56%description    devel
57The %{name}-devel package contains libraries and header files for
58developing applications that use %{name}.
59
60The various source and header files included in this package are licensed
61under the revised BSD, zlib/libpng, and Boost Public licenses. See the various
62COPYING files in the included documentation for the full text of these
63licenses, as well as the comments blocks in the source code for which license
64a given source or header file is released under.
65
66
67%package        examples
68Summary:        Example clients using %{name}
69Summary(ja):    %{name} で使用する模範クライアント
70Group:          Applications/Internet
71License:        BSD
72Requires:       %{name} = %{version}-%{release}
73
74%description    examples
75The %{name}-examples package contains example clients which intend to
76show how to make use of its various features. (Due to potential
77namespace conflicts, a couple of the examples had to be renamed. See the
78included documentation for more details.)
79
80
81%package        python
82Summary:        Python bindings for %{name}
83Summary(ja):    %{name} の Python バインディング
84Group:          System Environment/Libraries
85License:        Boost
86Requires:       %{name} = %{version}-%{release}
87
88%description    python
89The %{name}-python package contains Python language bindings (the 'libtorrent'
90module) that allow it to be used from within Python applications.
91
92
93%prep
94%setup -q -n "libtorrent-rasterbar-%{version}"
95
96## The RST files are the sources used to create the final HTML files; and are
97## not needed.
98rm -f docs/*.rst
99## Ensure that we get the licenses installed appropriately.
100install -p -m 0644 COPYING COPYING.BSD
101install -p -m 0644 %{SOURCE1} COPYING.Boost
102install -p -m 0644 %{SOURCE2} COPYING.zlib
103## Finally, ensure that everything is UTF-8, as it should be.
104iconv -t UTF-8 -f ISO_8859-15 AUTHORS -o AUTHORS.iconv
105mv AUTHORS.iconv AUTHORS
106
107
108%build
109## XXX: Even with the --with-asio=system configure option, the stuff in
110## the local include directory overrides that of the system. We don't like
111## local copies of system code. :)
112rm -rf include/libtorrent/asio*
113%configure --disable-static                             \
114        --enable-examples                               \
115        --enable-python-binding                         \
116        --with-boost-libdir=%{_libdir}
117
118#       --with-boost-filesystem=boost_filesystem-gcc41-mt-1_36 \
119#       --with-boost-program_options=boost_program_options-gcc41-mt-1_36 \
120#       --with-boost-python=mt                          \
121#       --with-boost-regex=boost_regex-gcc41-mt-1_36    \
122#       --with-boost-system=boost_system-gcc41-mt-1_36  \
123#       --with-boost-thread=boost_thread-gcc41-mt-1_36  \
124#       --with-zlib=system
125## Use the system libtool to ensure that we don't get unnecessary RPATH
126## hacks in our final build.
127make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
128pushd bindings/python
129        ## Fix the interpreter for the example clients
130        sed -i -e 's:^#!/bin/python$:#!/usr/bin/python:' {simple_,}client.py
131popd
132
133
134%check
135make check
136
137
138%install
139rm -rf %{buildroot}
140## Ensure that we preserve our timestamps properly.
141export CPPROG="%{__cp} -p"
142make install DESTDIR=%{buildroot} INSTALL="%{__install} -c -p"
143## Do the renaming due to the somewhat limited %%_bindir namespace.
144rename client torrent_client %{buildroot}%{_bindir}/*
145
146## Install the python binding module.
147pushd bindings/python
148        %{__python} setup.py install -O1 --skip-build --root %{buildroot}
149popd
150
151
152%clean
153rm -rf %{buildroot}
154
155
156%post -p /sbin/ldconfig
157
158
159%postun -p /sbin/ldconfig
160
161
162%files
163%defattr(-,root,root,-)
164%doc AUTHORS ChangeLog COPYING
165%exclude %{_libdir}/*.la
166%{_libdir}/libtorrent-rasterbar.so.*
167## Unfortunately (even with the "--disable-static" option to the %%configure
168## invocation) our use of the system libtool creates static libraries at build
169## time, so we must exclude them here.
170%exclude %{_libdir}/*.a
171
172%files  devel
173%defattr(-,root,root,-)
174%doc COPYING.Boost COPYING.BSD COPYING.zlib docs/
175%{_libdir}/pkgconfig/libtorrent-rasterbar.pc
176%{_includedir}/libtorrent/
177%{_libdir}/libtorrent-rasterbar.so
178
179%files examples
180%{_bindir}/*torrent*
181%{_bindir}/connection_tester
182#%{_bindir}/enum_if
183#%{_bindir}/fragmentation_test
184#%{_bindir}/parse_hash_fails
185%{_bindir}/parse_request_log
186%{_bindir}/rss_reader
187%{_bindir}/upnp_test
188#%{_bindir}/utp_test
189   
190%files  python
191%defattr(-,root,root,-)
192%doc AUTHORS ChangeLog COPYING.Boost bindings/python/{simple_,}client.py
193%{python_sitearch}/python_libtorrent-%{version}-py?.?.egg-info
194%{python_sitearch}/libtorrent.so
195
196
197%changelog
198* Tue Jun 14 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.9-1
199- new upstream release
200- added Buildrequires: libboost-chrono, libboost-random
201- deleted --with-zlib=system in %%configure
202- fixed -examples %%files
203
204* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.13-3
205- rebuild with openssl-1.0.2
206
207* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.16.13-2
208- moved python subpackage to System Environment/Libraries Group
209
210* Sun Jan 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16.13-1
211- new upstream release
212
213* Mon May 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16.9-1
214- new upstream release
215
216* Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.10-1
217- new upstream release
218- changed BuildRequires: util-linux-ng to util-linux
219
220* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 0.15.4-3
221- rebuilt with libboost-1.45.0
222
223* Mon Jan 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-2
224- rebuilt with openssl-1.0.0c
225- deleted unrecognized configure option (--with-asio)
226
227* Tue Oct 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-1
228- new upstream release
229
230* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.3-2
231- rebuild with rpm-4.8.1 for pkg-config file
232
233* Tue Sep 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.3-1
234- new upstream release
235
236* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.2-1
237- new upstream release
238
239* Sun Jul 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-1
240- new upstream release
241
242* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.0-1
243- new upstream release
244
245* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.9-1
246- new upstream release
247- applied new naming policy to spec
248
249* Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 0.14.8-2
250- rebuilt with new toolchain, python-2.6.4-3
251
252* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.8-1
253- new upstream release
254
255* Thu Dec 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.7-1
256- new upstream release
257
258* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.6-1
259- initial build for VineSeed
260
261* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.14.4-3
262- rebuilt with new openssl
263
264* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.4-2
265- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
266
267* Tue Jun 02 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.4-1
268- Update to new upstream release (0.14.4).
269- Drop outdated Boost patch.
270
271* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-2
272- Rebuild for the Boost 1.39.0 update.
273
274* Mon Apr 27 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-1
275- Update to new upstream bug-fix release (0.14.3).
276
277* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.2-2
278- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
279
280* Fri Feb 20 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.2-1
281- Update to new upstream bug-fix release (0.14.2)
282- Drop Python 2.6 and configure fix patches (fixed upstream):
283  - python26.patch
284  - configure-dont-use-locate.patch
285
286* Fri Jan 16 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-2
287- Rebuild for the soname bump in openssl-0.9.8j
288
289* Mon Jan 05 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-1
290- Update to new upstream release (0.14.1)
291- Add asio-devel as runtime dependency for the devel subpackage (#478589)
292- Add patch to build with Python 2.6:
293  + python26.patch
294- Add patch to make the configure script use the proper python include
295  directory instead of calling locate, as that can cause failures in a chroot
296  with no db file (and is a bit silly in the first place):
297  + configure-dont-use-locate.patch
298- Drop manual setup.py for building the python module (fixed upstream):
299  - setup.py
300- Update Source0 URL back to SourceForge's hosting.
301- Reenable the examples, since the Makefiles are fixed.
302
303* Fri Dec 19 2008 Petr Machata <pmachata@redhat.com> - 0.13.1-7
304- Rebuild for boost-1.37.0.
305
306* Wed Dec 17 2008 Benjamin Kosnik  <bkoz@redhat.com> - 0.13.1-6
307- Rebuild for boost-1.37.0.
308
309* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-5
310- Fix locations for Python 2.6
311
312* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-4
313- Rebuild for Python 2.6
314
315* Thu Nov 20 2008 Peter Gordon <peter@thecodergeek.com>
316- Update Source0 URL, for now.
317
318* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.13.1-3
319- fix license tag
320
321* Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-2
322- Add python bindings in a -python subpackage.
323
324* Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-1
325- Update to new upstream release (0.13.1): Contains an incompatible ABI/API
326  bump.
327- Drop GCC 4.3 patch (fixed upstream):
328  - gcc43.patch
329- Disable building the examples for now. (Attempted builds fail due to missing
330  Makefile support.)
331- Drop the source permissions and pkgconfig file tweaks (fixed upstream).
332
333* Sat Feb 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.12.1-1
334- Update to new upstream bug-fix release (0.12.1)
335- Rebuild for GCC 4.3
336- Drop security fix patch (merged upstream):
337  - svn1968-bdecode_recursive-security-fix.patch
338- Add GCC 4.3 build fixes (based on patch from Adel Gadllah, bug 432778):
339  + gcc43.patch
340
341* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.12-3
342- Add upstream patch (changeset 1968) to fix potential security vulnerability:
343  malformed messages passed through the bdecode_recursive routine could cause
344  a potential stack overflow.
345  + svn1968-bdecode_recursive-security-fix.patch
346
347* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
348- Rebuild against new Boost libraries.
349
350* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
351- Update to new upstream release (0.12 Final)
352- Split examples into a subpackage. Applications that use rb_libtorrent
353  don't need the example binaries installed; and splitting the package in this
354  manner is a bit more friendly to multilib environments. 
355
356* Sun Mar 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-0.rc1
357- Update to new upstream release (0.12 RC).
358- Forcibly use the system libtool to ensure that we remove any RPATH hacks.
359
360* Sun Jan 28 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-5
361- Fix installed pkgconfig file: Strip everything from Libs except for
362  '-ltorrent', as its [libtorrent's] DSO will ensure proper linking to other
363  needed libraries such as zlib and boost_thread. (Thanks to Michael Schwendt
364  and Mamoru Tasaka; bug #221372)
365
366* Sat Jan 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-4
367- Clarify potential licensing issues in the -devel subpackage:
368  + COPYING.zlib
369  + COPYING.Boost
370- Add my name in the Fedora-specific documentation (README-renames.Fedora) and
371  fix some spacing issues in it.
372- Strip the @ZLIB@ (and thus, the extra '-lz' link option) from the installed
373  pkgconfig file, as that is only useful when building a statically-linked
374  libtorrent binary.
375- Fix conflict: The -devel subpackage should conflict with the -devel
376  subpackage of libtorrent, not the main package.
377- Preserve timestamps in %%install.
378
379* Wed Jan 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-3
380- Fix License (GPL -> BSD)
381- Don't package RST (docs sources) files.
382- Only make the -devel subpackage conflict with libtorrent-devel.
383- Rename some of the examples more appropriately; and add the
384  README-renames.Fedora file to %%doc which explains this.
385
386* Fri Jan 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-2
387- Add Requires: pkgconfig to the -devel subpackage since it installs a .pc
388  file.
389
390* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
391- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.