source: projects/specs/trunk/lib/libt/libtool15/libtool15-vl.spec @ 521

Revision 521, 17.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 4.1.2
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool15
8Version: 1.5.26
9Release: 4%{?_dist_release}
10License: GPLv2+ and LGPLv2+ and GFDL
11Group:   Development/Tools
12Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
13URL:     http://www.gnu.org/software/libtool/
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
15Requires(post):  /sbin/install-info
16Requires(preun): /sbin/install-info
17Patch1:  libtool-1.5.24-multilib.patch
18
19# don't  read .la file in current working directory, root might get tricked
20# into running a prepared binary in that directory:
21Patch2:  libtool-1.5.24-relativepath.patch
22
23BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo
24Requires: autoconf >= 2.58, automake >= 1.4
25# make sure we can configure all supported langs
26BuildRequires: gcc, gcc-c++, libstdc++34-devel, gcc-gfortran, gcc-java
27# /usr/bin/libtool includes paths within gcc's versioned directories
28# Libtool must be rebuilt whenever a new upstream gcc is built
29Requires: gcc = %{gcc_version}
30
31Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
32Requires: libtool-ltdl = %{version}-%{release}, mktemp
33
34
35%description
36GNU Libtool is a set of shell scripts which automatically configure UNIX and
37UNIX-like systems to generically build shared libraries. Libtool provides a
38consistent, portable interface which simplifies the process of using shared
39libraries.
40
41If you are developing programs which will use shared libraries, but do not use
42the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
43should install the libtool package.
44
45The libtool package also includes all files needed to integrate the GNU
46Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
47(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
48and GNU Automake).
49
50This package includes a modification from the original GNU Libtool to allow
51support for multi-architecture systems, such as the AMD64 Opteron and the Intel
5264-bit Xeon.
53
54%description -l ja
55GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
56にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
57共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
58スを提供します。
59
60もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
61ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
62する必要があります。
63
64このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
65システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
66
67
68%package ltdl
69Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
70Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
71Group:    System Environment/Libraries
72Provides: libtool-libs = %{version}-%{release}
73Obsoletes: libtool-libs < 1.5.20
74License:  LGPL
75Requires(post):  /sbin/ldconfig
76Requires(postun):  /sbin/ldconfig
77
78
79%description ltdl
80The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
81library that provides a consistent, portable interface which simplifies the
82process of using dynamic modules.
83
84These runtime libraries are needed by programs that link directly to the
85system-installed ltdl libraries; they are not needed by software built using the
86rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
87
88%description -l ja ltdl
89libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
90ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
91利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
92
93
94## to build compat32 for x86_64 architecture support
95%package -n compat32-%{name}-ltdl
96Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
97Group: System Environment/Libraries
98%description -n compat32-%{name}-ltdl
99The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
100library that provides a consistent, portable interface which simplifies the
101process of using dynamic modules.
102
103%prep
104%setup -n libtool-%{version} -q
105%patch1 -p1
106%patch2 -p1
107
108
109%build
110
111./bootstrap
112
113export CC=gcc
114export CXX=g++
115export F77=gfortran
116export CFLAGS="$RPM_OPT_FLAGS -fPIC"
117# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
118./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
119# build not smp safe:
120make #%{?_smp_mflags}
121
122
123# check
124# make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
125
126
127
128%install
129rm -rf %{buildroot}
130make install DESTDIR=$RPM_BUILD_ROOT
131
132rm -f $RPM_BUILD_ROOT%{_bindir}/libtool*
133rm -rf $RPM_BUILD_ROOT%{_infodir}
134rm -rf $RPM_BUILD_ROOT%{_datadir}
135rm -rf $RPM_BUILD_ROOT%{_includedir}
136rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a,so}
137
138%clean
139rm -rf %{buildroot}
140
141
142%post ltdl -p /sbin/ldconfig
143%postun ltdl -p /sbin/ldconfig
144
145
146## to build compat32 for x86_64 architecture support
147%if %{build_compat32}
148%post -n compat32-%{name}-ltdl -p /sbin/ldconfig
149%postun -n compat32-%{name}-ltdl -p /sbin/ldconfig
150%endif
151
152
153%if !%{build_compat32}
154%files ltdl
155%defattr(-,root,root)
156%doc libltdl/COPYING.LIB libltdl/README
157%{_libdir}/libltdl.so.*
158%endif
159
160
161## to build compat32 for x86_64 architecture support
162%if %{build_compat32}
163%files -n compat32-%{name}-ltdl
164%defattr(-,root,root)
165%{_libdir}/libltdl.so.*
166%endif
167
168
169%changelog
170* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.26-4
171- rename to libtool15 to build as compat package
172  - build libtool15-ltdl only
173
174* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
175- updated to 1.5.26, importing changes from Fedora 1.5.26-2
176- new versioning policy; spec in UTF-8
177- define gcc_version to 4.1.2 for Vine
178
179* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
180- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
181
182* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
183- remove BuildRequires: libstdc++3-devel
184- add Requres: libtool-ltdl instead of libtool-libs
185
186* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
187- rebuilt with gcc4 (F77=gfortran now)
188- import Patch2 and Patch3 from FC6 1.5.22-6.1
189
190  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
191  - detect gcc path at runtime instead of requiring one specific version
192
193  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
194  - miscellaneous upstream fixes
195
196* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
197- new upstream release
198
199* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
200- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
201- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
202
203* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
204- added compat32-* packages for x86_64 architecture support
205
206* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
207- add Japanese Summaries and descriptions
208
209* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
210- new upstream release
211
212* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
213- updated to 1.5.18 based on Fedora package
214  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
215  - update to the 1.5.12 bugfix release
216  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
217  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
218  - Interpret `include' statements in toplevel ld.so.conf file.
219  - While "parsing" /etc/ld.so.conf, skip comments.
220  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
221    gcc's internal directories
222  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
223  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
224  - update to the 1.5.10 bugfix release
225    - obsoletes libtool-1.4-nonneg.patch
226    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
227    - obsoletes libtool-1.4.2-multilib.patch
228    - obsoletes libtool-1.4.2-demo.patch
229    - obsoletes libtool-1.5-testfailure.patch
230  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
231  - compile libltdl.a PIC
232
233* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
234- rebuild with gcc-3.3.5
235
236* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
237- new upstream release
238
239* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
240- merged with fedora-1.5.2-2
241  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
242  - update to 1.5.2 bugfix release
243  - update libtool-1.5-libtool.m4-x86_64.patch
244  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
245    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
246    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
247
248  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
249  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
250    [Joe Orton]
251
252* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
253- merged with rawhide 1.5-5
254  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
255  - based on 1.4.3-2 from Rawhide and built for Vine Linux
256  - added BuildPreReq: automake14
257
258* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
259- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
260  and s390x again
261
262* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
263- Fix misapplied chunk for expsym-linux patch
264
265* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
266- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
267  [reported by twaugh]
268- use -nostdlib also when linking with g++ and non-GNU ld in
269  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
270- use %%configure with CC and CXX set
271
272* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
273- don't use %%configure since target options caused libtool to assume
274  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
275- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
276  searched when relinking (#91110) [patch from Joe Orton]
277
278* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
279- rebuilt
280
281* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
282- update to 1.5
283- no longer override config.{guess,sub} for rpmbuild %%configure,
284  redhat-rpm-config owns those now
285- update and rename libtool-1.4.2-s390_x86_64.patch to
286  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
287- buildrequire autoconf and automake, no longer automake14
288- skip make check on s390 temporarily
289- no longer skip demo-nopic.test on x86_64, s390 and s390x
290- from Owen Taylor
291  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
292  - add quoting in mktemp patch
293  - add libtool-1.5-readonlysym.patch
294  - add libtool-1.5-testfailure.patch workaround
295  - relink patch no longer needed
296
297* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
298- add config.guess and config.sub, otherwise old versions of
299  these files can creep into /usr/share/libtool/
300
301* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
302- rebuilt
303
304* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
305- fix mktemp to work when running mktemp fails (#76602)
306  [reported by (Oron Peled)]
307- remove info dir file, don't exclude it
308- fix typo in -libs description (#79619)
309- use buildroot instead of RPM_BUILD_ROOT
310
311* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
312- use lib64 on s390x, too.
313
314* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
315- add comment to explain why we use an old Automake for building
316- buildrequire automake14
317
318* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
319- add --without check build option to allow disabling of "make check"
320- exclude info dir file rather than removing
321
322* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
323- define SED in ltmain.sh for historic ltconfig files
324- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
325- leave old missing file for now
326- general spec file cleanup
327  - don't copy install files to demo nor mess with installed ltdl files
328  - don't need to run make in doc
329  - force removal of info dir file
330  - don't need to create install prefix dir
331  - don't bother gzipping info files ourselves
332
333* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
334- update to 1.4.3
335- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
336- apply the multilib patch to just the original config files
337- update x86_64/s390 patch and just apply to original config files
338- use automake-1.4 in "make check" for demo-make.test to pass!
339- remove info dir file that is not installed
340- make autoreconf update missing
341
342* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
343- Added s390x and x64_64 support.
344
345* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
346- rebuild
347
348* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
349- patch to find the proper libdir on multilib boxes
350 
351* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
352- don't include demo in doc, specially now that we "make check" (#71609)
353
354* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
355- don't hardcode "configure.in" in libtoolize (#70864)
356  [reported by bastiaan@webcriminals.com]
357- make check, but not on ia64
358
359* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
360- automated rebuild
361
362* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
363- automated rebuild
364
365* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
366- add old patch from aoliva to fix relinking when installing into a buildroot
367- backport dup-deps fix from cvs stable branch
368
369* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
370- run ldconfig in postin and postun
371
372* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
373- rebuild in new environment
374
375* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
376- revert filemagic and archive-shared patches following cvs (#54887)
377- don't change "&& test" to "-a" in ltmain.in
378
379* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
380- automated rebuild
381
382* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
383- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
384- use file_magic for Linux ELF (#54887)
385- allow link against an archive when building a shared library (#54887)
386- include ltdl.m4 in manifest (#56671)
387
388* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
389- added URL to spec
390
391* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
392- 1.4.2 - sync up with autoconf...
393
394* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
395- extend s390 patch to 2 more files
396- s/Copyright/License/
397
398* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
399- add s390 patch for deplibs_check_method=pass_all
400
401* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
402- add patches from Tim Waugh #42724
403
404* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
405- add patches from cvs mainline
406
407* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
408- fix a "test" bug in ltmain.sh
409
410* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
411- disable the post commands to modify /usr/share/doc/
412
413* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
414- Require automake 1.4p1
415
416* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
417- update to libtool 1.4
418- adjust or remove patches
419
420* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
421- Fix recognition of ^0[0-9]+$ as a non-negative integer.
422
423* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
424- automatic rebuild
425
426* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
427- patch to use mktemp to create the tempdir
428- use %%configure after defining __libtoolize to /bin/true
429
430* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
431- subpackage libltdl into libtool-libs
432
433* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
434- running libtoolize on the libtool source tree ain't right :)
435
436* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
437- FHS packaging.
438
439* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
440- update to 1.3.5.
441
442* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
443- add prereqs for m4 and perl inorder to run autoconf/automake.
444
445* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
446- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
447
448* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
449- update to 1.3.4.
450
451* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
452- change from noarch to per-arch in order to package libltdl.a (#7493).
453
454* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
455- update to 1.3.3.
456
457* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
458- update to 1.3.2.
459
460* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
461- explicitly disable per-arch libraries (#2210)
462- undo hard links and remove zero length file (#2689)
463
464* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
465- update to 1.3.
466
467* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
468- disable the --cache-file passing to ltconfig; this breaks the older
469  ltconfig scripts found around.
470
471* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
472- auto rebuild in the new build environment (release 2)
473
474* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
475- update to 1.2f
476
477* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
478- completed arm patch
479- added patch to make it more arm-friendly
480- upgrade to version 1.2d
481
482* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
483- fixed busted group
484
485* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
486- Update to 1.0h
487- added install-info support
488
489* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
490- Update to 1.0f
491- BuildRoot it
492- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.