source: projects/specs/trunk/lib/libt/libtool/libtool-vl.spec @ 7851

Revision 7851, 19.9 KB checked in by Takemikaduchi, 11 years ago (diff)

rebuild toolchain

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 4.8.1
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool
8Version: 2.4.2
9Release: 3%{?_dist_release}
10License: GPLv2+ and LGPLv2+ and GFDL
11Group:   Development/Tools
12URL:     http://www.gnu.org/software/libtool/
13
14Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
15Patch0:  libtool-2.4-rpath.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18Requires(post):  /sbin/install-info
19Requires(preun): /sbin/install-info
20
21BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
22Requires: autoconf >= 2.58, automake >= 1.4
23# make sure we can configure all supported langs
24BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
25#BuildRequires: gcc-java
26# /usr/bin/libtool includes paths within gcc's versioned directories
27# Libtool must be rebuilt whenever a new upstream gcc is built
28Requires: gcc = %{gcc_version}
29
30Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
31Requires: libtool-ltdl = %{version}-%{release}, mktemp
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37GNU Libtool is a set of shell scripts which automatically configure UNIX and
38UNIX-like systems to generically build shared libraries. Libtool provides a
39consistent, portable interface which simplifies the process of using shared
40libraries.
41
42If you are developing programs which will use shared libraries, but do not use
43the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
44should install the libtool package.
45
46The libtool package also includes all files needed to integrate the GNU
47Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
48(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
49and GNU Automake).
50
51This package includes a modification from the original GNU Libtool to allow
52support for multi-architecture systems, such as the AMD64 Opteron and the Intel
5364-bit Xeon.
54
55%description -l ja
56GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
57にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
58共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
59スを提供します。
60
61もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
62ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
63する必要があります。
64
65このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
66システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
67
68
69%package ltdl
70Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
71Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
72Group:    System Environment/Libraries
73Provides: libtool-libs = %{version}-%{release}
74Obsoletes: libtool-libs < 1.5.20
75License:  LGPL
76Requires(post):  /sbin/ldconfig
77Requires(postun):  /sbin/ldconfig
78
79
80%description ltdl
81The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
82library that provides a consistent, portable interface which simplifies the
83process of using dynamic modules.
84
85These runtime libraries are needed by programs that link directly to the
86system-installed ltdl libraries; they are not needed by software built using the
87rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
88
89%description -l ja ltdl
90libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
91ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
92利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
93
94
95%package ltdl-devel
96Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
97Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
98Group:    Development/Libraries
99Requires: libtool-ltdl = %{version}-%{release}
100License:  LGPL
101
102
103%description ltdl-devel
104Static libraries and header files for development with ltdl.
105
106%description -l ja ltdl-devel
107ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
108
109
110## to build compat32 for x86_64 architecture support
111%package -n compat32-%{name}-ltdl
112Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
113Group: System Environment/Libraries
114%description -n compat32-%{name}-ltdl
115The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
116library that provides a consistent, portable interface which simplifies the
117process of using dynamic modules.
118
119%package -n compat32-%{name}-ltdl-devel
120Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
121Group: Development/Libraries
122Requires: compat32-%{name}-ltdl = %{version}-%{release}
123%description -n compat32-%{name}-ltdl-devel
124Static libraries and header files for development with ltdl.
125
126
127%prep
128%setup -q
129%patch0 -p1
130
131
132%build
133
134./bootstrap
135
136export CC=gcc
137export CXX=g++
138export F77=gfortran
139export CFLAGS="$RPM_OPT_FLAGS -fPIC"
140# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
141./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
142# build not smp safe:
143make #%{?_smp_mflags}
144
145
146#check
147#make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
148
149
150%install
151rm -rf %{buildroot}
152make install DESTDIR=$RPM_BUILD_ROOT
153rm -f %{buildroot}%{_infodir}/dir
154rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
155
156
157%clean
158rm -rf %{buildroot}
159
160
161%post
162/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
163
164%preun
165if [ "$1" = 0 ]; then
166   /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
167fi
168
169%post ltdl -p /sbin/ldconfig
170
171%postun ltdl -p /sbin/ldconfig
172
173%post -n compat32-%{name}-ltdl
174/sbin/ldconfig
175
176%postun -n compat32-%{name}-ltdl
177/sbin/ldconfig
178
179
180%files
181%defattr(-,root,root)
182%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog
183%{_bindir}/libtool
184%{_bindir}/libtoolize
185%{_datadir}/aclocal/*.m4
186%{_datadir}/libtool
187%{_infodir}/libtool.info*.gz
188%{_mandir}/man1/libtool.1.gz
189%{_mandir}/man1/libtoolize.1.gz
190
191%files ltdl
192%defattr(-,root,root)
193%doc libltdl/COPYING.LIB libltdl/README
194%{_libdir}/libltdl.so.*
195
196%files ltdl-devel
197%defattr(-,root,root)
198%{_libdir}/libltdl.so
199%{_includedir}/ltdl.h
200%{_includedir}/libltdl/*
201
202%if %{build_compat32}
203## to build compat32 for x86_64 architecture support
204%files -n compat32-%{name}-ltdl
205%defattr(-,root,root)
206%{_libdir}/libltdl.so.*
207
208%files -n compat32-%{name}-ltdl-devel
209%defattr(-,root,root)
210%{_libdir}/libltdl.so
211%endif
212
213
214%changelog
215* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
216- rebuild with gcc-4.8.1-2
217
218* Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
219- rebuild with gcc-4.8.1
220- add BuildRequires: help2man
221
222* Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
223- new upstream release
224
225* Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
226- rebuilt with gcc-4.6.2
227
228* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
229- new upstream release
230- update Patch0
231
232* Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
233- rebuilt with gcc-4.4.5
234
235* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
236- new upstream release
237
238* Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
239- rebuilt with gcc-4.4.3-1 (w/o gcc-java)
240
241* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
242- remove comment before compat32 scriptlet to avoid scriptlet failure.
243
244* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
245- removed %%if !%%{build_compat32} case condition
246
247* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
248- update to 2.2.6a
249- remove libltdl static library
250
251* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
252- updated to 1.5.26, importing changes from Fedora 1.5.26-2
253- new versioning policy; spec in UTF-8
254- define gcc_version to 4.1.2 for Vine
255
256* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
257- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
258
259* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
260- remove BuildRequires: libstdc++3-devel
261- add Requres: libtool-ltdl instead of libtool-libs
262
263* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
264- rebuilt with gcc4 (F77=gfortran now)
265- import Patch2 and Patch3 from FC6 1.5.22-6.1
266
267  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
268  - detect gcc path at runtime instead of requiring one specific version
269
270  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
271  - miscellaneous upstream fixes
272
273* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
274- new upstream release
275
276* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
277- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
278- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
279
280* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
281- added compat32-* packages for x86_64 architecture support
282
283* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
284- add Japanese Summaries and descriptions
285
286* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
287- new upstream release
288
289* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
290- updated to 1.5.18 based on Fedora package
291  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
292  - update to the 1.5.12 bugfix release
293  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
294  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
295  - Interpret `include' statements in toplevel ld.so.conf file.
296  - While "parsing" /etc/ld.so.conf, skip comments.
297  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
298    gcc's internal directories
299  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
300  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
301  - update to the 1.5.10 bugfix release
302    - obsoletes libtool-1.4-nonneg.patch
303    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
304    - obsoletes libtool-1.4.2-multilib.patch
305    - obsoletes libtool-1.4.2-demo.patch
306    - obsoletes libtool-1.5-testfailure.patch
307  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
308  - compile libltdl.a PIC
309
310* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
311- rebuild with gcc-3.3.5
312
313* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
314- new upstream release
315
316* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
317- merged with fedora-1.5.2-2
318  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
319  - update to 1.5.2 bugfix release
320  - update libtool-1.5-libtool.m4-x86_64.patch
321  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
322    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
323    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
324
325  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
326  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
327    [Joe Orton]
328
329* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
330- merged with rawhide 1.5-5
331  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
332  - based on 1.4.3-2 from Rawhide and built for Vine Linux
333  - added BuildPreReq: automake14
334
335* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
336- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
337  and s390x again
338
339* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
340- Fix misapplied chunk for expsym-linux patch
341
342* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
343- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
344  [reported by twaugh]
345- use -nostdlib also when linking with g++ and non-GNU ld in
346  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
347- use %%configure with CC and CXX set
348
349* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
350- don't use %%configure since target options caused libtool to assume
351  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
352- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
353  searched when relinking (#91110) [patch from Joe Orton]
354
355* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
356- rebuilt
357
358* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
359- update to 1.5
360- no longer override config.{guess,sub} for rpmbuild %%configure,
361  redhat-rpm-config owns those now
362- update and rename libtool-1.4.2-s390_x86_64.patch to
363  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
364- buildrequire autoconf and automake, no longer automake14
365- skip make check on s390 temporarily
366- no longer skip demo-nopic.test on x86_64, s390 and s390x
367- from Owen Taylor
368  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
369  - add quoting in mktemp patch
370  - add libtool-1.5-readonlysym.patch
371  - add libtool-1.5-testfailure.patch workaround
372  - relink patch no longer needed
373
374* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
375- add config.guess and config.sub, otherwise old versions of
376  these files can creep into /usr/share/libtool/
377
378* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
379- rebuilt
380
381* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
382- fix mktemp to work when running mktemp fails (#76602)
383  [reported by (Oron Peled)]
384- remove info dir file, don't exclude it
385- fix typo in -libs description (#79619)
386- use buildroot instead of RPM_BUILD_ROOT
387
388* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
389- use lib64 on s390x, too.
390
391* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
392- add comment to explain why we use an old Automake for building
393- buildrequire automake14
394
395* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
396- add --without check build option to allow disabling of "make check"
397- exclude info dir file rather than removing
398
399* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
400- define SED in ltmain.sh for historic ltconfig files
401- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
402- leave old missing file for now
403- general spec file cleanup
404  - don't copy install files to demo nor mess with installed ltdl files
405  - don't need to run make in doc
406  - force removal of info dir file
407  - don't need to create install prefix dir
408  - don't bother gzipping info files ourselves
409
410* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
411- update to 1.4.3
412- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
413- apply the multilib patch to just the original config files
414- update x86_64/s390 patch and just apply to original config files
415- use automake-1.4 in "make check" for demo-make.test to pass!
416- remove info dir file that is not installed
417- make autoreconf update missing
418
419* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
420- Added s390x and x64_64 support.
421
422* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
423- rebuild
424
425* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
426- patch to find the proper libdir on multilib boxes
427 
428* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
429- don't include demo in doc, specially now that we "make check" (#71609)
430
431* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
432- don't hardcode "configure.in" in libtoolize (#70864)
433  [reported by bastiaan@webcriminals.com]
434- make check, but not on ia64
435
436* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
437- automated rebuild
438
439* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
440- automated rebuild
441
442* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
443- add old patch from aoliva to fix relinking when installing into a buildroot
444- backport dup-deps fix from cvs stable branch
445
446* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
447- run ldconfig in postin and postun
448
449* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
450- rebuild in new environment
451
452* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
453- revert filemagic and archive-shared patches following cvs (#54887)
454- don't change "&& test" to "-a" in ltmain.in
455
456* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
457- automated rebuild
458
459* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
460- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
461- use file_magic for Linux ELF (#54887)
462- allow link against an archive when building a shared library (#54887)
463- include ltdl.m4 in manifest (#56671)
464
465* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
466- added URL to spec
467
468* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
469- 1.4.2 - sync up with autoconf...
470
471* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
472- extend s390 patch to 2 more files
473- s/Copyright/License/
474
475* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
476- add s390 patch for deplibs_check_method=pass_all
477
478* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
479- add patches from Tim Waugh #42724
480
481* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
482- add patches from cvs mainline
483
484* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
485- fix a "test" bug in ltmain.sh
486
487* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
488- disable the post commands to modify /usr/share/doc/
489
490* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
491- Require automake 1.4p1
492
493* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
494- update to libtool 1.4
495- adjust or remove patches
496
497* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
498- Fix recognition of ^0[0-9]+$ as a non-negative integer.
499
500* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
501- automatic rebuild
502
503* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
504- patch to use mktemp to create the tempdir
505- use %%configure after defining __libtoolize to /bin/true
506
507* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
508- subpackage libltdl into libtool-libs
509
510* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
511- running libtoolize on the libtool source tree ain't right :)
512
513* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
514- FHS packaging.
515
516* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
517- update to 1.3.5.
518
519* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
520- add prereqs for m4 and perl inorder to run autoconf/automake.
521
522* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
523- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
524
525* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
526- update to 1.3.4.
527
528* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
529- change from noarch to per-arch in order to package libltdl.a (#7493).
530
531* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
532- update to 1.3.3.
533
534* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
535- update to 1.3.2.
536
537* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
538- explicitly disable per-arch libraries (#2210)
539- undo hard links and remove zero length file (#2689)
540
541* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
542- update to 1.3.
543
544* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
545- disable the --cache-file passing to ltconfig; this breaks the older
546  ltconfig scripts found around.
547
548* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
549- auto rebuild in the new build environment (release 2)
550
551* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
552- update to 1.2f
553
554* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
555- completed arm patch
556- added patch to make it more arm-friendly
557- upgrade to version 1.2d
558
559* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
560- fixed busted group
561
562* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
563- Update to 1.0h
564- added install-info support
565
566* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
567- Update to 1.0f
568- BuildRoot it
569- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.