source: projects/specs/trunk/lib/libt/libtirpc/libtirpc-vl.spec @ 521

Revision 521, 9.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           libtirpc
2Version:        0.2.1
3Release:        2%{?_dist_release}
4Summary:        Transport Independent RPC Library
5Group:          System Environment/Libraries
6License:        SISSL and BSD
7URL:            http://nfsv4.bullopensource.org/
8
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10Source0:        http://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2
11
12BuildRequires:  automake, autoconf, libtool, pkgconfig
13BuildRequires:  libgssglue-devel
14
15%description
16This package contains SunLib's implementation of transport-independent
17RPC (TI-RPC) documentation.  This library forms a piece of the base of
18Open Network Computing (ONC), and is derived directly from the
19Solaris 2.3 source.
20
21TI-RPC is an enhanced version of TS-RPC that requires the UNIX System V
22Transport Layer Interface (TLI) or an equivalent X/Open Transport Interface
23(XTI).  TI-RPC is on-the-wire compatible with the TS-RPC, which is supported
24by almost 70 vendors on all major operating systems.  TS-RPC source code
25(RPCSRC 4.0) remains available from several internet sites.
26
27%package devel
28Summary:        Development files for the libtirpc library
29Group:          Development/Libraries
30Requires:       %{name} = %{version}-%{release}
31Requires:       pkgconfig
32
33%description devel
34This package includes header files and libraries necessary for
35developing programs which use the tirpc library.
36
37
38%prep
39%setup -q
40
41# Remove .orig files
42find . -name "*.orig" | xargs rm -f
43
44%build
45autoreconf -fisv
46%configure --enable-gss
47make all
48
49%install
50rm -rf %{buildroot}
51mkdir -p %{buildroot}/etc
52make install DESTDIR=%{buildroot}
53
54# Don't package .a or .la files
55rm -f %{buildroot}%{_libdir}/*.{a,la}
56
57# Creat the man diretory
58#mv %{buildroot}%{_mandir}/man3 %{buildroot}%{_mandir}/man3t
59
60%post  -p /sbin/ldconfig
61
62%postun -p /sbin/ldconfig
63
64%clean
65rm -rf %{buildroot}
66
67%files
68%defattr(-,root,root)
69%doc AUTHORS ChangeLog NEWS README
70%{_libdir}/libtirpc.so.*
71%config(noreplace)%{_sysconfdir}/netconfig
72
73%files devel
74%defattr(0644,root,root,755)
75%dir %{_includedir}/tirpc
76%dir %{_includedir}/tirpc/rpc
77%dir %{_includedir}/tirpc/rpcsvc
78%{_libdir}/libtirpc.so
79%{_libdir}/pkgconfig/libtirpc.pc
80%{_includedir}/tirpc/netconfig.h
81%{_includedir}/tirpc/rpc/auth.h
82%{_includedir}/tirpc/rpc/auth_des.h
83%{_includedir}/tirpc/rpc/auth_gss.h
84%{_includedir}/tirpc/rpc/auth_kerb.h
85%{_includedir}/tirpc/rpc/auth_unix.h
86%{_includedir}/tirpc/rpc/clnt.h
87%{_includedir}/tirpc/rpc/clnt_soc.h
88%{_includedir}/tirpc/rpc/clnt_stat.h
89%{_includedir}/tirpc/rpc/des.h
90%{_includedir}/tirpc/rpc/des_crypt.h
91%{_includedir}/tirpc/rpc/nettype.h
92%{_includedir}/tirpc/rpc/pmap_clnt.h
93%{_includedir}/tirpc/rpc/pmap_prot.h
94%{_includedir}/tirpc/rpc/pmap_rmt.h
95%{_includedir}/tirpc/rpc/raw.h
96%{_includedir}/tirpc/rpc/rpc.h
97%{_includedir}/tirpc/rpc/rpc_com.h
98%{_includedir}/tirpc/rpc/rpc_msg.h
99%{_includedir}/tirpc/rpc/rpcb_clnt.h
100%{_includedir}/tirpc/rpc/rpcb_prot.h
101%{_includedir}/tirpc/rpc/rpcb_prot.x
102%{_includedir}/tirpc/rpc/rpcent.h
103%{_includedir}/tirpc/rpc/svc.h
104%{_includedir}/tirpc/rpc/svc_auth.h
105%{_includedir}/tirpc/rpc/svc_dg.h
106%{_includedir}/tirpc/rpc/svc_soc.h
107%{_includedir}/tirpc/rpc/types.h
108%{_includedir}/tirpc/rpc/xdr.h
109%{_includedir}/tirpc/rpcsvc/crypt.h
110%{_includedir}/tirpc/rpcsvc/crypt.x
111%{_mandir}/*/*
112
113%changelog
114* Sun Feb 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.1-2
115- Initial build for Vine Linux
116
117* Mon Nov 30 2009 Steve Dickson  <steved@redhat.com> 0.2.1-1
118- Updated to latest upstream version: 0.2.1
119
120* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-4
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
122
123* Thu Jul  9 2009 Steve Dickson  <steved@redhat.com> 0.2.0-3
124- Updated to latest upstream tag: 0-2-1-rc3
125    Fixed the --disable-gss options
126    Fixed a number of warnings
127    Change how architectures are define in xdr_float.c
128
129* Mon Jun 29 2009 Steve Dickson  <steved@redhat.com> 0.2.0-2
130- Updated to latest upstream tag: 0-2-1-rc2
131    rpcb_clnt: RPC_PROGNOTREGISTERED is a permanent error
132    clnt_dg: Fix infinite loop when datagram call times ou
133    Updated .gitignore file
134    Replace the hard coded path name with the top_srcdir macrc
135    Added 'doc' to the SUBDIRS list so make install work correctly.
136
137* Fri May 29 2009 Steve Dickson  <steved@redhat.com> 0.2.0-1
138- Updated to latest upstream version: 0.2.0
139
140* Tue May 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.11-3
141- Replace the Sun RPC license with the BSD license, with the explicit permission of Sun Microsystems
142
143* Mon Apr 20 2009 Steve Dickson  <steved@redhat.com> 0.1.11-2
144- Updated to libtirpc-0.1.12-rc1
145
146* Mon Apr 20 2009 Steve Dickson  <steved@redhat.com> 0.1.11-1
147- Updated to the latest release: 0.1.11
148
149* Fri Mar 13 2009 Steve Dickson  <steved@redhat.com> 0.1.10-6
150- libtirpc: set r_netid and r_owner in __rpcb_findaddr_timed
151- libtirpc: be sure to free cl_netid and cl_tp
152- libtirpc: must free saved wire verifier when destroying context
153
154* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.10-5
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
156
157* Wed Jan 28 2009 Steve Dickson  <steved@redhat.com> 0.1.10-4
158- Converted all uids and uids to type uid_t and gid_t (sf 2446314)
159
160* Wed Jan 28 2009 Steve Dickson  <steved@redhat.com> 0.1.10-3
161- backwards compatibility: fix order of fields in TI-RPC's
162  svc_req (bz 481388)
163- Removed a number warnings.
164
165* Thu Jan 22 2009 Steve Dickson  <steved@redhat.com> 0.1.10-2
166- Header file fixes for C++
167
168* Thu Nov 20 2008 Steve Dickson  <steved@redhat.com> 0.1.10-1
169- Updated to latest upstream version: 0.1.10
170
171* Tue Oct 28 2008 Steve Dickson  <steved@redhat.com> 0.1.9-7
172- Fixed some incorrect function declarations (bz468815)
173
174* Mon Oct 27 2008 Steve Dickson  <steved@redhat.com> 0.1.9-6
175- Fix bad assumption taddr2uaddr processing that
176  caused a segfault (bz468014)
177
178* Tue Sep 16 2008 Steve Dickson <steved@redhat.com> 0.1.9-5
179- Fix for taddr2addr conversion bug of local addresses
180- Fixed some of warnings in: src/auth_time.c, src/clnt_dg.c and
181  src/clnt_raw.c
182- Added some #ifdef NOTUSED around some code in src/rpbc_clnt.c
183  that was not being used...
184
185* Thu Sep  4 2008 Steve Dickson <steved@redhat.com> 0.1.9-4
186- Always make IPv6 sockets V6ONLY
187- Fix incorrect sizeof() in __rpc_getbroadifs
188
189* Thu Aug  7 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.9-3
190- fix license tag
191
192* Tue Jul 9 2008 Steve Dickson  <steved@redhat.com> 0.1.9-1
193- Update to latest upstream version 0.1.9
194
195* Fri Jun 27 2008 Steve Dickson  <steved@redhat.com> 0.1.8-2
196- Added super-H(sh3,4) architecture support (bz 446559)
197
198* Tue Jun 10 2008 Steve Dickson  <steved@redhat.com> 0.1.8-1
199- Update to latest upstream version 0.1.8
200
201* Wed Mar 12 2008 Steve Dickson  <steved@redhat.com> 0.1.7-18
202- Install man pages in the 3t section
203
204* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.7-17
205- Autorebuild for GCC 4.3
206
207* Mon Feb 18 2008 Steve Dickson  <steved@redhat.com> 0.1.7-16
208- Added patch that creates a libtirpc.pc used by the
209  pkg-config command.
210
211* Thu Jan 24 2008 Steve Dickson  <steved@redhat.com> 0.1.7-15
212- Protect from buffer overflow in the GSS code. (bz 362121)
213
214* Mon Dec 17 2007 Steve Dickson  <steved@redhat.com> 0.1.7-14
215- Fixed typo in /etc/netconfig file (bz 414471)
216
217* Thu Oct 25 2007 Steve Dickson  <steved@redhat.com> 0.1.7-13
218- Added a check for the ARM arch (bz 351071)
219
220* Wed Oct 17 2007 Steve Dickson  <steved@redhat.com> 0.1.7-12
221- Switch the libgssapi dependency to libgssglue
222
223* Mon Oct 15 2007 Steve Dickson  <steved@redhat.com> 0.1.7-11
224- Made tcp6/udp6 network ids no longer visible in the netconfig
225  file since the ipv6 code is not fully baked yet in rpcbind. (bz 249121)
226
227* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.1.7-10
228- Rebuild for selinux ppc32 issue.
229
230* Mon Jul 30 2007 <steved@redhat.com> 0.1.7-9
231- Fixed mutex lock problem in clnt_raw_create()
232- Ignore the return value of snprintf() and use strlen() instead
233  to bump the pointer in clnt_sperror()
234- A couple ntohs() were needed in bindresvport_sa()
235- Added IP_RECVERR processing with to clnt_dg_call() so
236  application will see errors instead of timing out
237- Make sure remote address (xp_rtaddr) is populated
238  with the correct type of address.
239- Change the order of network ids in /etc/netconfg
240  putting ipv4 ids before ipv6.
241- Bumped up Release from 8 to 9.
242
243* Mon Jul  9 2007 <steved@redhat.com> 0.1.7-7
244- Fixed infinite loop in svc_run() (bz 246677)
245
246* Thu Apr 26 2007 <steved@redhat.com> 0.1.7-6
247- Fixed potential buffer overflow in xdr_strings
248- Added a optimization to bindresvport that allows more
249  ports to be tried.
250
251* Mon Mar 26 2007 Steve Dickson <steved@redhat.com> 0.1.7-5
252- Fixed Unowned Directory RPM problem (bz 233873)
253
254* Mon Aug 28 2006 Steve Dickson <steved@redhat.com> 0.1.7-4
255- Fixed undefined symbol (bz 204296)
256
257* Mon Aug 14 2006 Steve Dickson <steved@redhat.com> 0.1.7-3
258- Added in svc_auth_none needed by the GSSAPI code.
259- Added compile define for ppc64 archs
260
261* Fri Aug 11 2006 Steve Dickson <steved@redhat.com> 0.1.7-2
262- Uncommented tcp6 and udp6 in the default /etc/netconfig file.
263- Added hooks to used the libgssapi library.
264
265* Fri Aug  4 2006 Steve Dickson <steved@redhat.com> 0.1.7-1
266- Initial commit
Note: See TracBrowser for help on using the repository browser.