source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 1282

Revision 1282, 10.9 KB checked in by daisuke, 14 years ago (diff)

libtiff: update to 3.9.4, add bugfix patches

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 3.9.4
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12Patch1: libtiff-acversion.patch
13Patch2: libtiff-mantypo.patch
14Patch3: libtiff-scanlinesize.patch
15Patch4: libtiff-getimage-64bit.patch
16Patch5: libtiff-ycbcr-clamp.patch
17Patch6: libtiff-3samples.patch
18Patch7: libtiff-subsampling.patch
19Patch8: libtiff-unknown-fix.patch
20Patch9: libtiff-checkbytecount.patch
21Patch10: libtiff-tiffdump.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: zlib-devel zlib libjpeg-devel libjpeg
25Requires: zlib libjpeg
26%define LIBVER %(echo %{version} | cut -f-2 -d.)
27
28
29%description
30The libtiff package contains a library of functions for manipulating
31TIFF (Tagged Image File Format) image format files.  TIFF is a widely
32used file format for bitmapped images.  TIFF files usually end in the
33.tif extension and they are often quite large.
34
35The libtiff package should be installed if you need to manipulate TIFF
36format image files.
37
38%description -l ja
39libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
40扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
41広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
42拡張子が使われ,サイズは概して大きめです.
43
44TIFF 形式の画像ファイルを扱う必要があるならば,
45libtiff パッケージを是非インストールして下さい.
46
47
48%package devel
49Summary: Development tools for programs which will use the libtiff library.
50Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
51Group: Development/Libraries
52Requires: libtiff = %{version}
53
54
55%description devel
56This package contains the header files and static libraries for
57developing programs which will manipulate TIFF format image files
58using the libtiff library.
59
60If you need to develop programs which will manipulate TIFF format
61image files, you should install this package.  You'll also need to
62install the libtiff package.
63
64#'
65%description devel -l ja
66このパッケージには,libtiff ライブラリを使って TIFF 形式の
67画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
68スタティックライブラリが収められています.
69
70TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
71このパッケージをインストールして下さい.libtiff パッケージも同時に
72インストールする必要があります.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: A library of functions for manipulating TIFF format image files.
77Group: System Environment/Libraries
78Requires: zlib libjpeg
79Requires: %{name} = %{version}
80%description -n compat32-%{name}
81The libtiff package contains a library of functions for manipulating
82TIFF (Tagged Image File Format) image format files.  TIFF is a widely
83used file format for bitmapped images.  TIFF files usually end in the
84.tif extension and they are often quite large.
85
86The libtiff package should be installed if you need to manipulate TIFF
87format image files.
88
89%package -n compat32-%{name}-devel
90Summary: Development tools for programs which will use the libtiff library.
91Group: Development/Libraries
92Requires: compat32-%{name} = %{version}
93%description -n compat32-%{name}-devel
94This package contains the header files and static libraries for
95developing programs which will manipulate TIFF format image files
96using the libtiff library.
97
98If you need to develop programs which will manipulate TIFF format
99image files, you should install this package.  You'll also need to
100install the libtiff package.
101
102#'
103%prep
104%setup -q -n tiff-%{version}
105%patch1 -p1 -b .acversion
106%patch2 -p1 -b .mantypo
107%patch3 -p1 -b .scanlinesize
108%patch4 -p1
109%patch5 -p1
110%patch6 -p1
111%patch7 -p1
112%patch8 -p1
113%patch9 -p1
114%patch10 -p1
115
116%build
117%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
118%__make %{?_smp_mflags}
119%__make clean
120
121
122%install
123rm -fr $RPM_BUILD_ROOT
124%makeinstall
125rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
126
127# fix libdir in .la
128perl -pi -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
129
130
131%post -p /sbin/ldconfig
132
133
134%postun -p /sbin/ldconfig
135
136%if %{build_compat32}
137%post -n compat32-%{name} -p /sbin/ldconfig
138%postun -n compat32-%{name} -p /sbin/ldconfig
139%endif
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%files
145%defattr(-,root,root)
146%doc COPYRIGHT README RELEASE-DATE VERSION
147%{_bindir}/*
148%{_libdir}/libtiff*.so.*
149%{_mandir}/man1/*
150
151
152%files devel
153%defattr(-,root,root)
154%doc TODO html ChangeLog
155%{_includedir}/*
156%{_libdir}/libtiff*.so
157%{_libdir}/libtiff*.a
158%if %{_dist_release}=="vl4"
159# for Vine 4.x
160%{_libdir}/libtiff*.la
161%endif
162%{_mandir}/man3/*
163
164## to build compat32 for x86_64 architecture support
165%if %{build_compat32}
166%files -n compat32-%{name}
167%defattr(-,root,root)
168%{_libdir}/libtiff.so.*
169
170%files -n compat32-%{name}-devel
171%defattr(-,root,root)
172%{_libdir}/libtiff.so
173%{_libdir}/libtiff.a
174# %{_libdir}/libtiff.la
175%endif
176
177
178%changelog
179* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
180- new upstream release
181- add patch4-10 from fedora
182
183* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
184- new upstream release
185- remove BC: freeglut-devel
186- add patch1,2,4,5 from fedora
187- drop obsolete patches
188
189* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
190- change if-endif to make both i386 and compat32 packages
191
192* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
193- add patch5 for fix CVE-2009-2347 (Integer Overflow)
194
195* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
196- add patch4 for fix lzw underflow security issue
197- add if branch Vine4/5 in devel files section (*.la are included or not)
198
199* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
200- removed *.la
201- spec in utf-8
202
203* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
204- fix changelog typo (3.8.4 -> 3.8.2)
205- new versioning policy
206- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
207
208* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
209- fix libdir in libtiff.la
210- add BuildConflicts: freeglut-devel
211
212* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
213- rebuilt without glut-devel
214
215* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
216- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
217
218* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
219- new upstream release
220- remove obsolete patches
221- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
222- delete duped docs
223- add --disable-cxx to configure option
224- add *.la to devel package
225
226* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
227- added compat32-* packages for x86_64 architecture support
228- added --with-jpeg-lib-dir=%{_libdir} to configure
229
230* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
231- new upstream release
232- remove obsolete patches
233- cleanup specs
234
235* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
236- rebuild for Vine3.1
237
238* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
239- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
240- update URL
241
242* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
243- build for Vine2.6
244
245* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
246- fix changelog: proper name
247
248* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
249- add symlink to shared lib by running ldconfig at compile time
250
251* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
252- add patch8-13 from Fedora Core
253--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
254--- fix some integer and buffer overflows (#134853, #134848)
255- add patch14 from SUSE LINUX
256--* Wed Oct 20 2004 - meissner@suse.de
257--- Do not crash if we are using unsupported codecs (like OJPEG).
258
259* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
260- rebuild with new toolchains
261- to use License instead of Copyright
262
263* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
264- 3.5.7-6vl1
265- based on 3.5.7-6 from Rawhide
266
267* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
268- 3.5.5-8vl1
269- based on 3.5.5-8 from Rawhide
270- added Japanese summary and description
271
272* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
273- rebuild
274
275* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
276- added a tiff-to-ps.fpi filter for printing
277
278* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
279- automatic rebuild
280
281* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
282- apply Peter Skarpetis's fix for the 32-bit conversion
283
284* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
285- make man pages non-executable (#12811)
286
287* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
288- remove CVS repo info from data directories
289
290* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
291- fix build rooting
292- fix syntax error in configure script
293- move man pages to %{_mandir}
294
295* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
296- rebuild for an errata release
297
298* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
299- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
300
301* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
302- fix fax2ps swapping height and width in the bounding box
303
304* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
305- move man pages from devel package to the regular one
306- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
307  of libtiff)
308- fix fax2ps breakage (bug #8345)
309
310* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
311- set MANDIR=man3 to make multifunction man pages friendlier
312
313* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
314- fix URLs
315
316* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
317- link shared library against libjpeg and libz
318
319* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
320- enable zip and jpeg codecs
321- change defattr in normal package to 0755
322- add defattr to -devel package
323
324* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
325- update to 3.5.4
326
327* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
328- auto rebuild in the new build environment (release 6)
329
330* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
331- build for glibc 2.1
332
333* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
334- translations modified for de
335
336* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
337- rebuilt against fixed jpeg libs (libjpeg-6b)
338
339* Thu May 07 1998 Prospector System <bugs@redhat.com>
340- translations modified for de, fr, tr
341
342* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
343- new version to replace the one from libgr
344- patched for glibc
345- added shlib support
Note: See TracBrowser for help on using the repository browser.