source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 12415

Revision 12415, 13.3 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

c-ares-1.16.1-1

curl-7.70.0-1

libjpeg-turbo-2.0.4-2

libtiff-4.1.0-1

nghttp2-1.41.0-1

sqlite3-3.32.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.1.0
7Release: 1%{_dist_release}
8Group: System Environment/Libraries
9Vendor: Project Vine
10Distribution: Vine Linux
11Packager: daisuke, iwamoto
12
13License: distributable
14URL: http://www.simplesystems.org/libtiff/
15Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
16
17Patch0: libtiff-am-version.patch
18Patch1: libtiff-make-check.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: zlib-devel libjpeg-devel
22%define LIBVER %(echo %{version} | cut -f-2 -d.)
23%ifarch x86_64
24Provides: libtiff.so.4()(64bit)
25%else
26Provides: libtiff.so.4
27%endif
28Obsoletes: libtiff4
29
30%description
31The libtiff package contains a library of functions for manipulating
32TIFF (Tagged Image File Format) image format files.  TIFF is a widely
33used file format for bitmapped images.  TIFF files usually end in the
34.tif extension and they are often quite large.
35
36The libtiff package should be installed if you need to manipulate TIFF
37format image files.
38
39%description -l ja
40libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
41扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
42広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
43拡張子が使われ,サイズは概して大きめです.
44
45TIFF 形式の画像ファイルを扱う必要があるならば,
46libtiff パッケージを是非インストールして下さい.
47
48
49%package devel
50Summary: Development tools for programs which will use the libtiff library.
51Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
52Group: Development/Libraries
53Requires: libtiff = %{version}
54
55
56%description devel
57This package contains the header files and static libraries for
58developing programs which will manipulate TIFF format image files
59using the libtiff library.
60
61If you need to develop programs which will manipulate TIFF format
62image files, you should install this package.  You'll also need to
63install the libtiff package.
64
65#'
66%description devel -l ja
67このパッケージには,libtiff ライブラリを使って TIFF 形式の
68画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
69スタティックライブラリが収められています.
70
71TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
72このパッケージをインストールして下さい.libtiff パッケージも同時に
73インストールする必要があります.
74
75## to build compat32 for x86_64 architecture support
76%package -n compat32-%{name}
77Summary: A library of functions for manipulating TIFF format image files.
78Group: System Environment/Libraries
79Requires: %{name} = %{version}
80Provides: libtiff.so.4
81Obsoletes: compat32-libtiff4
82%description -n compat32-%{name}
83The libtiff package contains a library of functions for manipulating
84TIFF (Tagged Image File Format) image format files.  TIFF is a widely
85used file format for bitmapped images.  TIFF files usually end in the
86.tif extension and they are often quite large.
87
88The libtiff package should be installed if you need to manipulate TIFF
89format image files.
90
91%package -n compat32-%{name}-devel
92Summary: Development tools for programs which will use the libtiff library.
93Group: Development/Libraries
94Requires: compat32-%{name} = %{version}
95Requires: %{name}-devel = %{version}
96%description -n compat32-%{name}-devel
97This package contains the header files and static libraries for
98developing programs which will manipulate TIFF format image files
99using the libtiff library.
100
101If you need to develop programs which will manipulate TIFF format
102image files, you should install this package.  You'll also need to
103install the libtiff package.
104
105#'
106%prep
107%setup -q -n tiff-%{version}
108
109%patch0 -p1
110%patch1 -p1
111
112# Use build system's libtool.m4, not the one in the package.
113rm -f libtool.m4
114
115libtoolize --force  --copy
116aclocal -I . -I m4
117automake --add-missing --copy
118autoconf
119autoheader
120
121%build
122export CFLAGS="%{optflags} -fno-strict-aliasing"
123%configure \
124  --enable-ld-version-script \
125  --with-jpeg-lib-dir=%{_libdir} \
126  --disable-cxx
127%__make %{?_smp_mflags}
128%__make clean
129
130%install
131rm -fr %{buildroot}
132%makeinstall
133
134ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
135
136rm -rf %{buildroot}/usr/share/doc/tiff-%{version}
137rm -f %{buildroot}%{_libdir}/libtiff*.{a,la}
138
139
140%post -p /sbin/ldconfig
141
142%postun -p /sbin/ldconfig
143
144%if %{build_compat32}
145%post -n compat32-%{name} -p /sbin/ldconfig
146%postun -n compat32-%{name} -p /sbin/ldconfig
147%endif
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(-,root,root)
154%license COPYRIGHT
155%doc README RELEASE-DATE VERSION
156%{_bindir}/*
157%{_libdir}/libtiff*.so.*
158%{_mandir}/man1/*
159
160%files devel
161%defattr(-,root,root)
162%doc TODO html ChangeLog
163%{_includedir}/*
164%{_libdir}/libtiff*.so
165%{_libdir}/pkgconfig/*.pc
166%{_mandir}/man3/*
167
168## to build compat32 for x86_64 architecture support
169%if %{build_compat32}
170%files -n compat32-%{name}
171%defattr(-,root,root)
172%{_libdir}/libtiff.so.*
173
174%files -n compat32-%{name}-devel
175%defattr(-,root,root)
176%{_libdir}/libtiff.so
177%endif
178
179
180%changelog
181* Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.0-1
182- new upstream release.
183- dropped Patch1001-1004: fixed in upstream.
184
185* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-2
186- rebuilt with libjpeg.so.8.
187
188* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-1
189- new upstream release.
190- dropped Patch1000: fixed in upstream.
191- imported Patch1001-1003 from rawhide.
192- imported Patch1004 from upstream.
193
194* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
195- updated to 4.0.9.
196- added Patch1000 to fix CVE-2017-9935.
197
198* Sat Jun  3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
199- update to 4.0.8
200- drop patches; upstream fixed
201 - HylaFAX patch (Patch2)
202 - CVE patches (Patch3..16)
203
204* Sat May  6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
205- imported patches from rawhide.
206    - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
207    - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
208
209* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
210- new upstream release.
211- drooped patch1-11: fixed in upstream.
212
213* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
214- add patch1-11 from fc21 to fix security issues
215
216* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
217- new upstream release with security fix (CVE-2012-4447)
218- drop *.a files from -devel packages
219
220* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
221- new upstream release with security fixes (CVE-2012-2088, 2113)
222- drop patch1 (is included in new release)
223
224* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
225- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
226
227* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
228- fix R: for compat32 package
229
230* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
231- add libtiff.so.4 for compatibility
232- add pkgconfig file
233
234* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
235- new upstream release
236- add patch1 to fix CVE-2012-1173
237
238* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
239- new upstream release
240- drop all patches (are included in new release)
241- remove if-endif for Vine 4.x
242- add Vendor/Distri tags
243
244* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
245- add some patches from RHEL6 3.9.4-1.el6_0.3
246 - fix for CVE-2011-0192 (Patch11)
247 - fix for CVE-2011-1167 (Patch12)
248 - fix for CVE-2009-5022 (Patch13)
249
250* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
251- rebuilt with rpm-4.8.1-3
252
253* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
254- new upstream release
255- add patch4-10 from fedora
256
257* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
258- new upstream release
259- remove BC: freeglut-devel
260- add patch1,2,4,5 from fedora
261- drop obsolete patches
262
263* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
264- change if-endif to make both i386 and compat32 packages
265
266* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
267- add patch5 for fix CVE-2009-2347 (Integer Overflow)
268
269* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
270- add patch4 for fix lzw underflow security issue
271- add if branch Vine4/5 in devel files section (*.la are included or not)
272
273* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
274- removed *.la
275- spec in utf-8
276
277* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
278- fix changelog typo (3.8.4 -> 3.8.2)
279- new versioning policy
280- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
281
282* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
283- fix libdir in libtiff.la
284- add BuildConflicts: freeglut-devel
285
286* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
287- rebuilt without glut-devel
288
289* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
290- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
291
292* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
293- new upstream release
294- remove obsolete patches
295- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
296- delete duped docs
297- add --disable-cxx to configure option
298- add *.la to devel package
299
300* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
301- added compat32-* packages for x86_64 architecture support
302- added --with-jpeg-lib-dir=%{_libdir} to configure
303
304* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
305- new upstream release
306- remove obsolete patches
307- cleanup specs
308
309* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
310- rebuild for Vine3.1
311
312* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
313- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
314- update URL
315
316* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
317- build for Vine2.6
318
319* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
320- fix changelog: proper name
321
322* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
323- add symlink to shared lib by running ldconfig at compile time
324
325* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
326- add patch8-13 from Fedora Core
327--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
328--- fix some integer and buffer overflows (#134853, #134848)
329- add patch14 from SUSE LINUX
330--* Wed Oct 20 2004 - meissner@suse.de
331--- Do not crash if we are using unsupported codecs (like OJPEG).
332
333* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
334- rebuild with new toolchains
335- to use License instead of Copyright
336
337* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
338- 3.5.7-6vl1
339- based on 3.5.7-6 from Rawhide
340
341* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
342- 3.5.5-8vl1
343- based on 3.5.5-8 from Rawhide
344- added Japanese summary and description
345
346* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
347- rebuild
348
349* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
350- added a tiff-to-ps.fpi filter for printing
351
352* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
353- automatic rebuild
354
355* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
356- apply Peter Skarpetis's fix for the 32-bit conversion
357
358* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
359- make man pages non-executable (#12811)
360
361* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
362- remove CVS repo info from data directories
363
364* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
365- fix build rooting
366- fix syntax error in configure script
367- move man pages to %{_mandir}
368
369* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
370- rebuild for an errata release
371
372* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
373- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
374
375* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
376- fix fax2ps swapping height and width in the bounding box
377
378* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
379- move man pages from devel package to the regular one
380- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
381  of libtiff)
382- fix fax2ps breakage (bug #8345)
383
384* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
385- set MANDIR=man3 to make multifunction man pages friendlier
386
387* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
388- fix URLs
389
390* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
391- link shared library against libjpeg and libz
392
393* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
394- enable zip and jpeg codecs
395- change defattr in normal package to 0755
396- add defattr to -devel package
397
398* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
399- update to 3.5.4
400
401* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
402- auto rebuild in the new build environment (release 6)
403
404* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
405- build for glibc 2.1
406
407* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
408- translations modified for de
409
410* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
411- rebuilt against fixed jpeg libs (libjpeg-6b)
412
413* Thu May 07 1998 Prospector System <bugs@redhat.com>
414- translations modified for de, fr, tr
415
416* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
417- new version to replace the one from libgr
418- patched for glibc
419- added shlib support
Note: See TracBrowser for help on using the repository browser.