source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 12281

Revision 12281, 13.4 KB checked in by tomop, 5 years ago (diff)

updated 4 packages

hunspell-1.7.0-1

libtiff-4.0.10-2

msgpack-3.2.0-1

podofo-0.9.6-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.10
7Release: 2%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11
12URL: http://www.simplesystems.org/libtiff/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: zlib-devel libjpeg-devel
15%define LIBVER %(echo %{version} | cut -f-2 -d.)
16%ifarch x86_64
17Provides: libtiff.so.4()(64bit)
18%else
19Provides: libtiff.so.4
20%endif
21Obsoletes: libtiff4
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, iwamoto
26
27Patch0: libtiff-am-version.patch
28Patch1: libtiff-make-check.patch
29
30Patch1001: libtiff-CVE-2019-6128.patch
31Patch1002: libtiff-CVE-2018-12900_CVE-2019-7663.patch
32Patch1003: libtiff-CVE-2018-19210.patch
33Patch1004: CVE-2019-14973.patch
34
35%description
36The libtiff package contains a library of functions for manipulating
37TIFF (Tagged Image File Format) image format files.  TIFF is a widely
38used file format for bitmapped images.  TIFF files usually end in the
39.tif extension and they are often quite large.
40
41The libtiff package should be installed if you need to manipulate TIFF
42format image files.
43
44%description -l ja
45libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
46扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
47広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
48拡張子が使われ,サイズは概して大きめです.
49
50TIFF 形式の画像ファイルを扱う必要があるならば,
51libtiff パッケージを是非インストールして下さい.
52
53
54%package devel
55Summary: Development tools for programs which will use the libtiff library.
56Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
57Group: Development/Libraries
58Requires: libtiff = %{version}
59
60
61%description devel
62This package contains the header files and static libraries for
63developing programs which will manipulate TIFF format image files
64using the libtiff library.
65
66If you need to develop programs which will manipulate TIFF format
67image files, you should install this package.  You'll also need to
68install the libtiff package.
69
70#'
71%description devel -l ja
72このパッケージには,libtiff ライブラリを使って TIFF 形式の
73画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
74スタティックライブラリが収められています.
75
76TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
77このパッケージをインストールして下さい.libtiff パッケージも同時に
78インストールする必要があります.
79
80## to build compat32 for x86_64 architecture support
81%package -n compat32-%{name}
82Summary: A library of functions for manipulating TIFF format image files.
83Group: System Environment/Libraries
84Requires: %{name} = %{version}
85Provides: libtiff.so.4
86Obsoletes: compat32-libtiff4
87%description -n compat32-%{name}
88The libtiff package contains a library of functions for manipulating
89TIFF (Tagged Image File Format) image format files.  TIFF is a widely
90used file format for bitmapped images.  TIFF files usually end in the
91.tif extension and they are often quite large.
92
93The libtiff package should be installed if you need to manipulate TIFF
94format image files.
95
96%package -n compat32-%{name}-devel
97Summary: Development tools for programs which will use the libtiff library.
98Group: Development/Libraries
99Requires: compat32-%{name} = %{version}
100Requires: %{name}-devel = %{version}
101%description -n compat32-%{name}-devel
102This package contains the header files and static libraries for
103developing programs which will manipulate TIFF format image files
104using the libtiff library.
105
106If you need to develop programs which will manipulate TIFF format
107image files, you should install this package.  You'll also need to
108install the libtiff package.
109
110#'
111%prep
112%setup -q -n tiff-%{version}
113
114%patch0 -p1
115%patch1 -p1
116
117%patch1001 -p1
118%patch1002 -p1
119%patch1003 -p1
120%patch1004 -p1
121
122# Use build system's libtool.m4, not the one in the package.
123rm -f libtool.m4
124
125libtoolize --force  --copy
126aclocal -I . -I m4
127automake --add-missing --copy
128autoconf
129autoheader
130
131%build
132export CFLAGS="%{optflags} -fno-strict-aliasing"
133%configure \
134  --enable-ld-version-script \
135  --with-jpeg-lib-dir=%{_libdir} \
136  --disable-cxx
137%__make %{?_smp_mflags}
138%__make clean
139
140%install
141rm -fr %{buildroot}
142%makeinstall
143
144ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
145
146rm -rf %{buildroot}/usr/share/doc/tiff-%{version}
147rm -f %{buildroot}%{_libdir}/libtiff*.{a,la}
148
149
150%post -p /sbin/ldconfig
151
152%postun -p /sbin/ldconfig
153
154%if %{build_compat32}
155%post -n compat32-%{name} -p /sbin/ldconfig
156%postun -n compat32-%{name} -p /sbin/ldconfig
157%endif
158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%files
163%defattr(-,root,root)
164%license COPYRIGHT
165%doc README RELEASE-DATE VERSION
166%{_bindir}/*
167%{_libdir}/libtiff*.so.*
168%{_mandir}/man1/*
169
170%files devel
171%defattr(-,root,root)
172%doc TODO html ChangeLog
173%{_includedir}/*
174%{_libdir}/libtiff*.so
175%{_libdir}/pkgconfig/*.pc
176%{_mandir}/man3/*
177
178## to build compat32 for x86_64 architecture support
179%if %{build_compat32}
180%files -n compat32-%{name}
181%defattr(-,root,root)
182%{_libdir}/libtiff.so.*
183
184%files -n compat32-%{name}-devel
185%defattr(-,root,root)
186%{_libdir}/libtiff.so
187%endif
188
189
190%changelog
191* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-2
192- rebuilt with libjpeg.so.8.
193
194* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-1
195- new upstream release.
196- dropped Patch1000: fixed in upstream.
197- imported Patch1001-1003 from rawhide.
198- imported Patch1004 from upstream.
199
200* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
201- updated to 4.0.9.
202- added Patch1000 to fix CVE-2017-9935.
203
204* Sat Jun  3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
205- update to 4.0.8
206- drop patches; upstream fixed
207 - HylaFAX patch (Patch2)
208 - CVE patches (Patch3..16)
209
210* Sat May  6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
211- imported patches from rawhide.
212    - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
213    - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
214
215* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
216- new upstream release.
217- drooped patch1-11: fixed in upstream.
218
219* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
220- add patch1-11 from fc21 to fix security issues
221
222* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
223- new upstream release with security fix (CVE-2012-4447)
224- drop *.a files from -devel packages
225
226* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
227- new upstream release with security fixes (CVE-2012-2088, 2113)
228- drop patch1 (is included in new release)
229
230* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
231- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
232
233* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
234- fix R: for compat32 package
235
236* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
237- add libtiff.so.4 for compatibility
238- add pkgconfig file
239
240* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
241- new upstream release
242- add patch1 to fix CVE-2012-1173
243
244* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
245- new upstream release
246- drop all patches (are included in new release)
247- remove if-endif for Vine 4.x
248- add Vendor/Distri tags
249
250* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
251- add some patches from RHEL6 3.9.4-1.el6_0.3
252 - fix for CVE-2011-0192 (Patch11)
253 - fix for CVE-2011-1167 (Patch12)
254 - fix for CVE-2009-5022 (Patch13)
255
256* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
257- rebuilt with rpm-4.8.1-3
258
259* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
260- new upstream release
261- add patch4-10 from fedora
262
263* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
264- new upstream release
265- remove BC: freeglut-devel
266- add patch1,2,4,5 from fedora
267- drop obsolete patches
268
269* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
270- change if-endif to make both i386 and compat32 packages
271
272* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
273- add patch5 for fix CVE-2009-2347 (Integer Overflow)
274
275* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
276- add patch4 for fix lzw underflow security issue
277- add if branch Vine4/5 in devel files section (*.la are included or not)
278
279* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
280- removed *.la
281- spec in utf-8
282
283* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
284- fix changelog typo (3.8.4 -> 3.8.2)
285- new versioning policy
286- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
287
288* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
289- fix libdir in libtiff.la
290- add BuildConflicts: freeglut-devel
291
292* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
293- rebuilt without glut-devel
294
295* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
296- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
297
298* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
299- new upstream release
300- remove obsolete patches
301- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
302- delete duped docs
303- add --disable-cxx to configure option
304- add *.la to devel package
305
306* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
307- added compat32-* packages for x86_64 architecture support
308- added --with-jpeg-lib-dir=%{_libdir} to configure
309
310* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
311- new upstream release
312- remove obsolete patches
313- cleanup specs
314
315* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
316- rebuild for Vine3.1
317
318* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
319- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
320- update URL
321
322* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
323- build for Vine2.6
324
325* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
326- fix changelog: proper name
327
328* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
329- add symlink to shared lib by running ldconfig at compile time
330
331* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
332- add patch8-13 from Fedora Core
333--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
334--- fix some integer and buffer overflows (#134853, #134848)
335- add patch14 from SUSE LINUX
336--* Wed Oct 20 2004 - meissner@suse.de
337--- Do not crash if we are using unsupported codecs (like OJPEG).
338
339* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
340- rebuild with new toolchains
341- to use License instead of Copyright
342
343* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
344- 3.5.7-6vl1
345- based on 3.5.7-6 from Rawhide
346
347* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
348- 3.5.5-8vl1
349- based on 3.5.5-8 from Rawhide
350- added Japanese summary and description
351
352* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
353- rebuild
354
355* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
356- added a tiff-to-ps.fpi filter for printing
357
358* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
359- automatic rebuild
360
361* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
362- apply Peter Skarpetis's fix for the 32-bit conversion
363
364* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
365- make man pages non-executable (#12811)
366
367* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
368- remove CVS repo info from data directories
369
370* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
371- fix build rooting
372- fix syntax error in configure script
373- move man pages to %{_mandir}
374
375* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
376- rebuild for an errata release
377
378* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
379- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
380
381* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
382- fix fax2ps swapping height and width in the bounding box
383
384* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
385- move man pages from devel package to the regular one
386- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
387  of libtiff)
388- fix fax2ps breakage (bug #8345)
389
390* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
391- set MANDIR=man3 to make multifunction man pages friendlier
392
393* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
394- fix URLs
395
396* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
397- link shared library against libjpeg and libz
398
399* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
400- enable zip and jpeg codecs
401- change defattr in normal package to 0755
402- add defattr to -devel package
403
404* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
405- update to 3.5.4
406
407* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
408- auto rebuild in the new build environment (release 6)
409
410* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
411- build for glibc 2.1
412
413* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
414- translations modified for de
415
416* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
417- rebuilt against fixed jpeg libs (libjpeg-6b)
418
419* Thu May 07 1998 Prospector System <bugs@redhat.com>
420- translations modified for de, fr, tr
421
422* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
423- new version to replace the one from libgr
424- patched for glibc
425- added shlib support
Note: See TracBrowser for help on using the repository browser.