source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 12189

Revision 12189, 13.3 KB checked in by tomop, 5 years ago (diff)

updated image libs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.10
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11
12URL: http://www.simplesystems.org/libtiff/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: zlib-devel libjpeg-devel
15%define LIBVER %(echo %{version} | cut -f-2 -d.)
16%ifarch x86_64
17Provides: libtiff.so.4()(64bit)
18%else
19Provides: libtiff.so.4
20%endif
21Obsoletes: libtiff4
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, iwamoto
26
27Patch0: libtiff-am-version.patch
28Patch1: libtiff-make-check.patch
29
30Patch1001: libtiff-CVE-2019-6128.patch
31Patch1002: libtiff-CVE-2018-12900_CVE-2019-7663.patch
32Patch1003: libtiff-CVE-2018-19210.patch
33Patch1004: CVE-2019-14973.patch
34
35%description
36The libtiff package contains a library of functions for manipulating
37TIFF (Tagged Image File Format) image format files.  TIFF is a widely
38used file format for bitmapped images.  TIFF files usually end in the
39.tif extension and they are often quite large.
40
41The libtiff package should be installed if you need to manipulate TIFF
42format image files.
43
44%description -l ja
45libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
46扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
47広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
48拡張子が使われ,サイズは概して大きめです.
49
50TIFF 形式の画像ファイルを扱う必要があるならば,
51libtiff パッケージを是非インストールして下さい.
52
53
54%package devel
55Summary: Development tools for programs which will use the libtiff library.
56Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
57Group: Development/Libraries
58Requires: libtiff = %{version}
59
60
61%description devel
62This package contains the header files and static libraries for
63developing programs which will manipulate TIFF format image files
64using the libtiff library.
65
66If you need to develop programs which will manipulate TIFF format
67image files, you should install this package.  You'll also need to
68install the libtiff package.
69
70#'
71%description devel -l ja
72このパッケージには,libtiff ライブラリを使って TIFF 形式の
73画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
74スタティックライブラリが収められています.
75
76TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
77このパッケージをインストールして下さい.libtiff パッケージも同時に
78インストールする必要があります.
79
80## to build compat32 for x86_64 architecture support
81%package -n compat32-%{name}
82Summary: A library of functions for manipulating TIFF format image files.
83Group: System Environment/Libraries
84Requires: %{name} = %{version}
85Provides: libtiff.so.4
86Obsoletes: compat32-libtiff4
87%description -n compat32-%{name}
88The libtiff package contains a library of functions for manipulating
89TIFF (Tagged Image File Format) image format files.  TIFF is a widely
90used file format for bitmapped images.  TIFF files usually end in the
91.tif extension and they are often quite large.
92
93The libtiff package should be installed if you need to manipulate TIFF
94format image files.
95
96%package -n compat32-%{name}-devel
97Summary: Development tools for programs which will use the libtiff library.
98Group: Development/Libraries
99Requires: compat32-%{name} = %{version}
100Requires: %{name}-devel = %{version}
101%description -n compat32-%{name}-devel
102This package contains the header files and static libraries for
103developing programs which will manipulate TIFF format image files
104using the libtiff library.
105
106If you need to develop programs which will manipulate TIFF format
107image files, you should install this package.  You'll also need to
108install the libtiff package.
109
110#'
111%prep
112%setup -q -n tiff-%{version}
113
114%patch0 -p1
115%patch1 -p1
116
117%patch1001 -p1
118%patch1002 -p1
119%patch1003 -p1
120%patch1004 -p1
121
122# Use build system's libtool.m4, not the one in the package.
123rm -f libtool.m4
124
125libtoolize --force  --copy
126aclocal -I . -I m4
127automake --add-missing --copy
128autoconf
129autoheader
130
131%build
132export CFLAGS="%{optflags} -fno-strict-aliasing"
133%configure \
134  --enable-ld-version-script \
135  --with-jpeg-lib-dir=%{_libdir} \
136  --disable-cxx
137%__make %{?_smp_mflags}
138%__make clean
139
140%install
141rm -fr %{buildroot}
142%makeinstall
143
144ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
145
146rm -rf %{buildroot}/usr/share/doc/tiff-%{version}
147rm -f %{buildroot}%{_libdir}/libtiff*.{a,la}
148
149
150%post -p /sbin/ldconfig
151
152%postun -p /sbin/ldconfig
153
154%if %{build_compat32}
155%post -n compat32-%{name} -p /sbin/ldconfig
156%postun -n compat32-%{name} -p /sbin/ldconfig
157%endif
158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%files
163%defattr(-,root,root)
164%doc COPYRIGHT README RELEASE-DATE VERSION
165%{_bindir}/*
166%{_libdir}/libtiff*.so.*
167%{_mandir}/man1/*
168
169%files devel
170%defattr(-,root,root)
171%doc TODO html ChangeLog
172%{_includedir}/*
173%{_libdir}/libtiff*.so
174%{_libdir}/pkgconfig/*.pc
175%{_mandir}/man3/*
176
177## to build compat32 for x86_64 architecture support
178%if %{build_compat32}
179%files -n compat32-%{name}
180%defattr(-,root,root)
181%{_libdir}/libtiff.so.*
182
183%files -n compat32-%{name}-devel
184%defattr(-,root,root)
185%{_libdir}/libtiff.so
186%endif
187
188
189%changelog
190* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-1
191- new upstream release.
192- dropped Patch1000: fixed in upstream.
193- imported Patch1001-1003 from rawhide.
194- imported Patch1004 from upstream.
195
196* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
197- updated to 4.0.9.
198- added Patch1000 to fix CVE-2017-9935.
199
200* Sat Jun  3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
201- update to 4.0.8
202- drop patches; upstream fixed
203 - HylaFAX patch (Patch2)
204 - CVE patches (Patch3..16)
205
206* Sat May  6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
207- imported patches from rawhide.
208    - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
209    - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
210
211* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
212- new upstream release.
213- drooped patch1-11: fixed in upstream.
214
215* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
216- add patch1-11 from fc21 to fix security issues
217
218* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
219- new upstream release with security fix (CVE-2012-4447)
220- drop *.a files from -devel packages
221
222* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
223- new upstream release with security fixes (CVE-2012-2088, 2113)
224- drop patch1 (is included in new release)
225
226* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
227- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
228
229* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
230- fix R: for compat32 package
231
232* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
233- add libtiff.so.4 for compatibility
234- add pkgconfig file
235
236* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
237- new upstream release
238- add patch1 to fix CVE-2012-1173
239
240* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
241- new upstream release
242- drop all patches (are included in new release)
243- remove if-endif for Vine 4.x
244- add Vendor/Distri tags
245
246* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
247- add some patches from RHEL6 3.9.4-1.el6_0.3
248 - fix for CVE-2011-0192 (Patch11)
249 - fix for CVE-2011-1167 (Patch12)
250 - fix for CVE-2009-5022 (Patch13)
251
252* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
253- rebuilt with rpm-4.8.1-3
254
255* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
256- new upstream release
257- add patch4-10 from fedora
258
259* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
260- new upstream release
261- remove BC: freeglut-devel
262- add patch1,2,4,5 from fedora
263- drop obsolete patches
264
265* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
266- change if-endif to make both i386 and compat32 packages
267
268* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
269- add patch5 for fix CVE-2009-2347 (Integer Overflow)
270
271* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
272- add patch4 for fix lzw underflow security issue
273- add if branch Vine4/5 in devel files section (*.la are included or not)
274
275* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
276- removed *.la
277- spec in utf-8
278
279* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
280- fix changelog typo (3.8.4 -> 3.8.2)
281- new versioning policy
282- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
283
284* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
285- fix libdir in libtiff.la
286- add BuildConflicts: freeglut-devel
287
288* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
289- rebuilt without glut-devel
290
291* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
292- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
293
294* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
295- new upstream release
296- remove obsolete patches
297- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
298- delete duped docs
299- add --disable-cxx to configure option
300- add *.la to devel package
301
302* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
303- added compat32-* packages for x86_64 architecture support
304- added --with-jpeg-lib-dir=%{_libdir} to configure
305
306* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
307- new upstream release
308- remove obsolete patches
309- cleanup specs
310
311* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
312- rebuild for Vine3.1
313
314* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
315- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
316- update URL
317
318* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
319- build for Vine2.6
320
321* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
322- fix changelog: proper name
323
324* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
325- add symlink to shared lib by running ldconfig at compile time
326
327* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
328- add patch8-13 from Fedora Core
329--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
330--- fix some integer and buffer overflows (#134853, #134848)
331- add patch14 from SUSE LINUX
332--* Wed Oct 20 2004 - meissner@suse.de
333--- Do not crash if we are using unsupported codecs (like OJPEG).
334
335* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
336- rebuild with new toolchains
337- to use License instead of Copyright
338
339* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
340- 3.5.7-6vl1
341- based on 3.5.7-6 from Rawhide
342
343* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
344- 3.5.5-8vl1
345- based on 3.5.5-8 from Rawhide
346- added Japanese summary and description
347
348* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
349- rebuild
350
351* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
352- added a tiff-to-ps.fpi filter for printing
353
354* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
355- automatic rebuild
356
357* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
358- apply Peter Skarpetis's fix for the 32-bit conversion
359
360* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
361- make man pages non-executable (#12811)
362
363* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
364- remove CVS repo info from data directories
365
366* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
367- fix build rooting
368- fix syntax error in configure script
369- move man pages to %{_mandir}
370
371* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
372- rebuild for an errata release
373
374* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
375- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
376
377* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
378- fix fax2ps swapping height and width in the bounding box
379
380* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
381- move man pages from devel package to the regular one
382- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
383  of libtiff)
384- fix fax2ps breakage (bug #8345)
385
386* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
387- set MANDIR=man3 to make multifunction man pages friendlier
388
389* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
390- fix URLs
391
392* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
393- link shared library against libjpeg and libz
394
395* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
396- enable zip and jpeg codecs
397- change defattr in normal package to 0755
398- add defattr to -devel package
399
400* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
401- update to 3.5.4
402
403* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
404- auto rebuild in the new build environment (release 6)
405
406* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
407- build for glibc 2.1
408
409* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
410- translations modified for de
411
412* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
413- rebuilt against fixed jpeg libs (libjpeg-6b)
414
415* Thu May 07 1998 Prospector System <bugs@redhat.com>
416- translations modified for de, fr, tr
417
418* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
419- new version to replace the one from libgr
420- patched for glibc
421- added shlib support
Note: See TracBrowser for help on using the repository browser.