source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 521

Revision 521, 10.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 3.9.2
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12Patch1: libtiff-acversion.patch
13Patch2: libtiff-mantypo.patch
14Patch3: libtiff-CVE-2009-2347.patch
15Patch4: libtiff-jpeg-scanline.patch
16Patch5: libtiff-scanlinesize.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: zlib-devel zlib libjpeg-devel libjpeg
20Requires: zlib libjpeg
21%define LIBVER %(echo %{version} | cut -f-2 -d.)
22
23
24%description
25The libtiff package contains a library of functions for manipulating
26TIFF (Tagged Image File Format) image format files.  TIFF is a widely
27used file format for bitmapped images.  TIFF files usually end in the
28.tif extension and they are often quite large.
29
30The libtiff package should be installed if you need to manipulate TIFF
31format image files.
32
33%description -l ja
34libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
35扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
36広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
37拡張子が使われ,サイズは概して大きめです.
38
39TIFF 形式の画像ファイルを扱う必要があるならば,
40libtiff パッケージを是非インストールして下さい.
41
42
43%package devel
44Summary: Development tools for programs which will use the libtiff library.
45Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
46Group: Development/Libraries
47Requires: libtiff = %{version}
48
49
50%description devel
51This package contains the header files and static libraries for
52developing programs which will manipulate TIFF format image files
53using the libtiff library.
54
55If you need to develop programs which will manipulate TIFF format
56image files, you should install this package.  You'll also need to
57install the libtiff package.
58
59#'
60%description devel -l ja
61このパッケージには,libtiff ライブラリを使って TIFF 形式の
62画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
63スタティックライブラリが収められています.
64
65TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
66このパッケージをインストールして下さい.libtiff パッケージも同時に
67インストールする必要があります.
68
69## to build compat32 for x86_64 architecture support
70%package -n compat32-%{name}
71Summary: A library of functions for manipulating TIFF format image files.
72Group: System Environment/Libraries
73Requires: zlib libjpeg
74Requires: %{name} = %{version}
75%description -n compat32-%{name}
76The libtiff package contains a library of functions for manipulating
77TIFF (Tagged Image File Format) image format files.  TIFF is a widely
78used file format for bitmapped images.  TIFF files usually end in the
79.tif extension and they are often quite large.
80
81The libtiff package should be installed if you need to manipulate TIFF
82format image files.
83
84%package -n compat32-%{name}-devel
85Summary: Development tools for programs which will use the libtiff library.
86Group: Development/Libraries
87Requires: compat32-%{name} = %{version}
88%description -n compat32-%{name}-devel
89This package contains the header files and static libraries for
90developing programs which will manipulate TIFF format image files
91using the libtiff library.
92
93If you need to develop programs which will manipulate TIFF format
94image files, you should install this package.  You'll also need to
95install the libtiff package.
96
97#'
98%prep
99%setup -q -n tiff-%{version}
100%patch1 -p1 -b .acversion
101%patch2 -p1 -b .mantypo
102%patch3 -p1 -b .CVS-2009-2347
103%patch4 -p1 -b jpeg-scanline
104%patch5 -p1 -b .scanlinesize
105
106%build
107%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
108%__make %{?_smp_mflags}
109%__make clean
110
111
112%install
113rm -fr $RPM_BUILD_ROOT
114%makeinstall
115rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
116
117# fix libdir in .la
118perl -pi -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
119
120
121%post -p /sbin/ldconfig
122
123
124%postun -p /sbin/ldconfig
125
126%if %{build_compat32}
127%post -n compat32-%{name} -p /sbin/ldconfig
128%postun -n compat32-%{name} -p /sbin/ldconfig
129%endif
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%files
135%defattr(-,root,root)
136%doc COPYRIGHT README RELEASE-DATE VERSION
137%{_bindir}/*
138%{_libdir}/libtiff*.so.*
139%{_mandir}/man1/*
140
141
142%files devel
143%defattr(-,root,root)
144%doc TODO html ChangeLog
145%{_includedir}/*
146%{_libdir}/libtiff*.so
147%{_libdir}/libtiff*.a
148%if %{_dist_release}=="vl4"
149# for Vine 4.x
150%{_libdir}/libtiff*.la
151%endif
152%{_mandir}/man3/*
153
154## to build compat32 for x86_64 architecture support
155%if %{build_compat32}
156%files -n compat32-%{name}
157%defattr(-,root,root)
158%{_libdir}/libtiff.so.*
159
160%files -n compat32-%{name}-devel
161%defattr(-,root,root)
162%{_libdir}/libtiff.so
163%{_libdir}/libtiff.a
164# %{_libdir}/libtiff.la
165%endif
166
167
168%changelog
169* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
170- new upstream release
171- remove BC: freeglut-devel
172- add patch1,2,4,5 from fedora
173- drop obsolete patches
174
175* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
176- change if-endif to make both i386 and compat32 packages
177
178* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
179- add patch5 for fix CVE-2009-2347 (Integer Overflow)
180
181* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
182- add patch4 for fix lzw underflow security issue
183- add if branch Vine4/5 in devel files section (*.la are included or not)
184
185* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
186- removed *.la
187- spec in utf-8
188
189* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
190- fix changelog typo (3.8.4 -> 3.8.2)
191- new versioning policy
192- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
193
194* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
195- fix libdir in libtiff.la
196- add BuildConflicts: freeglut-devel
197
198* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
199- rebuilt without glut-devel
200
201* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
202- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
203
204* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
205- new upstream release
206- remove obsolete patches
207- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
208- delete duped docs
209- add --disable-cxx to configure option
210- add *.la to devel package
211
212* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
213- added compat32-* packages for x86_64 architecture support
214- added --with-jpeg-lib-dir=%{_libdir} to configure
215
216* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
217- new upstream release
218- remove obsolete patches
219- cleanup specs
220
221* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
222- rebuild for Vine3.1
223
224* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
225- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
226- update URL
227
228* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
229- build for Vine2.6
230
231* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
232- fix changelog: proper name
233
234* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
235- add symlink to shared lib by running ldconfig at compile time
236
237* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
238- add patch8-13 from Fedora Core
239--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
240--- fix some integer and buffer overflows (#134853, #134848)
241- add patch14 from SUSE LINUX
242--* Wed Oct 20 2004 - meissner@suse.de
243--- Do not crash if we are using unsupported codecs (like OJPEG).
244
245* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
246- rebuild with new toolchains
247- to use License instead of Copyright
248
249* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
250- 3.5.7-6vl1
251- based on 3.5.7-6 from Rawhide
252
253* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
254- 3.5.5-8vl1
255- based on 3.5.5-8 from Rawhide
256- added Japanese summary and description
257
258* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
259- rebuild
260
261* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
262- added a tiff-to-ps.fpi filter for printing
263
264* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
265- automatic rebuild
266
267* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
268- apply Peter Skarpetis's fix for the 32-bit conversion
269
270* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
271- make man pages non-executable (#12811)
272
273* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
274- remove CVS repo info from data directories
275
276* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
277- fix build rooting
278- fix syntax error in configure script
279- move man pages to %{_mandir}
280
281* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
282- rebuild for an errata release
283
284* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
285- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
286
287* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
288- fix fax2ps swapping height and width in the bounding box
289
290* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
291- move man pages from devel package to the regular one
292- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
293  of libtiff)
294- fix fax2ps breakage (bug #8345)
295
296* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
297- set MANDIR=man3 to make multifunction man pages friendlier
298
299* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
300- fix URLs
301
302* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
303- link shared library against libjpeg and libz
304
305* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
306- enable zip and jpeg codecs
307- change defattr in normal package to 0755
308- add defattr to -devel package
309
310* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
311- update to 3.5.4
312
313* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
314- auto rebuild in the new build environment (release 6)
315
316* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
317- build for glibc 2.1
318
319* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
320- translations modified for de
321
322* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
323- rebuilt against fixed jpeg libs (libjpeg-6b)
324
325* Thu May 07 1998 Prospector System <bugs@redhat.com>
326- translations modified for de, fr, tr
327
328* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
329- new version to replace the one from libgr
330- patched for glibc
331- added shlib support
Note: See TracBrowser for help on using the repository browser.