source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 10954

Revision 10954, 12.0 KB checked in by tomop, 7 years ago (diff)

gd-2.2.4-1 g/gd/gd-vl.spec

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.7
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11
12URL: http://www.remotesensing.org/libtiff/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: zlib-devel libjpeg-devel
15%define LIBVER %(echo %{version} | cut -f-2 -d.)
16%ifarch x86_64
17Provides: libtiff.so.4()(64bit)
18%else
19Provides: libtiff.so.4
20%endif
21Obsoletes: libtiff4
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, iwamoto
26
27%description
28The libtiff package contains a library of functions for manipulating
29TIFF (Tagged Image File Format) image format files.  TIFF is a widely
30used file format for bitmapped images.  TIFF files usually end in the
31.tif extension and they are often quite large.
32
33The libtiff package should be installed if you need to manipulate TIFF
34format image files.
35
36%description -l ja
37libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
38扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
39広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
40拡張子が使われ,サイズは概して大きめです.
41
42TIFF 形式の画像ファイルを扱う必要があるならば,
43libtiff パッケージを是非インストールして下さい.
44
45
46%package devel
47Summary: Development tools for programs which will use the libtiff library.
48Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
49Group: Development/Libraries
50Requires: libtiff = %{version}
51
52
53%description devel
54This package contains the header files and static libraries for
55developing programs which will manipulate TIFF format image files
56using the libtiff library.
57
58If you need to develop programs which will manipulate TIFF format
59image files, you should install this package.  You'll also need to
60install the libtiff package.
61
62#'
63%description devel -l ja
64このパッケージには,libtiff ライブラリを使って TIFF 形式の
65画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
66スタティックライブラリが収められています.
67
68TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
69このパッケージをインストールして下さい.libtiff パッケージも同時に
70インストールする必要があります.
71
72## to build compat32 for x86_64 architecture support
73%package -n compat32-%{name}
74Summary: A library of functions for manipulating TIFF format image files.
75Group: System Environment/Libraries
76Requires: %{name} = %{version}
77Provides: libtiff.so.4
78Obsoletes: compat32-libtiff4
79%description -n compat32-%{name}
80The libtiff package contains a library of functions for manipulating
81TIFF (Tagged Image File Format) image format files.  TIFF is a widely
82used file format for bitmapped images.  TIFF files usually end in the
83.tif extension and they are often quite large.
84
85The libtiff package should be installed if you need to manipulate TIFF
86format image files.
87
88%package -n compat32-%{name}-devel
89Summary: Development tools for programs which will use the libtiff library.
90Group: Development/Libraries
91Requires: compat32-%{name} = %{version}
92Requires: %{name}-devel = %{version}
93%description -n compat32-%{name}-devel
94This package contains the header files and static libraries for
95developing programs which will manipulate TIFF format image files
96using the libtiff library.
97
98If you need to develop programs which will manipulate TIFF format
99image files, you should install this package.  You'll also need to
100install the libtiff package.
101
102#'
103%prep
104%setup -q -n tiff-%{version}
105
106%build
107%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
108%__make %{?_smp_mflags}
109%__make clean
110
111
112%install
113rm -fr $RPM_BUILD_ROOT
114%makeinstall
115rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
116
117ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
118
119rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
120
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%if %{build_compat32}
127%post -n compat32-%{name} -p /sbin/ldconfig
128%postun -n compat32-%{name} -p /sbin/ldconfig
129%endif
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%files
135%defattr(-,root,root)
136%doc COPYRIGHT README RELEASE-DATE VERSION
137%{_bindir}/*
138%{_libdir}/libtiff*.so.*
139%{_mandir}/man1/*
140
141%files devel
142%defattr(-,root,root)
143%doc TODO html ChangeLog
144%{_includedir}/*
145%{_libdir}/libtiff*.so
146%{_libdir}/pkgconfig/*.pc
147%{_mandir}/man3/*
148
149## to build compat32 for x86_64 architecture support
150%if %{build_compat32}
151%files -n compat32-%{name}
152%defattr(-,root,root)
153%{_libdir}/libtiff.so.*
154
155%files -n compat32-%{name}-devel
156%defattr(-,root,root)
157%{_libdir}/libtiff.so
158%endif
159
160
161%changelog
162* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
163- new upstream release.
164- drooped patch1-11: fixed in upstream.
165
166* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
167- add patch1-11 from fc21 to fix security issues
168
169* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
170- new upstream release with security fix (CVE-2012-4447)
171- drop *.a files from -devel packages
172
173* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
174- new upstream release with security fixes (CVE-2012-2088, 2113)
175- drop patch1 (is included in new release)
176
177* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
178- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
179
180* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
181- fix R: for compat32 package
182
183* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
184- add libtiff.so.4 for compatibility
185- add pkgconfig file
186
187* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
188- new upstream release
189- add patch1 to fix CVE-2012-1173
190
191* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
192- new upstream release
193- drop all patches (are included in new release)
194- remove if-endif for Vine 4.x
195- add Vendor/Distri tags
196
197* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
198- add some patches from RHEL6 3.9.4-1.el6_0.3
199 - fix for CVE-2011-0192 (Patch11)
200 - fix for CVE-2011-1167 (Patch12)
201 - fix for CVE-2009-5022 (Patch13)
202
203* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
204- rebuilt with rpm-4.8.1-3
205
206* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
207- new upstream release
208- add patch4-10 from fedora
209
210* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
211- new upstream release
212- remove BC: freeglut-devel
213- add patch1,2,4,5 from fedora
214- drop obsolete patches
215
216* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
217- change if-endif to make both i386 and compat32 packages
218
219* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
220- add patch5 for fix CVE-2009-2347 (Integer Overflow)
221
222* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
223- add patch4 for fix lzw underflow security issue
224- add if branch Vine4/5 in devel files section (*.la are included or not)
225
226* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
227- removed *.la
228- spec in utf-8
229
230* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
231- fix changelog typo (3.8.4 -> 3.8.2)
232- new versioning policy
233- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
234
235* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
236- fix libdir in libtiff.la
237- add BuildConflicts: freeglut-devel
238
239* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
240- rebuilt without glut-devel
241
242* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
243- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
244
245* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
246- new upstream release
247- remove obsolete patches
248- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
249- delete duped docs
250- add --disable-cxx to configure option
251- add *.la to devel package
252
253* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
254- added compat32-* packages for x86_64 architecture support
255- added --with-jpeg-lib-dir=%{_libdir} to configure
256
257* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
258- new upstream release
259- remove obsolete patches
260- cleanup specs
261
262* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
263- rebuild for Vine3.1
264
265* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
266- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
267- update URL
268
269* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
270- build for Vine2.6
271
272* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
273- fix changelog: proper name
274
275* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
276- add symlink to shared lib by running ldconfig at compile time
277
278* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
279- add patch8-13 from Fedora Core
280--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
281--- fix some integer and buffer overflows (#134853, #134848)
282- add patch14 from SUSE LINUX
283--* Wed Oct 20 2004 - meissner@suse.de
284--- Do not crash if we are using unsupported codecs (like OJPEG).
285
286* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
287- rebuild with new toolchains
288- to use License instead of Copyright
289
290* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
291- 3.5.7-6vl1
292- based on 3.5.7-6 from Rawhide
293
294* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
295- 3.5.5-8vl1
296- based on 3.5.5-8 from Rawhide
297- added Japanese summary and description
298
299* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
300- rebuild
301
302* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
303- added a tiff-to-ps.fpi filter for printing
304
305* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
306- automatic rebuild
307
308* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
309- apply Peter Skarpetis's fix for the 32-bit conversion
310
311* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
312- make man pages non-executable (#12811)
313
314* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
315- remove CVS repo info from data directories
316
317* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
318- fix build rooting
319- fix syntax error in configure script
320- move man pages to %{_mandir}
321
322* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
323- rebuild for an errata release
324
325* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
326- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
327
328* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
329- fix fax2ps swapping height and width in the bounding box
330
331* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
332- move man pages from devel package to the regular one
333- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
334  of libtiff)
335- fix fax2ps breakage (bug #8345)
336
337* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
338- set MANDIR=man3 to make multifunction man pages friendlier
339
340* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
341- fix URLs
342
343* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
344- link shared library against libjpeg and libz
345
346* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
347- enable zip and jpeg codecs
348- change defattr in normal package to 0755
349- add defattr to -devel package
350
351* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
352- update to 3.5.4
353
354* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
355- auto rebuild in the new build environment (release 6)
356
357* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
358- build for glibc 2.1
359
360* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
361- translations modified for de
362
363* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
364- rebuilt against fixed jpeg libs (libjpeg-6b)
365
366* Thu May 07 1998 Prospector System <bugs@redhat.com>
367- translations modified for de, fr, tr
368
369* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
370- new version to replace the one from libgr
371- patched for glibc
372- added shlib support
Note: See TracBrowser for help on using the repository browser.