source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 8079

Revision 8079, 12.5 KB checked in by iwamoto, 10 years ago (diff)

libtiff: seed libtiff security patch
stone: add R:gcc-cpp

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.3
7Release: 2%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11
12Patch1: libtiff-CVE-2012-4447.patch
13Patch2: libtiff-CVE-2012-4564.patch
14Patch3: libtiff-printdir-width.patch
15Patch4: libtiff-jpeg-test.patch
16Patch5: libtiff-CVE-2013-1960.patch
17Patch6: libtiff-CVE-2013-1961.patch
18Patch7: libtiff-manpage-update.patch
19Patch8: libtiff-CVE-2013-4231.patch
20Patch9: libtiff-CVE-2013-4232.patch
21Patch10: libtiff-CVE-2013-4244.patch
22Patch11: libtiff-make-check.patch
23
24URL: http://www.remotesensing.org/libtiff/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: zlib-devel libjpeg-devel
27%define LIBVER %(echo %{version} | cut -f-2 -d.)
28%ifarch x86_64
29Provides: libtiff.so.4()(64bit)
30%else
31Provides: libtiff.so.4
32%endif
33Obsoletes: libtiff4
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: daisuke, iwamoto
38
39%description
40The libtiff package contains a library of functions for manipulating
41TIFF (Tagged Image File Format) image format files.  TIFF is a widely
42used file format for bitmapped images.  TIFF files usually end in the
43.tif extension and they are often quite large.
44
45The libtiff package should be installed if you need to manipulate TIFF
46format image files.
47
48%description -l ja
49libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
50扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
51広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
52拡張子が使われ,サイズは概して大きめです.
53
54TIFF 形式の画像ファイルを扱う必要があるならば,
55libtiff パッケージを是非インストールして下さい.
56
57
58%package devel
59Summary: Development tools for programs which will use the libtiff library.
60Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
61Group: Development/Libraries
62Requires: libtiff = %{version}
63
64
65%description devel
66This package contains the header files and static libraries for
67developing programs which will manipulate TIFF format image files
68using the libtiff library.
69
70If you need to develop programs which will manipulate TIFF format
71image files, you should install this package.  You'll also need to
72install the libtiff package.
73
74#'
75%description devel -l ja
76このパッケージには,libtiff ライブラリを使って TIFF 形式の
77画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
78スタティックライブラリが収められています.
79
80TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
81このパッケージをインストールして下さい.libtiff パッケージも同時に
82インストールする必要があります.
83
84## to build compat32 for x86_64 architecture support
85%package -n compat32-%{name}
86Summary: A library of functions for manipulating TIFF format image files.
87Group: System Environment/Libraries
88Requires: %{name} = %{version}
89Provides: libtiff.so.4
90Obsoletes: compat32-libtiff4
91%description -n compat32-%{name}
92The libtiff package contains a library of functions for manipulating
93TIFF (Tagged Image File Format) image format files.  TIFF is a widely
94used file format for bitmapped images.  TIFF files usually end in the
95.tif extension and they are often quite large.
96
97The libtiff package should be installed if you need to manipulate TIFF
98format image files.
99
100%package -n compat32-%{name}-devel
101Summary: Development tools for programs which will use the libtiff library.
102Group: Development/Libraries
103Requires: compat32-%{name} = %{version}
104Requires: %{name}-devel = %{version}
105%description -n compat32-%{name}-devel
106This package contains the header files and static libraries for
107developing programs which will manipulate TIFF format image files
108using the libtiff library.
109
110If you need to develop programs which will manipulate TIFF format
111image files, you should install this package.  You'll also need to
112install the libtiff package.
113
114#'
115%prep
116%setup -q -n tiff-%{version}
117
118%patch1 -p1 -b .CVE-2012-4447
119%patch2 -p1 -b .CVE-2012-4564
120%patch3 -p1 -b .printdir-width
121%patch4 -p1 -b .jpeg-test
122%patch5 -p1 -b .CVE-2013-1960
123%patch6 -p1 -b .CVE-2013-1961
124%patch7 -p1 -b .manpage-update
125%patch8 -p1 -b .CVE-2013-4231
126%patch9 -p1 -b .CVE-2013-4232
127%patch10 -p1 -b .CVE-2013-4244
128%patch11 -p1
129
130%build
131%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
132%__make %{?_smp_mflags}
133%__make clean
134
135
136%install
137rm -fr $RPM_BUILD_ROOT
138%makeinstall
139rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
140
141ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
142
143rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
144
145
146%post -p /sbin/ldconfig
147
148%postun -p /sbin/ldconfig
149
150%if %{build_compat32}
151%post -n compat32-%{name} -p /sbin/ldconfig
152%postun -n compat32-%{name} -p /sbin/ldconfig
153%endif
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%files
159%defattr(-,root,root)
160%doc COPYRIGHT README RELEASE-DATE VERSION
161%{_bindir}/*
162%{_libdir}/libtiff*.so.*
163%{_mandir}/man1/*
164
165%files devel
166%defattr(-,root,root)
167%doc TODO html ChangeLog
168%{_includedir}/*
169%{_libdir}/libtiff*.so
170%{_libdir}/pkgconfig/*.pc
171%{_mandir}/man3/*
172
173## to build compat32 for x86_64 architecture support
174%if %{build_compat32}
175%files -n compat32-%{name}
176%defattr(-,root,root)
177%{_libdir}/libtiff.so.*
178
179%files -n compat32-%{name}-devel
180%defattr(-,root,root)
181%{_libdir}/libtiff.so
182%endif
183
184
185%changelog
186* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
187- add patch1-11 from fc21 to fix security issues
188
189* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
190- new upstream release with security fix (CVE-2012-4447)
191- drop *.a files from -devel packages
192
193* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
194- new upstream release with security fixes (CVE-2012-2088, 2113)
195- drop patch1 (is included in new release)
196
197* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
198- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
199
200* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
201- fix R: for compat32 package
202
203* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
204- add libtiff.so.4 for compatibility
205- add pkgconfig file
206
207* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
208- new upstream release
209- add patch1 to fix CVE-2012-1173
210
211* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
212- new upstream release
213- drop all patches (are included in new release)
214- remove if-endif for Vine 4.x
215- add Vendor/Distri tags
216
217* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
218- add some patches from RHEL6 3.9.4-1.el6_0.3
219 - fix for CVE-2011-0192 (Patch11)
220 - fix for CVE-2011-1167 (Patch12)
221 - fix for CVE-2009-5022 (Patch13)
222
223* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
224- rebuilt with rpm-4.8.1-3
225
226* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
227- new upstream release
228- add patch4-10 from fedora
229
230* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
231- new upstream release
232- remove BC: freeglut-devel
233- add patch1,2,4,5 from fedora
234- drop obsolete patches
235
236* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
237- change if-endif to make both i386 and compat32 packages
238
239* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
240- add patch5 for fix CVE-2009-2347 (Integer Overflow)
241
242* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
243- add patch4 for fix lzw underflow security issue
244- add if branch Vine4/5 in devel files section (*.la are included or not)
245
246* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
247- removed *.la
248- spec in utf-8
249
250* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
251- fix changelog typo (3.8.4 -> 3.8.2)
252- new versioning policy
253- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
254
255* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
256- fix libdir in libtiff.la
257- add BuildConflicts: freeglut-devel
258
259* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
260- rebuilt without glut-devel
261
262* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
263- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
264
265* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
266- new upstream release
267- remove obsolete patches
268- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
269- delete duped docs
270- add --disable-cxx to configure option
271- add *.la to devel package
272
273* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
274- added compat32-* packages for x86_64 architecture support
275- added --with-jpeg-lib-dir=%{_libdir} to configure
276
277* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
278- new upstream release
279- remove obsolete patches
280- cleanup specs
281
282* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
283- rebuild for Vine3.1
284
285* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
286- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
287- update URL
288
289* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
290- build for Vine2.6
291
292* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
293- fix changelog: proper name
294
295* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
296- add symlink to shared lib by running ldconfig at compile time
297
298* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
299- add patch8-13 from Fedora Core
300--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
301--- fix some integer and buffer overflows (#134853, #134848)
302- add patch14 from SUSE LINUX
303--* Wed Oct 20 2004 - meissner@suse.de
304--- Do not crash if we are using unsupported codecs (like OJPEG).
305
306* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
307- rebuild with new toolchains
308- to use License instead of Copyright
309
310* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
311- 3.5.7-6vl1
312- based on 3.5.7-6 from Rawhide
313
314* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
315- 3.5.5-8vl1
316- based on 3.5.5-8 from Rawhide
317- added Japanese summary and description
318
319* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
320- rebuild
321
322* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
323- added a tiff-to-ps.fpi filter for printing
324
325* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
326- automatic rebuild
327
328* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
329- apply Peter Skarpetis's fix for the 32-bit conversion
330
331* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
332- make man pages non-executable (#12811)
333
334* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
335- remove CVS repo info from data directories
336
337* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
338- fix build rooting
339- fix syntax error in configure script
340- move man pages to %{_mandir}
341
342* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
343- rebuild for an errata release
344
345* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
346- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
347
348* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
349- fix fax2ps swapping height and width in the bounding box
350
351* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
352- move man pages from devel package to the regular one
353- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
354  of libtiff)
355- fix fax2ps breakage (bug #8345)
356
357* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
358- set MANDIR=man3 to make multifunction man pages friendlier
359
360* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
361- fix URLs
362
363* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
364- link shared library against libjpeg and libz
365
366* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
367- enable zip and jpeg codecs
368- change defattr in normal package to 0755
369- add defattr to -devel package
370
371* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
372- update to 3.5.4
373
374* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
375- auto rebuild in the new build environment (release 6)
376
377* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
378- build for glibc 2.1
379
380* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
381- translations modified for de
382
383* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
384- rebuilt against fixed jpeg libs (libjpeg-6b)
385
386* Thu May 07 1998 Prospector System <bugs@redhat.com>
387- translations modified for de, fr, tr
388
389* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
390- new version to replace the one from libgr
391- patched for glibc
392- added shlib support
Note: See TracBrowser for help on using the repository browser.