source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 12519

Revision 12519, 13.3 KB checked in by tomop, 3 years ago (diff)

updated 7 packages

ghostscript-9.53.3-1

lua-5.4.2-1

libjpeg-turbo-2.0.6-1

libtiff-4.2.0-1

openjpeg2-2.4.0-1

proftpd-1.3.7a-1

wireshark-3.4.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.2.0
7Release: 1%{_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11Packager: daisuke, iwamoto
12
13License: distributable
14URL: http://www.simplesystems.org/libtiff/
15Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
16
17Patch0: libtiff-am-version.patch
18Patch1: libtiff-make-check.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: zlib-devel libjpeg-devel
22%define LIBVER %(echo %{version} | cut -f-2 -d.)
23%ifarch x86_64
24Provides: libtiff.so.4()(64bit)
25%else
26Provides: libtiff.so.4
27%endif
28Obsoletes: libtiff4
29
30%description
31The libtiff package contains a library of functions for manipulating
32TIFF (Tagged Image File Format) image format files.  TIFF is a widely
33used file format for bitmapped images.  TIFF files usually end in the
34.tif extension and they are often quite large.
35
36The libtiff package should be installed if you need to manipulate TIFF
37format image files.
38
39%description -l ja
40libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
41扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
42広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
43拡張子が使われ,サイズは概して大きめです.
44
45TIFF 形式の画像ファイルを扱う必要があるならば,
46libtiff パッケージを是非インストールして下さい.
47
48
49%package devel
50Summary: Development tools for programs which will use the libtiff library.
51Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
52Group: programming
53Requires: libtiff = %{version}
54
55
56%description devel
57This package contains the header files and static libraries for
58developing programs which will manipulate TIFF format image files
59using the libtiff library.
60
61If you need to develop programs which will manipulate TIFF format
62image files, you should install this package.  You'll also need to
63install the libtiff package.
64
65#'
66%description devel -l ja
67このパッケージには,libtiff ライブラリを使って TIFF 形式の
68画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
69スタティックライブラリが収められています.
70
71TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
72このパッケージをインストールして下さい.libtiff パッケージも同時に
73インストールする必要があります.
74
75## to build compat32 for x86_64 architecture support
76%package -n compat32-%{name}
77Summary: A library of functions for manipulating TIFF format image files.
78Group: system
79Requires: %{name} = %{version}
80Provides: libtiff.so.4
81Obsoletes: compat32-libtiff4
82%description -n compat32-%{name}
83The libtiff package contains a library of functions for manipulating
84TIFF (Tagged Image File Format) image format files.  TIFF is a widely
85used file format for bitmapped images.  TIFF files usually end in the
86.tif extension and they are often quite large.
87
88The libtiff package should be installed if you need to manipulate TIFF
89format image files.
90
91%package -n compat32-%{name}-devel
92Summary: Development tools for programs which will use the libtiff library.
93Group: programming
94Requires: compat32-%{name} = %{version}
95Requires: %{name}-devel = %{version}
96%description -n compat32-%{name}-devel
97This package contains the header files and static libraries for
98developing programs which will manipulate TIFF format image files
99using the libtiff library.
100
101If you need to develop programs which will manipulate TIFF format
102image files, you should install this package.  You'll also need to
103install the libtiff package.
104#'
105
106
107%debug_package
108
109
110%prep
111%setup -q -n tiff-%{version}
112
113%patch0 -p1
114%patch1 -p1
115
116# Use build system's libtool.m4, not the one in the package.
117rm -f libtool.m4
118
119libtoolize --force  --copy
120aclocal -I . -I m4
121automake --add-missing --copy
122autoconf
123autoheader
124
125
126%build
127export CFLAGS="%{optflags} -fno-strict-aliasing"
128%configure \
129  --enable-ld-version-script \
130  --with-jpeg-lib-dir=%{_libdir} \
131  --disable-cxx
132%__make %{?_smp_mflags}
133%__make clean
134
135
136%install
137rm -fr %{buildroot}
138%makeinstall
139
140ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
141
142rm -rf %{buildroot}/usr/share/doc/tiff-%{version}
143rm -f %{buildroot}%{_libdir}/libtiff*.{a,la}
144
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149
150%post -p /sbin/ldconfig
151%postun -p /sbin/ldconfig
152
153%if %{build_compat32}
154%post -n compat32-%{name} -p /sbin/ldconfig
155%postun -n compat32-%{name} -p /sbin/ldconfig
156%endif
157
158
159%files
160%defattr(-,root,root)
161%license COPYRIGHT
162%doc README RELEASE-DATE VERSION
163%{_bindir}/*
164%{_libdir}/libtiff*.so.*
165%{_mandir}/man1/*
166
167%files devel
168%defattr(-,root,root)
169%doc TODO html ChangeLog
170%{_includedir}/*
171%{_libdir}/libtiff*.so
172%{_libdir}/pkgconfig/*.pc
173%{_mandir}/man3/*
174
175## to build compat32 for x86_64 architecture support
176%if %{build_compat32}
177%files -n compat32-%{name}
178%defattr(-,root,root)
179%{_libdir}/libtiff.so.*
180
181%files -n compat32-%{name}-devel
182%defattr(-,root,root)
183%{_libdir}/libtiff.so
184%endif
185
186
187%changelog
188* Tue Dec 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.0-1
189- new upstream release.
190
191* Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.0-1
192- new upstream release.
193- dropped Patch1001-1004: fixed in upstream.
194
195* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-2
196- rebuilt with libjpeg.so.8.
197
198* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-1
199- new upstream release.
200- dropped Patch1000: fixed in upstream.
201- imported Patch1001-1003 from rawhide.
202- imported Patch1004 from upstream.
203
204* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
205- updated to 4.0.9.
206- added Patch1000 to fix CVE-2017-9935.
207
208* Sat Jun  3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
209- update to 4.0.8
210- drop patches; upstream fixed
211 - HylaFAX patch (Patch2)
212 - CVE patches (Patch3..16)
213
214* Sat May  6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
215- imported patches from rawhide.
216    - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
217    - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
218
219* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
220- new upstream release.
221- drooped patch1-11: fixed in upstream.
222
223* Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
224- add patch1-11 from fc21 to fix security issues
225
226* Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
227- new upstream release with security fix (CVE-2012-4447)
228- drop *.a files from -devel packages
229
230* Thu Aug  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
231- new upstream release with security fixes (CVE-2012-2088, 2113)
232- drop patch1 (is included in new release)
233
234* Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
235- Obosletes: libtiff4 and compat32-libtiff4 (vl6)
236
237* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
238- fix R: for compat32 package
239
240* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
241- add libtiff.so.4 for compatibility
242- add pkgconfig file
243
244* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
245- new upstream release
246- add patch1 to fix CVE-2012-1173
247
248* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
249- new upstream release
250- drop all patches (are included in new release)
251- remove if-endif for Vine 4.x
252- add Vendor/Distri tags
253
254* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
255- add some patches from RHEL6 3.9.4-1.el6_0.3
256 - fix for CVE-2011-0192 (Patch11)
257 - fix for CVE-2011-1167 (Patch12)
258 - fix for CVE-2009-5022 (Patch13)
259
260* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
261- rebuilt with rpm-4.8.1-3
262
263* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
264- new upstream release
265- add patch4-10 from fedora
266
267* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
268- new upstream release
269- remove BC: freeglut-devel
270- add patch1,2,4,5 from fedora
271- drop obsolete patches
272
273* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
274- change if-endif to make both i386 and compat32 packages
275
276* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
277- add patch5 for fix CVE-2009-2347 (Integer Overflow)
278
279* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
280- add patch4 for fix lzw underflow security issue
281- add if branch Vine4/5 in devel files section (*.la are included or not)
282
283* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
284- removed *.la
285- spec in utf-8
286
287* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
288- fix changelog typo (3.8.4 -> 3.8.2)
289- new versioning policy
290- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
291
292* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
293- fix libdir in libtiff.la
294- add BuildConflicts: freeglut-devel
295
296* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
297- rebuilt without glut-devel
298
299* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
300- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
301
302* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
303- new upstream release
304- remove obsolete patches
305- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
306- delete duped docs
307- add --disable-cxx to configure option
308- add *.la to devel package
309
310* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
311- added compat32-* packages for x86_64 architecture support
312- added --with-jpeg-lib-dir=%{_libdir} to configure
313
314* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
315- new upstream release
316- remove obsolete patches
317- cleanup specs
318
319* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
320- rebuild for Vine3.1
321
322* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
323- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
324- update URL
325
326* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
327- build for Vine2.6
328
329* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
330- fix changelog: proper name
331
332* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
333- add symlink to shared lib by running ldconfig at compile time
334
335* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
336- add patch8-13 from Fedora Core
337--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
338--- fix some integer and buffer overflows (#134853, #134848)
339- add patch14 from SUSE LINUX
340--* Wed Oct 20 2004 - meissner@suse.de
341--- Do not crash if we are using unsupported codecs (like OJPEG).
342
343* Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
344- rebuild with new toolchains
345- to use License instead of Copyright
346
347* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
348- 3.5.7-6vl1
349- based on 3.5.7-6 from Rawhide
350
351* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
352- 3.5.5-8vl1
353- based on 3.5.5-8 from Rawhide
354- added Japanese summary and description
355
356* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
357- rebuild
358
359* Mon Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
360- added a tiff-to-ps.fpi filter for printing
361
362* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
363- automatic rebuild
364
365* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
366- apply Peter Skarpetis's fix for the 32-bit conversion
367
368* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
369- make man pages non-executable (#12811)
370
371* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
372- remove CVS repo info from data directories
373
374* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
375- fix build rooting
376- fix syntax error in configure script
377- move man pages to %{_mandir}
378
379* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
380- rebuild for an errata release
381
382* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
383- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
384
385* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
386- fix fax2ps swapping height and width in the bounding box
387
388* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
389- move man pages from devel package to the regular one
390- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
391  of libtiff)
392- fix fax2ps breakage (bug #8345)
393
394* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
395- set MANDIR=man3 to make multifunction man pages friendlier
396
397* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
398- fix URLs
399
400* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
401- link shared library against libjpeg and libz
402
403* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
404- enable zip and jpeg codecs
405- change defattr in normal package to 0755
406- add defattr to -devel package
407
408* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
409- update to 3.5.4
410
411* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
412- auto rebuild in the new build environment (release 6)
413
414* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
415- build for glibc 2.1
416
417* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
418- translations modified for de
419
420* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
421- rebuilt against fixed jpeg libs (libjpeg-6b)
422
423* Thu May 07 1998 Prospector System <bugs@redhat.com>
424- translations modified for de, fr, tr
425
426* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
427- new version to replace the one from libgr
428- patched for glibc
429- added shlib support
Note: See TracBrowser for help on using the repository browser.