source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 6203

Revision 6203, 11.3 KB checked in by daisuke, 12 years ago (diff)
  • Sun May 20 2012 Daisuke SUZUKI <daisuke@…> 4.0.1-3
  • fix R: for compat32 package
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.1
7Release: 3%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12Patch1: libtiff-CVE-2012-1173.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: zlib-devel libjpeg-devel
16%define LIBVER %(echo %{version} | cut -f-2 -d.)
17%ifarch x86_64
18Provides: libtiff.so.4()(64bit)
19%else
20Provides: libtiff.so.4
21%endif
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, iwamoto
26
27%description
28The libtiff package contains a library of functions for manipulating
29TIFF (Tagged Image File Format) image format files.  TIFF is a widely
30used file format for bitmapped images.  TIFF files usually end in the
31.tif extension and they are often quite large.
32
33The libtiff package should be installed if you need to manipulate TIFF
34format image files.
35
36%description -l ja
37libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
38扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
39広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
40拡張子が使われ,サイズは概して大きめです.
41
42TIFF 形式の画像ファイルを扱う必要があるならば,
43libtiff パッケージを是非インストールして下さい.
44
45
46%package devel
47Summary: Development tools for programs which will use the libtiff library.
48Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
49Group: Development/Libraries
50Requires: libtiff = %{version}
51
52
53%description devel
54This package contains the header files and static libraries for
55developing programs which will manipulate TIFF format image files
56using the libtiff library.
57
58If you need to develop programs which will manipulate TIFF format
59image files, you should install this package.  You'll also need to
60install the libtiff package.
61
62#'
63%description devel -l ja
64このパッケージには,libtiff ライブラリを使って TIFF 形式の
65画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
66スタティックライブラリが収められています.
67
68TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
69このパッケージをインストールして下さい.libtiff パッケージも同時に
70インストールする必要があります.
71
72## to build compat32 for x86_64 architecture support
73%package -n compat32-%{name}
74Summary: A library of functions for manipulating TIFF format image files.
75Group: System Environment/Libraries
76Requires: %{name} = %{version}
77Provides: libtiff.so.4
78%description -n compat32-%{name}
79The libtiff package contains a library of functions for manipulating
80TIFF (Tagged Image File Format) image format files.  TIFF is a widely
81used file format for bitmapped images.  TIFF files usually end in the
82.tif extension and they are often quite large.
83
84The libtiff package should be installed if you need to manipulate TIFF
85format image files.
86
87%package -n compat32-%{name}-devel
88Summary: Development tools for programs which will use the libtiff library.
89Group: Development/Libraries
90Requires: compat32-%{name} = %{version}
91Requires: %{name}-devel = %{version}
92%description -n compat32-%{name}-devel
93This package contains the header files and static libraries for
94developing programs which will manipulate TIFF format image files
95using the libtiff library.
96
97If you need to develop programs which will manipulate TIFF format
98image files, you should install this package.  You'll also need to
99install the libtiff package.
100
101#'
102%prep
103%setup -q -n tiff-%{version}
104
105%patch1 -p1 -b .CVE-2012-1173
106
107%build
108%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
109%__make %{?_smp_mflags}
110%__make clean
111
112
113%install
114rm -fr $RPM_BUILD_ROOT
115%makeinstall
116rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
117
118ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
119
120rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
121
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127%if %{build_compat32}
128%post -n compat32-%{name} -p /sbin/ldconfig
129%postun -n compat32-%{name} -p /sbin/ldconfig
130%endif
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%files
136%defattr(-,root,root)
137%doc COPYRIGHT README RELEASE-DATE VERSION
138%{_bindir}/*
139%{_libdir}/libtiff*.so.*
140%{_mandir}/man1/*
141
142
143%files devel
144%defattr(-,root,root)
145%doc TODO html ChangeLog
146%{_includedir}/*
147%{_libdir}/libtiff*.so
148%{_libdir}/libtiff*.a
149%{_libdir}/pkgconfig/*.pc
150%{_mandir}/man3/*
151
152## to build compat32 for x86_64 architecture support
153%if %{build_compat32}
154%files -n compat32-%{name}
155%defattr(-,root,root)
156%{_libdir}/libtiff.so.*
157
158%files -n compat32-%{name}-devel
159%defattr(-,root,root)
160%{_libdir}/libtiff.so
161%{_libdir}/libtiff.a
162%endif
163
164
165%changelog
166* Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
167- fix R: for compat32 package
168
169* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
170- add libtiff.so.4 for compatibility
171- add pkgconfig file
172
173* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
174- new upstream release
175- add patch1 to fix CVE-2012-1173
176
177* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
178- new upstream release
179- drop all patches (are included in new release)
180- remove if-endif for Vine 4.x
181- add Vendor/Distri tags
182
183* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
184- add some patches from RHEL6 3.9.4-1.el6_0.3
185 - fix for CVE-2011-0192 (Patch11)
186 - fix for CVE-2011-1167 (Patch12)
187 - fix for CVE-2009-5022 (Patch13)
188
189* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
190- rebuilt with rpm-4.8.1-3
191
192* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
193- new upstream release
194- add patch4-10 from fedora
195
196* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
197- new upstream release
198- remove BC: freeglut-devel
199- add patch1,2,4,5 from fedora
200- drop obsolete patches
201
202* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
203- change if-endif to make both i386 and compat32 packages
204
205* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
206- add patch5 for fix CVE-2009-2347 (Integer Overflow)
207
208* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
209- add patch4 for fix lzw underflow security issue
210- add if branch Vine4/5 in devel files section (*.la are included or not)
211
212* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
213- removed *.la
214- spec in utf-8
215
216* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
217- fix changelog typo (3.8.4 -> 3.8.2)
218- new versioning policy
219- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
220
221* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
222- fix libdir in libtiff.la
223- add BuildConflicts: freeglut-devel
224
225* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
226- rebuilt without glut-devel
227
228* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
229- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
230
231* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
232- new upstream release
233- remove obsolete patches
234- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
235- delete duped docs
236- add --disable-cxx to configure option
237- add *.la to devel package
238
239* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
240- added compat32-* packages for x86_64 architecture support
241- added --with-jpeg-lib-dir=%{_libdir} to configure
242
243* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
244- new upstream release
245- remove obsolete patches
246- cleanup specs
247
248* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
249- rebuild for Vine3.1
250
251* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
252- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
253- update URL
254
255* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
256- build for Vine2.6
257
258* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
259- fix changelog: proper name
260
261* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
262- add symlink to shared lib by running ldconfig at compile time
263
264* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
265- add patch8-13 from Fedora Core
266--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
267--- fix some integer and buffer overflows (#134853, #134848)
268- add patch14 from SUSE LINUX
269--* Wed Oct 20 2004 - meissner@suse.de
270--- Do not crash if we are using unsupported codecs (like OJPEG).
271
272* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
273- rebuild with new toolchains
274- to use License instead of Copyright
275
276* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
277- 3.5.7-6vl1
278- based on 3.5.7-6 from Rawhide
279
280* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
281- 3.5.5-8vl1
282- based on 3.5.5-8 from Rawhide
283- added Japanese summary and description
284
285* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
286- rebuild
287
288* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
289- added a tiff-to-ps.fpi filter for printing
290
291* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
292- automatic rebuild
293
294* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
295- apply Peter Skarpetis's fix for the 32-bit conversion
296
297* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
298- make man pages non-executable (#12811)
299
300* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
301- remove CVS repo info from data directories
302
303* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
304- fix build rooting
305- fix syntax error in configure script
306- move man pages to %{_mandir}
307
308* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
309- rebuild for an errata release
310
311* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
312- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
313
314* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
315- fix fax2ps swapping height and width in the bounding box
316
317* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
318- move man pages from devel package to the regular one
319- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
320  of libtiff)
321- fix fax2ps breakage (bug #8345)
322
323* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
324- set MANDIR=man3 to make multifunction man pages friendlier
325
326* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
327- fix URLs
328
329* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
330- link shared library against libjpeg and libz
331
332* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
333- enable zip and jpeg codecs
334- change defattr in normal package to 0755
335- add defattr to -devel package
336
337* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
338- update to 3.5.4
339
340* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
341- auto rebuild in the new build environment (release 6)
342
343* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
344- build for glibc 2.1
345
346* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
347- translations modified for de
348
349* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
350- rebuilt against fixed jpeg libs (libjpeg-6b)
351
352* Thu May 07 1998 Prospector System <bugs@redhat.com>
353- translations modified for de, fr, tr
354
355* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
356- new version to replace the one from libgr
357- patched for glibc
358- added shlib support
Note: See TracBrowser for help on using the repository browser.