source: projects/specs/trunk/lib/libt/libtevent/libtevent-vl.spec @ 11584

Revision 11584, 5.7 KB checked in by tomop, 6 years ago (diff)

libtevent-0.9.36-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libtevent
4Summary: The tevent library
5Summary(ja): Tevent ライブラリ
6Version: 0.9.36
7Release: 1%{?_dist_release}
8Group: System Environment/Libraries
9License: LGPLv3+
10URL: http://tevent.samba.org/
11Source: http://samba.org/ftp/tevent/tevent-%{version}.tar.gz
12BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
13
14Patch1: tevent-098-add_abi_scripts_and_fix_exports.patch
15
16BuildRequires: libtalloc-devel >= 2.0.0
17BuildRequires: python-devel python-rpm-macros
18BuildRequires: python3-devel python3-rpm-macros
19BuildRequires: python-talloc-devel
20BuildRequires: python3-talloc-devel
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: tomop
25
26%description
27Tevent is an event system based on the talloc memory management library.
28Tevent has support for many event types, including timers, signals, and
29the classic file descriptor events.
30Tevent also provide helpers to deal with asynchronous code providing the
31tevent_req (Tevent Request) functions.
32
33%package devel
34Summary: Developer tools for the Tevent library
35Summary(ja): Tevent ライブラリの開発用ファイル
36Group: Development/Libraries
37Requires: libtevent = %{version}-%{release}
38Requires: libtalloc-devel >= 2.0.0
39Requires: pkgconfig
40
41%description devel
42Header files needed to develop programs that link against the Tevent library.
43
44%package -n python-tevent
45Summary: Python bindings for the Tevent library
46Summary(ja): Tevent ライブラリの python バインディング
47Group: System Environment/Libraries
48Requires: libtevent = %{version}-%{release}
49Requires: python-talloc >= 2.0.0
50Requires: pkgconfig
51
52%description -n python-tevent
53Python bindings for libtevent
54
55%package -n python3-tevent
56Summary: Python3 bindings for the Tevent library
57Summary(ja): Tevent ライブラリの python3 バインディング
58Group: System Environment/Libraries
59Requires: libtevent = %{version}-%{release}
60Requires: python3-talloc >= 2.0.0
61Requires: pkgconfig
62
63%description -n python3-tevent
64Python3 bindings for libtevent
65
66%if %{build_compat32}
67
68%package -n compat32-%{name}
69Summary: The tevent library
70Summary(ja): Tevent ライブラリ
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74Tevent is an event system based on the talloc memory management library.
75Tevent has support for many event types, including timers, signals, and
76the classic file descriptor events.
77Tevent also provide helpers to deal with asynchronous code providing the
78tevent_req (Tevent Request) functions.
79
80%endif
81
82%prep
83%setup -q -n tevent-%{version}
84
85%build
86%configure
87%configure --disable-rpath \
88        --bundled-libraries=NONE \
89        --builtin-libraries=replace \
90        --extra-python=%{__python3}
91
92make %{?_smp_mflags} V=1
93
94%check
95make %{?_smp_mflags} check
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DESTDIR=$RPM_BUILD_ROOT
101
102#ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so.0
103#ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so
104
105rm -f $RPM_BUILD_ROOT%{_libdir}/libtevent.a
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files
111%defattr(-,root,root,-)
112%{_libdir}/libtevent.so.*
113
114%files devel
115%defattr(-,root,root,-)
116%{_includedir}/tevent.h
117%{_libdir}/libtevent.so
118%{_libdir}/pkgconfig/tevent.pc
119
120%files -n python-tevent
121%{python_sitearch}/_tevent.so
122%{python_sitearch}/tevent.py
123
124%files -n python3-tevent
125%{python3_sitearch}/tevent.py
126%{python3_sitearch}/_tevent.cpython*.so
127
128%if %{build_compat32}
129
130%files -n compat32-%{name}
131%defattr(-,root,root,-)
132%{_libdir}/libtevent.so.*
133
134%endif
135
136%post
137/sbin/ldconfig
138
139%postun
140/sbin/ldconfig
141
142%if %build_compat32
143
144%post -n compat32-%{name}
145/sbin/ldconfig
146
147%postun -n compat32-%{name}
148/sbin/ldconfig
149
150%endif
151
152%changelog
153* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.36-1
154- new upstream release.
155- dropped Patch1.
156- enabled python3 modules.
157
158* Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.32-1
159- new upstream release.
160
161* Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.31-1
162- new upstream release.
163
164* Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.28-1
165- new upstream release.
166
167* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.26-1
168- new upstream release.
169
170* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.25-1
171- new upstream release.
172
173* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-2
174- added compat32 package.
175
176* Fri Mar  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-1
177- new upstream release.
178
179* Wed Dec  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.22-1
180- new upstream release.
181
182* Mon Oct  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.21-2
183- moved libtevent to System Environment/Libraries Group
184
185* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.21-1
186- new upstream release.
187
188* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.20-1
189- new upstream release.
190
191* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.19-1
192- new upstream release.
193
194* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.17-1
195- new upstream release.
196- initial build for Vine Linux.
197
198* Fri May 21 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-8
199- Run make check during RPM build
200- Fix abi_check patch to guarantee script executability
201
202* Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7.1
203- Remove all references to ABI compatibility patch
204
205* Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7
206- Drop ABI compatibility patch (no longer needed)
207
208* Wed Sep 23 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-5
209- Add patch to fix a segfault case
210
211* Wed Sep 16 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-2
212- Fix abi compatibility with 0.9.3
213
214* Tue Sep 8 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-1
215- First independent release for tevent 0.9.8
Note: See TracBrowser for help on using the repository browser.