source: projects/specs/trunk/lib/libt/libtevent/libtevent-vl.spec @ 10042

Revision 10042, 4.8 KB checked in by tomop, 8 years ago (diff)

libldb-1.1.26-1, libtevent-0.9.28-1, samba-4.3.5-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libtevent
4Summary: The tevent library
5Summary(ja): Tevent ライブラリ
6Version: 0.9.28
7Release: 1%{?_dist_release}
8Group: System Environment/Libraries
9License: LGPLv3+
10URL: http://tevent.samba.org/
11Source: http://samba.org/ftp/tevent/tevent-%{version}.tar.gz
12BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
13
14Patch1: tevent-098-add_abi_scripts_and_fix_exports.patch
15
16BuildRequires: libtalloc-devel >= 2.0.0
17BuildRequires: python-devel
18BuildRequires: pytalloc-devel
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: tomop
23
24%description
25Tevent is an event system based on the talloc memory management library.
26Tevent has support for many event types, including timers, signals, and
27the classic file descriptor events.
28Tevent also provide helpers to deal with asynchronous code providing the
29tevent_req (Tevent Request) functions.
30
31%package devel
32Summary: Developer tools for the Tevent library
33Summary(ja): Tevent ライブラリの開発用ファイル
34Group: Development/Libraries
35Requires: libtevent = %{version}-%{release}
36Requires: libtalloc-devel >= 2.0.0
37Requires: pkgconfig
38
39%description devel
40Header files needed to develop programs that link against the Tevent library.
41
42%package -n python-tevent
43Summary: Python bindings for the Tevent library
44Summary(ja): Tevent ライブラリの python バインディング
45Group: System Environment/Libraries
46Requires: libtevent = %{version}-%{release}
47Requires: pytalloc >= 2.0.0
48Requires: pkgconfig
49
50%description -n python-tevent
51Python bindings for libtevent
52
53%if %build_compat32
54
55%package -n compat32-%{name}
56Summary: The tevent library
57Summary(ja): Tevent ライブラリ
58Group: System Environment/Libraries
59
60%description -n compat32-%{name}
61Tevent is an event system based on the talloc memory management library.
62Tevent has support for many event types, including timers, signals, and
63the classic file descriptor events.
64Tevent also provide helpers to deal with asynchronous code providing the
65tevent_req (Tevent Request) functions.
66
67%endif
68
69%prep
70%setup -q -n tevent-%{version}
71
72%patch1 -p1 -b .abi_checks
73
74%build
75%configure
76make %{?_smp_mflags}
77
78%check
79make %{?_smp_mflags} check
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84make install DESTDIR=$RPM_BUILD_ROOT
85
86#ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so.0
87#ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/libtevent.a
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(-,root,root,-)
96%{_libdir}/libtevent.so.*
97
98%files devel
99%defattr(-,root,root,-)
100%{_includedir}/tevent.h
101%{_libdir}/libtevent.so
102%{_libdir}/pkgconfig/tevent.pc
103
104%files -n python-tevent
105%{python_sitearch}/_tevent.so
106%{python_sitearch}/tevent.py
107
108%if %build_compat32
109
110%files -n compat32-%{name}
111%defattr(-,root,root,-)
112%{_libdir}/libtevent.so.*
113
114%endif
115
116%post
117/sbin/ldconfig
118
119%postun
120/sbin/ldconfig
121
122%if %build_compat32
123
124%post -n compat32-%{name}
125/sbin/ldconfig
126
127%postun -n compat32-%{name}
128/sbin/ldconfig
129
130%endif
131
132%changelog
133* Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.28-1
134- new upstream release.
135
136* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.26-1
137- new upstream release.
138
139* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.25-1
140- new upstream release.
141
142* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-2
143- added compat32 package.
144
145* Fri Mar  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-1
146- new upstream release.
147
148* Wed Dec  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.22-1
149- new upstream release.
150
151* Mon Oct  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.21-2
152- moved libtevent to System Environment/Libraries Group
153
154* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.21-1
155- new upstream release.
156
157* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.20-1
158- new upstream release.
159
160* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.19-1
161- new upstream release.
162
163* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.17-1
164- new upstream release.
165- initial build for Vine Linux.
166
167* Fri May 21 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-8
168- Run make check during RPM build
169- Fix abi_check patch to guarantee script executability
170
171* Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7.1
172- Remove all references to ABI compatibility patch
173
174* Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7
175- Drop ABI compatibility patch (no longer needed)
176
177* Wed Sep 23 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-5
178- Add patch to fix a segfault case
179
180* Wed Sep 16 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-2
181- Fix abi compatibility with 0.9.3
182
183* Tue Sep 8 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-1
184- First independent release for tevent 0.9.8
Note: See TracBrowser for help on using the repository browser.