source: projects/specs/trunk/lib/libt/libtermcap/libtermcap-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A basic system library for accessing the termcap database.
2Name: libtermcap
3Version: 2.0.8
4Release: 47%{?_dist_release}
5Source: ftp://metalab.unc.edu/pub/Linux/GCC/termcap-2.0.8.tar.bz2
6Url: ftp://metalab.unc.edu/pub/Linux/GCC/
7License: LGPL
8Group: System Environment/Libraries
9Patch0: termcap-2.0.8-shared.patch
10Patch1: termcap-2.0.8-setuid.patch
11Patch2: termcap-2.0.8-instnoroot.patch
12Patch3: termcap-2.0.8-compat21.patch
13Patch4: termcap-2.0.8-xref.patch
14Patch5: termcap-2.0.8-fix-tc.patch
15Patch6: termcap-2.0.8-ignore-p.patch
16Patch7: termcap-buffer.patch
17# This patch is a REALLY BAD IDEA without patch #10 below....
18Patch8: termcap-2.0.8-bufsize.patch
19Patch9: termcap-2.0.8-colon.patch
20Patch10: libtermcap-aaargh.patch
21Patch11: termcap-2.0.8-glibc22.patch
22Patch12: libtermcap-2.0.8-ia64.patch
23Patch13: termcap-116934.patch
24Patch14: termcap-2.0.8-shrink.patch
25Patch15: termcap-2.0.8-octal.patch
26Patch16: termcap-2.0.8-nofree.patch
27Requires: termcap
28BuildPrereq: texinfo
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30Obsoletes: libtermcap-devel <= 2.0.8-46vl1
31
32%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
33
34%description
35The libtermcap package contains a basic system library needed to
36access the termcap database.  The termcap library supports easy access
37to the termcap database, so that programs can output character-based
38displays in a terminal-independent manner.
39
40%package -n compat32-%{name}
41Summary: A basic system library for accessing the termcap database.
42Group: System Environment/Libraries
43Requires: %{name} = %{version}-%{release}
44
45%description -n compat32-%{name}
46The libtermcap package contains a basic system library needed to
47access the termcap database.  The termcap library supports easy access
48to the termcap database, so that programs can output character-based
49displays in a terminal-independent manner.
50
51%prep
52%setup -q -n termcap-2.0.8
53%patch0 -p1
54%patch1 -p1
55%patch2 -p1 -b .nochown
56%patch3 -p1 -b .compat21
57%patch4 -p1
58%patch5 -p1 -b .fix-tc
59%patch6 -p1 -b .ignore-p
60%patch7 -p1 -b .buffer
61%patch8 -p1 -b .bufsize
62%patch9 -p1 -b .colon
63%patch10 -p1 -b .aaargh
64%patch11 -p1 -b .glibc22
65%ifarch ia64
66%patch12 -p1 -b .ia64
67%endif
68%patch13 -p1 -b .116934
69%patch14 -p1 -b .shrink
70%patch15 -p1 -b .octal
71%patch16 -p1 -b .nofree
72
73%build
74make AR=%{__ar} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -I."
75
76%install
77rm -rf $RPM_BUILD_ROOT
78%ifarch x86_64
79mkdir -p $RPM_BUILD_ROOT/{usr/lib,usr/lib64,%{_infodir},usr/include,etc,lib64}
80%else
81mkdir -p $RPM_BUILD_ROOT/{usr/lib,%{_infodir},usr/include,etc,lib}
82%endif
83
84export PATH=/sbin:$PATH
85make prefix=$RPM_BUILD_ROOT/usr install
86
87install -c -m644 termcap.src $RPM_BUILD_ROOT/etc/termcap
88cp termcap.info* $RPM_BUILD_ROOT/%{_infodir}
89
90( cd $RPM_BUILD_ROOT
91  rm -f ./etc/termcap
92  mv ./usr/lib/libtermcap.so* ./%{_lib}
93  #ln -sf libtermcap.so.2.0.8 ./%{_lib}/libtermcap.so
94  rm -f ./%{_lib}/libtermcap.so
95  cd usr/%{_lib}
96  ln -sf ../../%{_lib}/libtermcap.so.2.0.8 libtermcap.so
97%ifarch x86_64
98  mv ../lib/libtermcap.a .
99  rmdir ../lib
100%endif
101  cd ../..
102  strip -R .comments --strip-unneeded ./%{_lib}/libtermcap.so.2.0.8
103  gzip -9nf ./%{_infodir}/termcap.info*
104  chmod 644 ./%{_infodir}/termcap.info*
105)
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111
112%postun -p /sbin/ldconfig
113
114%post -n compat32-%{name} -p /sbin/ldconfig
115
116%postun -n compat32-%{name} -p /sbin/ldconfig
117
118
119%files
120%defattr(-,root,root)
121/%{_lib}/libtermcap.so.2.0.8
122
123%if %{build_compat32}
124%files -n compat32-%{name}
125%defattr(-,root,root)
126/%{_lib}/libtermcap.so.2.0.8
127
128
129%changelog
130* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-47
131- new versioning policy
132- remove libtermcap-devel, replaced by ncurses-devel(libtinfo)
133
134* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.8-46vl1
135- rebuit with new toolchain
136- not postun but preun to execute install-info --delete - fixed.
137
138  - Tue Jun 27 2006 Florian La Roche <laroche@redhat.com> - 2.0.8-46
139  - no need for the trigger, if info files are in the -devel subrpm
140
141  - Mon Feb 27 2006 Miloslav Trmac <mitr@redhat.com> - 2.0.8-45
142  - Add Requires(postun): /sbin/install-info to libtermcap-devel (#182836)
143
144* Wed Feb 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.8-44vl1
145- s/Copyright/License/
146- use %%{_tmppath}/%%{name}-%%{version}-root as BuildRoot
147- import patch13-16 from FC 2.0.8-44
148
149  * Mon Jan 2 2006 Petr Raszyk <praszyk@redhat.com> 2.0.8-43
150  - libtermcap does not 'free()'memory. See #74346
151    A patch termcap-2.0.8-nofree.patch
152
153  * Fri Mar 18 2005 Nalin Dahyabhai <nalin@redhat.com> 2.0.8-41
154  - don't trip over capabilities which end in '^' or '\'
155  - don't accept numbers with '8' or '9' in them as valid octal numbers
156
157  * Fri May  7 2004 Tim Waugh <twaugh@redhat.com> 2.0.8-38
158  - Fix tgetent() (bug #116934).
159
160* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.0.8-36vl2
161- added compat32- packages for x86_64 architecture support
162
163* Wed Jun 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.8-36vl1
164- added patch12 from rawhide
165
166* Wed Dec 19 2001 Toru Sagami <sagami@vinelinux.org> 2.0.8-26vl2
167- enabled patch11 in order to build on glibc-22
168
169* Sat Jun 09 2001 <sagami@vinelinux.org>
170- 2.0.8-26vl1: follow up with 2.0.8-26 from 2.0.8-20vl1
171- disabled patch11 for glibc-22
172
173* Sat Oct  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
174- Uninstall info pages in %%postun devel rather than %%postun
175  (Bug #18545)
176
177* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
178- fix broken symlink (#16285)
179
180* Mon Aug 14 2000 Preston Brown <pbrown@redhat.com>
181- absolute --> relative symlink (#16131)
182
183* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
184- automatic rebuild
185
186* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
187- move the trigger to the devel package, that's where the info pages
188  live now
189
190* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
191- rebuild for next release
192- move info pages to the development package
193- use %%{_infodir}
194- patched to build against new glibc (patch11)
195
196* Sun Feb  6 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
197- BuildPrereq: texinfo (#8927)
198
199* Sat Feb  5 2000 Bernhard RosenkrçÏzer <bero@redhat.com>
200- strip library
201- fix up handling of RPM_OPT_FLAGS
202
203* Tue Aug 30 1999 Bill Nottingham <notting@redhat.com>
204- ignore the first argument to tgetent, so the last change doesn't
205  keep blowing up programs.
206- ignore the second argument to tgetstr() as well.
207
208* Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
209- increase default size of malloc'ed tgetent buffer from 1024 to 1536.
210- don't shrink colons (#4270).
211- rebuild for 6.1.
212
213* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
214- add buffer overflow patch from Kevin Vajk <kvajk@ricochet.net>
215
216* Sat May 15 1999 Jeff Johnson <jbj@redhat.com>
217- permit multiple tc= continuations and ignore unnecessary %p ("push arg") (#54)
218
219* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
220- auto rebuild in the new build environment (release 13)
221- fix to make the texi documenattion compile
222
223* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
224- use __PMT(...) prototypes (#761)
225
226* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
227- build against glibc 2.1
228
229* Wed Aug 05 1998 Erik Troan <ewt@redhat.com>
230- run install-info from a %trigger so we don't have to make it a prereq; as
231  termcap is used by bash, the install ordering issues are hairy
232- commented out the chown stuff from 'make install' so you don't have to
233  be root to build this
234- don't run ldconfig if prefix= is used during 'make install'
235
236* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
237- build root.
238
239* Tue Jun 30 1998 Alan Cox <alan@redhat.com>
240- But assume system termcap is sane. Also handle setfsuid return right.
241
242* Tue Jun 30 1998 Alan Cox <alan@redhat.com>
243- TERMCAP environment hole for setuid apps squished.
244
245* Thu May 07 1998 Prospector System <bugs@redhat.com>
246- translations modified for de, fr, tr
247
248* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
249- spec file cleanups
250
251* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
252- built against glibc
Note: See TracBrowser for help on using the repository browser.