source: projects/specs/trunk/lib/libt/libtdb/libtdb-vl.spec @ 8910

Revision 8910, 5.5 KB checked in by tomop, 10 years ago (diff)

samba-4.1.11-1, etc.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libtdb
4Version: 1.3.0
5Release: 1%{?_dist_release}
6Group: System Environment/Libraries
7Summary: The tdb library
8License: LGPLv3+
9URL: http://tdb.samba.org/
10Source: http://samba.org/ftp/tdb/tdb-%{version}.tar.gz
11BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13BuildRequires: autoconf
14BuildRequires: libxslt
15BuildRequires: docbook-style-xsl
16BuildRequires: python-devel
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: tomop
21
22# Patches
23Patch0001: 0001-Install-python-bindings-in-the-arch-specific-location.patch
24
25%description
26A library that implements a trivial database.
27
28%package devel
29Group: Development/Libraries
30Summary: Header files need to link the Tdb library
31Requires: libtdb = %{version}-%{release}
32Requires: pkgconfig
33
34%description devel
35Header files needed to develop programs that link against the Tdb library.
36
37%package -n tdb-tools
38Group: Development/Libraries
39Summary: Developer tools for the Tdb library
40Requires: libtdb = %{version}-%{release}
41
42%description -n tdb-tools
43Tools to manage Tdb files
44
45%package -n python-tdb
46Group: Development/Libraries
47Summary: Python bindings for the Tdb library
48Requires: libtdb = %{version}-%{release}
49
50%description -n python-tdb
51Python bindings for libtdb
52
53%if %build_compat32
54
55%package -n compat32-libtdb
56Summary: The TDB library
57Group: System Environment/Libraries
58
59%description -n compat32-libtdb
60A library that implements a trivial database.
61
62%endif
63
64%prep
65%setup -q -n tdb-%{version}
66%patch0001 -p1
67
68%build
69#./autogen.sh
70%configure --disable-rpath --bundled-libraries=NONE
71make %{?_smp_mflags} V=1
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make install DESTDIR=$RPM_BUILD_ROOT
77
78# Shared libraries need to be marked executable for
79# rpmbuild to strip them and include them in debuginfo
80find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
81
82rm -f $RPM_BUILD_ROOT%{_libdir}/libtdb.a
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(-,root,root,-)
89%{_libdir}/libtdb.so.*
90
91%files devel
92%defattr(-,root,root)
93%{_includedir}/tdb.h
94%{_libdir}/libtdb.so
95%{_libdir}/pkgconfig/tdb.pc
96
97%files -n tdb-tools
98%defattr(-,root,root,-)
99%{_bindir}/tdbbackup
100%{_bindir}/tdbdump
101%{_bindir}/tdbtool
102%{_bindir}/tdbrestore
103%{_mandir}/man8/tdbbackup.8*
104%{_mandir}/man8/tdbdump.8*
105%{_mandir}/man8/tdbtool.8*
106%{_mandir}/man8/tdbrestore.8*
107
108%files -n python-tdb
109%defattr(-,root,root,-)
110%{python_sitearch}/tdb.so
111
112%if %build_compat32
113
114%files -n compat32-libtdb
115%attr(755,root,root) %{_libdir}/libtdb.so.*
116
117%endif
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%post -n python-tdb -p /sbin/ldconfig
124
125%postun -n python-tdb -p /sbin/ldconfig
126
127%if %build_compat32
128
129%post -n compat32-libtdb -p /sbin/ldconfig
130%postun -n compat32-libtdb -p /sbin/ldconfig
131
132%endif
133
134%changelog
135* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
136- new upstream release.
137
138* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-2
139- rebuilt with current environment.
140
141* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-1
142- new upstream release.
143
144* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.11-1
145- new upstream release.
146
147* Sat Apr 14 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.10-1
148- new upstream release.
149- updated Patch0001.
150
151* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-11
152- rebuild with python-2.7.2
153
154* Thu Mar 24 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.9-10
155- initial build for Vine Linux.
156
157* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.9-9
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
159
160* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-8
161- Actually fix the verbosity
162
163* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-7
164- Let rpmbuild strip binaries, make build more verbose.
165- Original patch by Ville Skyttä <ville.skytta@iki.fi>
166
167* Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-6
168- Install python bindings into the correct location
169
170* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-5
171- Run ldconfig on python-tdb
172
173* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-4
174- Do not delete a necessary file during %%install
175
176* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-3
177- Bump release to rebuild with the correct sources in place
178
179* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-2
180- Bump build to rebuild with sources in place
181
182* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-1
183- New upstream bugfix release
184- Adds a new tdbrestore utility
185- Convert to new WAF build-system
186- Add python bindings in new python-tdb subpackage
187
188* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-3
189- add missing build require
190
191* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-2
192- Fix spec file
193- Package manpages too
194
195* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-1
196- New upstream bugfix release
197
198* Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 1.2.0-1
199- New upstream release
200
201* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-2
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
203
204* Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-1
205- Original tarballs had a screw-up, rebuild with new fixed tarballs from
206  upstream.
207
208* Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-0
209- New upstream release
210
211* Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.1.3-15
212- First public independent release from upstream
Note: See TracBrowser for help on using the repository browser.