source: projects/specs/trunk/lib/libt/libtdb/libtdb-vl.spec @ 12079

Revision 12079, 7.8 KB checked in by tomop, 5 years ago (diff)

libtdb-1.3.18-1

Line 
1%bcond_with python2
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5Name: libtdb
6Summary: The tdb library
7Summary(ja): TDB ライブラリ
8Version: 1.3.18
9Release: 1%{?_dist_release}
10
11Group: System Environment/Libraries
12License: LGPLv3+
13URL: http://tdb.samba.org/
14Source: http://samba.org/ftp/tdb/tdb-%{version}.tar.gz
15
16BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
17BuildRequires: autoconf
18BuildRequires: libxslt
19BuildRequires: docbook-style-xsl
20%if %{with python2}
21BuildRequires: python-devel python-rpm-macros
22%endif
23BuildRequires: python3-devel python3-rpm-macros
24BuildRequires: libtirpc-devel
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: tomop
29
30%description
31A library that implements a trivial database.
32
33%package devel
34Summary: Header files need to link the Tdb library
35Group: Development/Libraries
36Requires: libtdb = %{version}-%{release}
37Requires: pkgconfig
38
39%description devel
40Header files needed to develop programs that link against the Tdb library.
41
42%package -n tdb-tools
43Summary: Tools to manipulate tdb files
44Summary(ja): TDB ファイルを処理するためのツール集
45Group: Applications/System
46Requires: libtdb = %{version}-%{release}
47
48%description -n tdb-tools
49Tools to manage Tdb files
50
51%if %{with python2}
52%package -n python-tdb
53Summary: Python bindings for the Tdb library
54Summary(ja): TDB ライブラリの python バインディング
55Group: System Environment/Libraries
56Requires: libtdb = %{version}-%{release}
57
58%description -n python-tdb
59Python bindings for libtdb
60
61%endif
62
63%package -n python3-tdb
64Summary: Python3 bindings for the Tdb library
65Requires: libtdb = %{version}-%{release}
66%{?python_provide:%python_provide python3-tdb}
67%if %{without python2}
68Obsoletes: python-tdb < %{version}
69%endif
70
71%description -n python3-tdb
72Python3 bindings for libtdb
73
74%if %{build_compat32}
75
76%package -n compat32-libtdb
77Summary: The TDB library
78Summary(ja): TDB ライブラリ
79Group: System Environment/Libraries
80Requires: libtdb = %{version}-%{release}
81
82%description -n compat32-libtdb
83A library that implements a trivial database.
84
85%endif
86
87%prep
88%setup -q -n tdb-%{version}
89
90%build
91#./autogen.sh
92%if %{without python2}
93export PYTHON=%{__python3}
94%endif
95%configure --disable-rpath \
96        --bundled-libraries=NONE \
97        --builtin-libraries=replace \
98%if %{with python2}
99        --extra-python=%{__python3}
100%endif
101
102make %{?_smp_mflags} V=1
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107make install DESTDIR=$RPM_BUILD_ROOT
108
109# Shared libraries need to be marked executable for
110# rpmbuild to strip them and include them in debuginfo
111find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
112
113rm -f $RPM_BUILD_ROOT%{_libdir}/libtdb.a
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files
119%defattr(-,root,root,-)
120%{_libdir}/libtdb.so.*
121
122%files devel
123%defattr(-,root,root)
124%{_includedir}/tdb.h
125%{_libdir}/libtdb.so
126%{_libdir}/pkgconfig/tdb.pc
127
128%files -n tdb-tools
129%defattr(-,root,root,-)
130%{_bindir}/tdbbackup
131%{_bindir}/tdbdump
132%{_bindir}/tdbtool
133%{_bindir}/tdbrestore
134%{_mandir}/man8/tdbbackup.8*
135%{_mandir}/man8/tdbdump.8*
136%{_mandir}/man8/tdbtool.8*
137%{_mandir}/man8/tdbrestore.8*
138
139%if %{with python2}
140%files -n python-tdb
141%defattr(-,root,root,-)
142%{python_sitearch}/*
143%endif
144
145%files -n python3-tdb
146%{python3_sitearch}/*
147
148%if %{build_compat32}
149
150%files -n compat32-libtdb
151%attr(755,root,root) %{_libdir}/libtdb.so.*
152
153%endif
154
155%post -p /sbin/ldconfig
156
157%postun -p /sbin/ldconfig
158
159%if %{with python2}
160%post -n python-tdb -p /sbin/ldconfig
161
162%postun -n python-tdb -p /sbin/ldconfig
163
164%endif
165
166%post -n python3-tdb -p /sbin/ldconfig
167
168%postun -n python3-tdb -p /sbin/ldconfig
169
170%if %build_compat32
171
172%post -n compat32-libtdb -p /sbin/ldconfig
173%postun -n compat32-libtdb -p /sbin/ldconfig
174
175%endif
176
177%changelog
178* Sat May 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.18-1
179- new upstream release.
180- disabled python2.
181- added BR:libtirpc-devel.
182
183* Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.16-1
184- new upstream release.
185
186* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.15-1
187- new upstream release.
188- dropped Patch1.
189- enabled python3 modules.
190
191* Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.14-1
192- new upstream release.
193
194* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.13-1
195- new upstream release.
196
197* Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.12-1
198- new upstream release.
199
200* Wed Apr 13 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.9-1
201- new upstream release.
202
203* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.8-1
204- new upstream release.
205
206* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7-1
207- new upstream release.
208
209* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
210- new upstream release.
211
212* Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-1
213- new upstream release.
214
215* Wed Dec  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
216- new upstream release.
217
218* Sat Oct  4 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.0-2
219- moved python-tdb to System Environment/Libraries Group
220- moved tdb-tool to Applications/System Group
221
222* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
223- new upstream release.
224
225* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-2
226- rebuilt with current environment.
227
228* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-1
229- new upstream release.
230
231* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.11-1
232- new upstream release.
233
234* Sat Apr 14 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.10-1
235- new upstream release.
236- updated Patch0001.
237
238* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-11
239- rebuild with python-2.7.2
240
241* Thu Mar 24 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.9-10
242- initial build for Vine Linux.
243
244* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.9-9
245- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
246
247* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-8
248- Actually fix the verbosity
249
250* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-7
251- Let rpmbuild strip binaries, make build more verbose.
252- Original patch by Ville Skyttä <ville.skytta@iki.fi>
253
254* Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-6
255- Install python bindings into the correct location
256
257* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-5
258- Run ldconfig on python-tdb
259
260* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-4
261- Do not delete a necessary file during %%install
262
263* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-3
264- Bump release to rebuild with the correct sources in place
265
266* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-2
267- Bump build to rebuild with sources in place
268
269* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-1
270- New upstream bugfix release
271- Adds a new tdbrestore utility
272- Convert to new WAF build-system
273- Add python bindings in new python-tdb subpackage
274
275* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-3
276- add missing build require
277
278* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-2
279- Fix spec file
280- Package manpages too
281
282* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-1
283- New upstream bugfix release
284
285* Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 1.2.0-1
286- New upstream release
287
288* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-2
289- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
290
291* Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-1
292- Original tarballs had a screw-up, rebuild with new fixed tarballs from
293  upstream.
294
295* Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-0
296- New upstream release
297
298* Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.1.3-15
299- First public independent release from upstream
Note: See TracBrowser for help on using the repository browser.