source: projects/specs/trunk/lib/libt/libtdb/libtdb-vl.spec @ 12469

Revision 12469, 7.9 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

RevLine 
[12079]1%bcond_with python2
2
[3095]3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
[8998]5Summary: The tdb library
6Summary(ja): TDB ライブラリ
[12469]7Name: libtdb
[12362]8Version: 1.4.3
[12469]9Release: 2%{?_dist_release}
10Group: system
11Vendor: Project Vine
12Distribution: Vine Linux
[8998]13
[3095]14License: LGPLv3+
[12362]15URL: https://tdb.samba.org/
16Source: https://samba.org/ftp/tdb/tdb-%{version}.tar.gz
[8998]17
[3095]18BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
19BuildRequires: autoconf
20BuildRequires: libxslt
21BuildRequires: docbook-style-xsl
[12079]22%if %{with python2}
[11582]23BuildRequires: python-devel python-rpm-macros
[12079]24%endif
[11582]25BuildRequires: python3-devel python3-rpm-macros
[12079]26BuildRequires: libtirpc-devel
[3095]27
28%description
29A library that implements a trivial database.
30
[12469]31
[3095]32%package devel
[8998]33Summary: Header files need to link the Tdb library
[12469]34Group: programming
[3095]35Requires: libtdb = %{version}-%{release}
36Requires: pkgconfig
37
38%description devel
39Header files needed to develop programs that link against the Tdb library.
40
[12469]41
[3095]42%package -n tdb-tools
[8998]43Summary: Tools to manipulate tdb files
44Summary(ja): TDB ファイルを処理するためのツール集
[12469]45Group: admin-tools
[3095]46Requires: libtdb = %{version}-%{release}
47
48%description -n tdb-tools
49Tools to manage Tdb files
50
[12469]51
[12079]52%if %{with python2}
[3095]53%package -n python-tdb
54Summary: Python bindings for the Tdb library
[8998]55Summary(ja): TDB ライブラリの python バインディング
[12469]56Group: programming
[3095]57Requires: libtdb = %{version}-%{release}
58
59%description -n python-tdb
60Python bindings for libtdb
[12079]61%endif
62
[12469]63
[11582]64%package -n python3-tdb
65Summary: Python3 bindings for the Tdb library
[12469]66Group: programming
[11582]67Requires: libtdb = %{version}-%{release}
68%{?python_provide:%python_provide python3-tdb}
[12079]69%if %{without python2}
70Obsoletes: python-tdb < %{version}
71%endif
[3095]72
[11582]73%description -n python3-tdb
74Python3 bindings for libtdb
75
[12469]76
[11582]77%if %{build_compat32}
[3095]78%package -n compat32-libtdb
79Summary: The TDB library
[8998]80Summary(ja): TDB ライブラリ
[12469]81Group: system
[8998]82Requires: libtdb = %{version}-%{release}
[3095]83
84%description -n compat32-libtdb
85A library that implements a trivial database.
86%endif
87
[12469]88
[3095]89%prep
90%setup -q -n tdb-%{version}
91
[12469]92
[3095]93%build
[6101]94#./autogen.sh
[12079]95%if %{without python2}
96export PYTHON=%{__python3}
97%endif
[11582]98%configure --disable-rpath \
[12079]99%if %{with python2}
[12469]100        --extra-python=%{__python3} \
[12079]101%endif
[12469]102        --bundled-libraries=NONE \
103        --builtin-libraries=replace
[3095]104make %{?_smp_mflags} V=1
105
[12469]106
[3095]107%install
108rm -rf $RPM_BUILD_ROOT
109
110make install DESTDIR=$RPM_BUILD_ROOT
111
112# Shared libraries need to be marked executable for
113# rpmbuild to strip them and include them in debuginfo
114find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
115
116rm -f $RPM_BUILD_ROOT%{_libdir}/libtdb.a
117
[12469]118
[3095]119%clean
120rm -rf $RPM_BUILD_ROOT
121
[12469]122
[3095]123%files
124%defattr(-,root,root,-)
125%{_libdir}/libtdb.so.*
126
127%files devel
128%defattr(-,root,root)
129%{_includedir}/tdb.h
130%{_libdir}/libtdb.so
131%{_libdir}/pkgconfig/tdb.pc
132
133%files -n tdb-tools
134%defattr(-,root,root,-)
135%{_bindir}/tdbbackup
136%{_bindir}/tdbdump
137%{_bindir}/tdbtool
138%{_bindir}/tdbrestore
139%{_mandir}/man8/tdbbackup.8*
140%{_mandir}/man8/tdbdump.8*
141%{_mandir}/man8/tdbtool.8*
142%{_mandir}/man8/tdbrestore.8*
143
[12079]144%if %{with python2}
[3095]145%files -n python-tdb
146%defattr(-,root,root,-)
[9673]147%{python_sitearch}/*
[12079]148%endif
[3095]149
[11582]150%files -n python3-tdb
151%{python3_sitearch}/*
[3095]152
[11582]153%if %{build_compat32}
[3095]154%files -n compat32-libtdb
155%attr(755,root,root) %{_libdir}/libtdb.so.*
156%endif
157
[12469]158
[3095]159%post -p /sbin/ldconfig
160%postun -p /sbin/ldconfig
161
[12079]162%if %{with python2}
[3095]163%post -n python-tdb -p /sbin/ldconfig
164%postun -n python-tdb -p /sbin/ldconfig
[12079]165%endif
166
[11959]167%post -n python3-tdb -p /sbin/ldconfig
168%postun -n python3-tdb -p /sbin/ldconfig
169
[3095]170%if %build_compat32
171%post -n compat32-libtdb -p /sbin/ldconfig
172%postun -n compat32-libtdb -p /sbin/ldconfig
173%endif
174
[12469]175
[3095]176%changelog
[12469]177* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-2
178- rebuilt with python-3.8.
179
[12362]180* Tue Mar 31 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
181- new upstream release.
182
[12079]183* Sat May 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.18-1
184- new upstream release.
185- disabled python2.
186- added BR:libtirpc-devel.
187
[11959]188* Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.16-1
189- new upstream release.
190
[11582]191* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.15-1
192- new upstream release.
193- dropped Patch1.
194- enabled python3 modules.
195
[11157]196* Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.14-1
197- new upstream release.
198
[11059]199* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.13-1
200- new upstream release.
201
[10840]202* Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.12-1
203- new upstream release.
204
[10178]205* Wed Apr 13 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.9-1
206- new upstream release.
207
[9846]208* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.8-1
209- new upstream release.
210
[9673]211* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7-1
212- new upstream release.
213
[9599]214* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
215- new upstream release.
216
[9254]217* Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-1
218- new upstream release.
219
[9599]220* Wed Dec  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
[9136]221- new upstream release.
222
[8998]223* Sat Oct  4 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.0-2
224- moved python-tdb to System Environment/Libraries Group
225- moved tdb-tool to Applications/System Group
226
[8910]227* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
228- new upstream release.
229
[8130]230* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-2
231- rebuilt with current environment.
232
[7885]233* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.12-1
234- new upstream release.
235
[7254]236* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.11-1
237- new upstream release.
238
[6101]239* Sat Apr 14 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.10-1
240- new upstream release.
241- updated Patch0001.
242
[5701]243* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-11
244- rebuild with python-2.7.2
245
[3095]246* Thu Mar 24 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.9-10
247- initial build for Vine Linux.
248
249* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.9-9
250- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
251
252* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-8
253- Actually fix the verbosity
254
255* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-7
256- Let rpmbuild strip binaries, make build more verbose.
257- Original patch by Ville Skyttä <ville.skytta@iki.fi>
258
259* Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-6
260- Install python bindings into the correct location
261
262* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-5
263- Run ldconfig on python-tdb
264
265* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-4
266- Do not delete a necessary file during %%install
267
268* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-3
269- Bump release to rebuild with the correct sources in place
270
271* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-2
272- Bump build to rebuild with sources in place
273
274* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-1
275- New upstream bugfix release
276- Adds a new tdbrestore utility
277- Convert to new WAF build-system
278- Add python bindings in new python-tdb subpackage
279
280* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-3
281- add missing build require
282
283* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-2
284- Fix spec file
285- Package manpages too
286
287* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-1
288- New upstream bugfix release
289
290* Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 1.2.0-1
291- New upstream release
292
293* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-2
294- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
295
296* Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-1
297- Original tarballs had a screw-up, rebuild with new fixed tarballs from
298  upstream.
299
300* Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-0
301- New upstream release
302
303* Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.1.3-15
304- First public independent release from upstream
Note: See TracBrowser for help on using the repository browser.