source: projects/specs/trunk/lib/libt/libtalloc/libtalloc-vl.spec @ 11959

Revision 11959, 7.3 KB checked in by tomop, 5 years ago (diff)

samba-4.9.3-1 and requirements

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libtalloc
4Version: 2.1.14
5Release: 1%{?_dist_release}
6Group: System Environment/Libraries
7Summary: The talloc library
8License: LGPLv3+
9URL: http://talloc.samba.org/
10Source: http://samba.org/ftp/talloc/talloc-%{version}.tar.gz
11BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13BuildRequires: autoconf
14BuildRequires: libxslt
15BuildRequires: docbook-style-xsl
16BuildRequires: doxygen
17BuildRequires: python-devel python-rpm-macros
18BuildRequires: python3-devel python3-rpm-macros
19
20Provides: bundled(libreplace)
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: tomop
25
26%description
27A library that implements a hierarchical allocator with destructors.
28
29%package devel
30Group: Development/Libraries
31Summary: Developer tools for the Talloc library
32Requires: libtalloc = %{version}-%{release}
33
34%description devel
35Header files needed to develop programs that link against the Talloc library.
36
37%package -n python-talloc
38Group: Development/Libraries
39Summary: Python bindings for the Talloc library
40Requires: libtalloc = %{version}-%{release}
41Obsoletes: pytalloc < 2.1.11
42Provides: pytalloc = %{version}
43
44%description -n python-talloc
45Python libraries for creating bindings using talloc
46
47%package -n python-talloc-devel
48Group: Development/Libraries
49Summary: Development libraries for python-talloc
50Requires: python-talloc = %{version}-%{release}
51Obsoletes: pytalloc-devel < 2.1.11
52Provides: pytalloc-devel = %{version}
53
54%description -n python-talloc-devel
55Development libraries for python-talloc
56
57%package -n python3-talloc
58Group: Development/Libraries
59Summary: Python3 bindings for the Talloc library
60Requires: libtalloc = %{version}-%{release}
61
62%description -n python3-talloc
63Python3 libraries for creating bindings using talloc
64
65%package -n python3-talloc-devel
66Group: Development/Libraries
67Summary: Development libraries for python3-talloc
68Requires: python3-talloc = %{version}-%{release}
69
70%description -n python3-talloc-devel
71Development libraries for python3-talloc
72
73%if %{build_compat32}
74
75%package -n compat32-libtalloc
76Summary: The talloc library
77Group: System Environment/Libraries
78
79%description -n compat32-libtalloc
80A library that implements a hierarchical allocator with destructors.
81
82%endif
83
84%prep
85%setup -q -n talloc-%{version}
86
87%build
88#./autogen.sh
89%configure --disable-rpath \
90        --disable-rpath-install \
91        --bundled-libraries=NONE \
92        --builtin-libraries=replace \
93        --disable-silent-rules \
94        --extra-python=%{__python3}
95
96make %{?_smp_mflags} V=1
97
98%install
99rm -rf $RPM_BUILD_ROOT
100
101make install DESTDIR=$RPM_BUILD_ROOT
102
103# Shared libraries need to be marked executable for
104# rpmbuild to strip them and include them in debuginfo
105find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
106
107rm -f $RPM_BUILD_ROOT%{_libdir}/libtalloc.a
108rm -f $RPM_BUILD_ROOT/usr/share/swig/*/talloc.i
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root,-)
115%{_libdir}/libtalloc.so.*
116
117%files devel
118%defattr(-,root,root,-)
119%{_includedir}/talloc.h
120%{_libdir}/libtalloc.so
121%{_libdir}/pkgconfig/talloc.pc
122%{_mandir}/man3/talloc.3.gz
123
124%files -n python-talloc
125%defattr(-,root,root,-)
126%{_libdir}/libpytalloc-util.so.*
127%{python_sitearch}/talloc.so
128
129%files -n python-talloc-devel
130%defattr(-,root,root,-)
131%{_includedir}/pytalloc.h
132%{_libdir}/pkgconfig/pytalloc-util.pc
133%{_libdir}/libpytalloc-util.so
134
135%files -n python3-talloc
136%defattr(-,root,root,-)
137%{_libdir}/libpytalloc-util.cpython*.so.*
138%{python3_sitearch}/talloc.cpython*.so
139
140%files -n python3-talloc-devel
141%defattr(-,root,root,-)
142%{_includedir}/pytalloc.h
143%{_libdir}/pkgconfig/pytalloc-util.cpython-*.pc
144%{_libdir}/libpytalloc-util.cpython*.so
145
146%if %{build_compat32}
147
148%files -n compat32-libtalloc
149%attr(755,root,root) %{_libdir}/libtalloc.so.*
150
151%endif
152
153%post -p /sbin/ldconfig
154
155%postun -p /sbin/ldconfig
156
157%post -n python-talloc -p /sbin/ldconfig
158%postun -n python-talloc -p /sbin/ldconfig
159
160%post -n python3-talloc -p /sbin/ldconfig
161%postun -n python3-talloc -p /sbin/ldconfig
162
163%if %{build_compat32}
164
165%post -n compat32-libtalloc -p /sbin/ldconfig
166%postun -n compat32-libtalloc -p /sbin/ldconfig
167
168%endif
169
170%changelog
171* Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.14-1
172- new upstream release.
173
174* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.11-1
175- new upstream release.
176- enabled python3 modules.
177- renamed python packages.
178
179* Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.8-1
180- new upstream release.
181
182* Wed Jun  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.7-1
183- new upstream release.
184
185* Thu Mar 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
186- new upstream release.
187
188* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.5-1
189- new upstream release.
190
191* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.4-1
192- new upstream release.
193
194* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.3-1
195- new upstream release.
196
197* Fri Apr 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.2-1
198- new upstream release.
199
200* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
201- new upstream release.
202
203* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
204- rebuilt with current environment.
205
206* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
207- new upstream release.
208
209* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
210- new upstream release.
211
212* Sat Apr 14 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.7-1
213- new upstream release.
214- updated Patch0001.
215
216* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.5-10
217- rebuild with python-2.7.2
218
219* Thu Mar 24 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-9
220- initial build for Vine Linux.
221
222* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.5-8
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
224
225* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-7
226- Let rpmbuild strip binaries, make build more verbose.
227- Resolves rhbz#669477 - libtalloc 2.0.5-6 binaries not stripped,
228-                        empty -debuginfo
229- Original patch by Ville Skyttä <ville.skytta@iki.fi>
230
231* Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-6
232- Install python bindings in the correct location
233
234* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-5
235- Run ldconfig on pytalloc
236
237* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-4
238- Fix build failure on 32-bit platforms
239
240* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-3
241- New version from upstream
242- Add support for pytalloc
243- Convert to new WAF build-system
244
245* Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 2.0.1-1
246- New version from upstream
247- Also stop building the compat lib, it is not necessary anymore
248
249* Tue Sep  8 2009 Simo Sorce <ssorce@redhat.com> - 2.0.0-0
250- New version from upstream.
251- Build also sover 1 compat library to ease packages migration
252
253* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-2
254- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
255
256* Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-1
257- Original tarballs had a screw-up, rebuild with new fixed tarballs from
258  upstream.
259
260* Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-0
261- New Upstream release.
262
263* Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.3.0-0
264- First public independent release from upstream
Note: See TracBrowser for help on using the repository browser.