source: projects/specs/trunk/lib/libt/libtalloc/libtalloc-vl.spec @ 10363

Revision 10363, 5.8 KB checked in by tomop, 8 years ago (diff)

libtalloc-2.1.7-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libtalloc
4Version: 2.1.7
5Release: 1%{?_dist_release}
6Group: System Environment/Libraries
7Summary: The talloc library
8License: LGPLv3+
9URL: http://talloc.samba.org/
10Source: http://samba.org/ftp/talloc/talloc-%{version}.tar.gz
11BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13BuildRequires: autoconf
14BuildRequires: libxslt
15BuildRequires: docbook-style-xsl
16BuildRequires: python-devel
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: tomop
21
22# Patches
23Patch0001: 0001-Install-python-bindings-in-the-arch-specific-location.patch
24
25%description
26A library that implements a hierarchical allocator with destructors.
27
28%package devel
29Group: Development/Libraries
30Summary: Developer tools for the Talloc library
31Requires: libtalloc = %{version}-%{release}
32
33%description devel
34Header files needed to develop programs that link against the Talloc library.
35
36%package -n pytalloc
37Group: Development/Libraries
38Summary: Developer tools for the Talloc library
39Requires: libtalloc = %{version}-%{release}
40
41%description -n pytalloc
42Pytalloc libraries for creating python bindings using talloc
43
44%package -n pytalloc-devel
45Group: Development/Libraries
46Summary: Developer tools for the Talloc library
47Requires: pytalloc = %{version}-%{release}
48
49%description -n pytalloc-devel
50Development libraries for pytalloc
51
52%if %build_compat32
53
54%package -n compat32-libtalloc
55Summary: The talloc library
56Group: System Environment/Libraries
57
58%description -n compat32-libtalloc
59A library that implements a hierarchical allocator with destructors.
60
61%endif
62
63%prep
64%setup -q -n talloc-%{version}
65%patch0001 -p1
66
67%build
68#./autogen.sh
69%configure --disable-rpath --bundled-libraries=NONE
70make %{?_smp_mflags} V=1
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75make install DESTDIR=$RPM_BUILD_ROOT
76
77# Shared libraries need to be marked executable for
78# rpmbuild to strip them and include them in debuginfo
79find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
80
81rm -f $RPM_BUILD_ROOT%{_libdir}/libtalloc.a
82rm -f $RPM_BUILD_ROOT/usr/share/swig/*/talloc.i
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(-,root,root,-)
89%{_libdir}/libtalloc.so.*
90
91%files devel
92%defattr(-,root,root,-)
93%{_includedir}/talloc.h
94%{_libdir}/libtalloc.so
95%{_libdir}/pkgconfig/talloc.pc
96%{_mandir}/man3/talloc.3.gz
97
98%files -n pytalloc
99%defattr(-,root,root,-)
100%{_libdir}/libpytalloc-util.so.*
101%{python_sitearch}/talloc.so
102
103%files -n pytalloc-devel
104%defattr(-,root,root,-)
105%{_includedir}/pytalloc.h
106%{_libdir}/pkgconfig/pytalloc-util.pc
107%{_libdir}/libpytalloc-util.so
108
109%if %build_compat32
110
111%files -n compat32-libtalloc
112%attr(755,root,root) %{_libdir}/libtalloc.so.*
113
114%endif
115
116%post -p /sbin/ldconfig
117
118%postun -p /sbin/ldconfig
119
120%post -n pytalloc -p /sbin/ldconfig
121%postun -n pytalloc -p /sbin/ldconfig
122
123%if %build_compat32
124
125%post -n compat32-libtalloc -p /sbin/ldconfig
126%postun -n compat32-libtalloc -p /sbin/ldconfig
127
128%endif
129
130%changelog
131* Wed Jun  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.7-1
132- new upstream release.
133
134* Thu Mar 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
135- new upstream release.
136
137* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.5-1
138- new upstream release.
139
140* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.4-1
141- new upstream release.
142
143* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.3-1
144- new upstream release.
145
146* Fri Apr 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.2-1
147- new upstream release.
148
149* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
150- new upstream release.
151
152* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
153- rebuilt with current environment.
154
155* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
156- new upstream release.
157
158* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
159- new upstream release.
160
161* Sat Apr 14 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.7-1
162- new upstream release.
163- updated Patch0001.
164
165* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.5-10
166- rebuild with python-2.7.2
167
168* Thu Mar 24 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-9
169- initial build for Vine Linux.
170
171* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.5-8
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
173
174* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-7
175- Let rpmbuild strip binaries, make build more verbose.
176- Resolves rhbz#669477 - libtalloc 2.0.5-6 binaries not stripped,
177-                        empty -debuginfo
178- Original patch by Ville Skyttä <ville.skytta@iki.fi>
179
180* Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-6
181- Install python bindings in the correct location
182
183* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-5
184- Run ldconfig on pytalloc
185
186* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-4
187- Fix build failure on 32-bit platforms
188
189* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-3
190- New version from upstream
191- Add support for pytalloc
192- Convert to new WAF build-system
193
194* Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 2.0.1-1
195- New version from upstream
196- Also stop building the compat lib, it is not necessary anymore
197
198* Tue Sep  8 2009 Simo Sorce <ssorce@redhat.com> - 2.0.0-0
199- New version from upstream.
200- Build also sover 1 compat library to ease packages migration
201
202* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
204
205* Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-1
206- Original tarballs had a screw-up, rebuild with new fixed tarballs from
207  upstream.
208
209* Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-0
210- New Upstream release.
211
212* Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.3.0-0
213- First public independent release from upstream
Note: See TracBrowser for help on using the repository browser.