source: projects/specs/trunk/lib/libs/libssh2/libssh2-vl.spec @ 521

Revision 521, 3.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A library implementing the SSH2 protocol
2Summary(ja):    SSH2 プロトコルを実装するためのライブラリ
3Name:           libssh2
4Version:        1.0
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        BSD
9URL:            http://www.libssh2.org/
10Source0:        http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires:  openssl-devel
14BuildRequires:  zlib-devel   
15
16%description
17libssh2 is a library implementing the SSH2 protocol as defined by
18Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
19SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
20SECSH-DHGEX(04), and SECSH-NUMBERS(10).
21
22
23%package        devel
24Summary:        Development files for %{name}
25Summary(ja):    %{name} の開発ファイル
26Group:          Development/Libraries
27Requires:       %{name} = %{version}-%{release}
28
29%description    devel
30The %{name}-devel package contains libraries and header files for
31developing applications that use %{name}.
32
33%package        docs
34Summary:        Documentation for %{name}
35Summary(ja):    %{name} のドキュメント
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38
39%description    docs
40The %{name}-docs package contains man pages and examples for
41developing applications that use %{name}.
42
43
44%prep
45%setup -q
46
47# make sure things are UTF-8...
48for i in ChangeLog NEWS ; do
49    iconv --from=ISO-8859-1 --to=UTF-8 $i > new
50    mv new $i
51done
52
53%build
54%configure --disable-static --enable-shared
55
56make %{?_smp_mflags}
57
58
59%install
60rm -rf %{buildroot}
61
62make install DESTDIR=%{buildroot} INSTALL="install -p"
63find %{buildroot} -name '*.la' -exec rm -f {} +
64
65# clean things up a bit for packaging
66( cd example && make clean )
67rm -rf example/simple/.deps
68find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
69
70%check
71(cd tests && make check)
72
73%clean
74rm -rf %{buildroot}
75
76
77%post -p /sbin/ldconfig
78
79%postun -p /sbin/ldconfig
80
81
82%files
83%defattr(-,root,root,-)
84%doc AUTHORS ChangeLog COPYING README NEWS
85%{_libdir}/*.so.*
86
87%files docs
88%defattr(-,root,root,-)
89%doc COPYING HACKING example/
90%{_mandir}/man?/*
91
92%files devel
93%defattr(-,root,root,-)
94%doc COPYING
95%{_includedir}/*
96%{_libdir}/*.so
97
98%changelog
99* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
100- initial build for Vine Linux
101
102* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
103- rebuilt with new openssl
104
105* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
107
108* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
110
111* Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
112- update to 1.0
113
114* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
115- rebuild with new openssl
116
117* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
118- Autorebuild for GCC 4.3
119
120* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
121- rebuild for new openssl...
122
123* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
124- bump
125
126* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
127- add INSTALL arg to make install vs env. var
128
129* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
130- run tests; don't package test
131
132* Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
133- split docs into -docs (they seemed... large.)
134
135* Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
136- update to 0.18
137
138* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
139- update to 0.17
140- many spec file changes
141
142* Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
143- Fix release tag
144- Move manpages to -devel package
145- Add Examples dir to -devel package
146
147* Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
148- Initial build
Note: See TracBrowser for help on using the repository browser.