source: projects/specs/trunk/lib/libs/libssh2/libssh2-vl.spec @ 12056

Revision 12056, 5.8 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library implementing the SSH2 protocol
4Summary(ja):    SSH2 プロトコルを実装するためのライブラリ
5Name:           libssh2
6Version:        1.8.2
7Release:        1%{?_dist_release}
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12Group:          System Environment/Libraries
13License:        BSD
14URL:            http://www.libssh2.org/
15Source0:        http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
16Patch1:         0001-scp-do-not-NUL-terminate-the-command-for-remote-exec.patch
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18
19BuildRequires:  openssl-devel
20BuildRequires:  zlib-devel   
21
22%description
23libssh2 is a library implementing the SSH2 protocol as defined by
24Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
25SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
26SECSH-DHGEX(04), and SECSH-NUMBERS(10).
27
28
29%package        devel
30Summary:        Development files for %{name}
31Summary(ja):    %{name} の開発ファイル
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34
35%description    devel
36The %{name}-devel package contains libraries and header files for
37developing applications that use %{name}.
38
39%package        docs
40Summary:        Documentation for %{name}
41Summary(ja):    %{name} のドキュメント
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}
44
45%description    docs
46The %{name}-docs package contains man pages and examples for
47developing applications that use %{name}.
48
49## to build compat32 for x86_64 architecture support
50%package -n compat32-%{name}
51Summary: A library implementing the SSH2 protocol
52Summary(ja): SSH2 プロトコルを実装するためのライブラリ
53Group: System Environment/Libraries
54
55%description -n compat32-%{name}
56libssh2 is a library implementing the SSH2 protocol as defined by
57Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
58SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
59SECSH-DHGEX(04), and SECSH-NUMBERS(10).
60
61
62%prep
63%setup -q
64
65# scp: do not NUL-terminate the command for remote exec
66# https://bugzilla.redhat.com/show_bug.cgi?id=1489736
67# https://github.com/libssh2/libssh2/pull/208
68%patch1 -p1
69
70# Replace hard wired port number in the test suite to avoid collisions
71# between 32-bit and 64-bit builds running on a single build-host
72sed -i s/4711/47%{__isa_bits}/ tests/ssh2.{c,sh}
73
74# make sure things are UTF-8...
75for i in ChangeLog NEWS ; do
76    iconv --from=ISO-8859-1 --to=UTF-8 $i > new
77    mv new $i
78done
79
80%build
81%configure --disable-static --enable-shared
82
83make %{?_smp_mflags}
84
85%install
86rm -rf %{buildroot}
87
88make install DESTDIR=%{buildroot} INSTALL="install -p"
89find %{buildroot} -name '*.la' -exec rm -f {} +
90
91# clean things up a bit for packaging
92( cd example && make clean )
93rm -rf example/simple/.deps
94find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
95
96%check
97(cd tests && make check)
98
99%clean
100rm -rf %{buildroot}
101
102
103%post -p /sbin/ldconfig
104
105%postun -p /sbin/ldconfig
106
107%post -n compat32-%{name} -p /sbin/ldconfig
108
109%postun -n compat32-%{name} -p /sbin/ldconfig
110
111
112%files
113%defattr(-,root,root,-)
114%doc AUTHORS ChangeLog COPYING README NEWS
115%{_libdir}/*.so.*
116
117%files docs
118%defattr(-,root,root,-)
119%doc COPYING example/ docs/HACKING
120%{_mandir}/man?/*
121
122%files devel
123%defattr(-,root,root,-)
124%doc COPYING
125%{_includedir}/*
126%{_libdir}/*.so
127%{_libdir}/pkgconfig/libssh2.pc
128
129%if %{build_compat32}
130%files -n compat32-%{name}
131%defattr(-,root,root,-)
132%{_libdir}/*.so.*
133%endif
134
135%changelog
136* Thu Mar 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
137- new upstream release.
138
139* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.0-1
140- new upstream release.
141- built with openssl-1.1.1.
142
143* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-2
144- rebuilt with openssl 1.0.2g
145
146* Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-1
147- new upstream release with security fixes
148
149* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
150- new upstream reelase
151- add compat32 package
152
153* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
154- new upstream release
155- fix %%files
156
157* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
158- initial build for Vine Linux
159
160* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
161- rebuilt with new openssl
162
163* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
165
166* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
168
169* Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
170- update to 1.0
171
172* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
173- rebuild with new openssl
174
175* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
176- Autorebuild for GCC 4.3
177
178* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
179- rebuild for new openssl...
180
181* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
182- bump
183
184* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
185- add INSTALL arg to make install vs env. var
186
187* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
188- run tests; don't package test
189
190* Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
191- split docs into -docs (they seemed... large.)
192
193* Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
194- update to 0.18
195
196* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
197- update to 0.17
198- many spec file changes
199
200* Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
201- Fix release tag
202- Move manpages to -devel package
203- Add Examples dir to -devel package
204
205* Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
206- Initial build
Note: See TracBrowser for help on using the repository browser.