source: projects/specs/trunk/lib/libs/libssh2/libssh2-vl.spec @ 12284

Revision 12284, 5.7 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

lmdb-0.9.24-1

libmodsecurity-3.0.3-3

libssh2-1.9.0-1

nginx-1.16.1-2

proftpd-1.3.6b-1

ssdeep-2.14.1-8

yajl-2.1.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A library implementing the SSH2 protocol
4Summary(ja):    SSH2 プロトコルを実装するためのライブラリ
5Name:           libssh2
6Version:        1.9.0
7Release:        1%{?_dist_release}
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12Group:          System Environment/Libraries
13License:        BSD
14URL:            https://www.libssh2.org/
15Source0:        https://www.libssh2.org/download/%{name}-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17
18BuildRequires:  openssl-devel
19BuildRequires:  zlib-devel   
20
21%description
22libssh2 is a library implementing the SSH2 protocol as defined by
23Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
24SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
25SECSH-DHGEX(04), and SECSH-NUMBERS(10).
26
27
28%package        devel
29Summary:        Development files for %{name}
30Summary(ja):    %{name} の開発ファイル
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33
34%description    devel
35The %{name}-devel package contains libraries and header files for
36developing applications that use %{name}.
37
38%package        docs
39Summary:        Documentation for %{name}
40Summary(ja):    %{name} のドキュメント
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43
44%description    docs
45The %{name}-docs package contains man pages and examples for
46developing applications that use %{name}.
47
48## to build compat32 for x86_64 architecture support
49%package -n compat32-%{name}
50Summary: A library implementing the SSH2 protocol
51Summary(ja): SSH2 プロトコルを実装するためのライブラリ
52Group: System Environment/Libraries
53
54%description -n compat32-%{name}
55libssh2 is a library implementing the SSH2 protocol as defined by
56Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
57SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
58SECSH-DHGEX(04), and SECSH-NUMBERS(10).
59
60
61%prep
62%setup -q
63
64# Replace hard wired port number in the test suite to avoid collisions
65# between 32-bit and 64-bit builds running on a single build-host
66sed -i s/4711/47%{__isa_bits}/ tests/ssh2.{c,sh}
67
68# make sure things are UTF-8...
69for i in ChangeLog NEWS ; do
70    iconv --from=ISO-8859-1 --to=UTF-8 $i > new
71    mv new $i
72done
73
74%build
75%configure --disable-static --enable-shared
76
77make %{?_smp_mflags}
78
79%install
80rm -rf %{buildroot}
81
82make install DESTDIR=%{buildroot} INSTALL="install -p"
83find %{buildroot} -name '*.la' -exec rm -f {} +
84
85# clean things up a bit for packaging
86( cd example && make clean )
87rm -rf example/simple/.deps
88find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
89
90%check
91(cd tests && make check)
92
93%clean
94rm -rf %{buildroot}
95
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%post -n compat32-%{name} -p /sbin/ldconfig
102
103%postun -n compat32-%{name} -p /sbin/ldconfig
104
105
106%files
107%defattr(-,root,root,-)
108%license COPYING
109%doc NEWS README* RELEASE-NOTES
110%{_libdir}/*.so.*
111
112%files docs
113%defattr(-,root,root,-)
114%license COPYING
115%doc example/ docs/HACKING
116%{_mandir}/man?/*
117
118%files devel
119%defattr(-,root,root,-)
120%license COPYING
121%{_includedir}/*
122%{_libdir}/*.so
123%{_libdir}/pkgconfig/libssh2.pc
124
125%if %{build_compat32}
126%files -n compat32-%{name}
127%defattr(-,root,root,-)
128%{_libdir}/*.so.*
129%endif
130
131%changelog
132* Thu Oct 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.0-1
133- new upstream release.
134
135* Thu Mar 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
136- new upstream release.
137
138* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.0-1
139- new upstream release.
140- built with openssl-1.1.1.
141
142* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-2
143- rebuilt with openssl 1.0.2g
144
145* Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-1
146- new upstream release with security fixes
147
148* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
149- new upstream reelase
150- add compat32 package
151
152* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
153- new upstream release
154- fix %%files
155
156* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
157- initial build for Vine Linux
158
159* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
160- rebuilt with new openssl
161
162* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
164
165* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
167
168* Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
169- update to 1.0
170
171* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
172- rebuild with new openssl
173
174* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
175- Autorebuild for GCC 4.3
176
177* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
178- rebuild for new openssl...
179
180* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
181- bump
182
183* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
184- add INSTALL arg to make install vs env. var
185
186* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
187- run tests; don't package test
188
189* Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
190- split docs into -docs (they seemed... large.)
191
192* Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
193- update to 0.18
194
195* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
196- update to 0.17
197- many spec file changes
198
199* Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
200- Fix release tag
201- Move manpages to -devel package
202- Add Examples dir to -devel package
203
204* Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
205- Initial build
Note: See TracBrowser for help on using the repository browser.