source: projects/specs/trunk/lib/libs/libsodium/libsodium-vl.spec @ 11094

Revision 11094, 1.9 KB checked in by iwaim, 7 years ago (diff)

new: libsodium

Line 
1%define ver 1.0.12
2%define rel 1
3
4Summary: a modern and easy-to-use crypto library
5Summary(ja): モダンで手軽に使える暗号化ライブラリー
6Name: libsodium
7Version: %{ver}
8Release: %{rel}%{?_dist_release}
9Source0: %{name}-%{version}.tar.gz
10License: ISC
11Group: System Environment/Libraries
12URL: https://github.com/jedisct1/libsodium
13
14#BuildRequires:
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: iwaim
20
21
22%description
23Sodium is a new, easy-to-use software library for encryption, decryption,
24signatures, password hashing and more.
25
26It is a portable, cross-compilable, installable, packageable fork of NaCl,
27with a compatible API, and an extended API to improve usability even further.
28
29Its goal is to provide all of the core operations needed to build
30higher-level cryptographic tools.
31
32%package devel
33Summary: Development files for %{name}
34Summary(ja): %{name} の開発ファイル
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37
38%description devel
39The %{name}-devel package contains libraries and header files for
40developing applications that use %{name}.
41
42
43%prep
44%setup -q
45
46
47%build
48./autogen.sh
49%configure --enable-shared --disable-static
50%{__make} %{?_smp_mflags}
51
52
53%install
54%{__rm} -rf ${RPM_BUILD_ROOT}
55%{__make} install DESTDIR=${RPM_BUILD_ROOT}
56
57%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/libsodium.la
58
59
60%clean
61%{__rm} -rf ${RPM_BUILD_ROOT}
62
63
64%check
65make check
66
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72
73%files
74%defattr(-,root,root)
75%doc LICENSE AUTHORS ChangeLog THANKS README.*
76%{_libdir}/libsodium.so.*
77
78%files devel
79%defattr(-,root,root)
80%doc LICENSE AUTHORS ChangeLog THANKS README.*
81%{_libdir}/pkgconfig/libsodium.pc
82%{_libdir}/libsodium.so
83%{_includedir}/sodium.h
84%{_includedir}/sodium
85
86
87%changelog
88* Mon Jun  5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.12-1
89- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.