source: projects/specs/trunk/lib/libs/libsmbios/libsmbios-vl.spec @ 521

Revision 521, 8.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# these are all substituted by autoconf
2%define major 2
3%define minor 0
4%define sub 1
5%define extralevel %{nil}
6%define release_name libsmbios
7%define release_version %{major}.%{minor}.%{sub}%{extralevel}
8
9Name: %{release_name}
10Version: %{release_version}
11Release: 3%{?_dist_release}
12License: GPLv2+ or OSL
13Group: System Environment/Libraries
14Source: http://linux.dell.com/libsmbios/download/%{name}/%{name}-%{version}/%{name}-%{version}.tar.gz
15URL: http://linux.dell.com/libsmbios/main
16Summary: Libsmbios shared libraries
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18Provides: libsmbios-libs = %{version}-%{release}
19BuildRequires: libxml2-devel
20
21# libsmbios only ever makes sense on intel compatible arches
22# no DMI tables on ppc, s390, etc.
23ExclusiveArch: x86_64 ia64 %{ix86}
24
25#EPEL4/5 dont have cppunit/cppunit-devel, so skip build tests
26# everything else should be able to pull in cppunit to run unit tests
27# during build. Doesnt affect binaries produced, so doesnt affect
28# build reproducability.
29%if %(test "%{dist}" != ".el4" -a "%{dist}" != ".el5" && echo 1 || echo 0)
30BuildRequires: cppunit-devel
31%endif
32
33# no doxygen native for suse
34%if %(test ! -e /etc/SuSE-release && echo 1 || echo 0)
35BuildRequires: doxygen
36%endif
37
38
39%description
40Libsmbios is a library and utilities that can be used by client programs
41to get information from standard BIOS tables, such as the SMBIOS table.
42
43%package -n smbios-utils
44Summary: The "supported" sample binaries that use libsmbios
45Group: Applications/System
46Requires: libsmbios = %{version}-%{release}
47Obsoletes: libsmbios-bin < 0:2.0.0
48Provides: libsmbios-bin = %{version}-%{release}
49Obsoletes: libsmbios-unsupported-bin < 0:2.0.0
50Provides: libsmbios-unsupported-bin = %{version}-%{release}
51Obsoletes: libsmbios-libs < 0:2.0.0
52Provides: libsmbios-libs = %{version}-%{release}
53
54%package devel
55Summary: Development headers and archives
56Group: Development/Libraries
57Requires: libsmbios = %{version}-%{release}
58
59%description devel
60Libsmbios is a library and utilities that can be used by client programs
61to get information from standard BIOS tables, such as the SMBIOS table.
62
63This package contains the headers and .a files necessary to compile new
64client programs against libsmbios.
65
66%description -n smbios-utils
67Libsmbios is a library and utilities that can be used by client programs
68to get information from standard BIOS tables, such as the SMBIOS table.
69
70This package contains some sample binaries that use libsmbios.
71
72%prep
73%setup -q
74find . -type d -exec chmod -f 755 {} \;
75find doc include libraries bin-unsupported build bin-supported cppunit -type f -exec chmod -f 644 {} \;
76chmod 755 cppunit/*.sh
77
78%build
79export EXTRA_CXXFLAGS="%{optflags}"
80export EXTRA_CFLAGS="%{optflags}"
81export RELEASE_MAJOR=%{major}
82export RELEASE_MINOR=%{minor}
83export RELEASE_SUBLEVEL=%{sub}
84export RELEASE_EXTRALEVEL=%{extralevel}
85%configure
86mkdir -p doc/full/html
87make -e %{?_smp_mflags}
88[ ! -d /usr/include/cppunit ] || make -e check
89
90%install
91rm -rf %{buildroot}
92
93make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
94mkdir -p %{buildroot}/usr/include
95cp -a include/smbios %{buildroot}/usr/include/
96rm -f %{buildroot}/%{_libdir}/lib*.la
97find %{buildroot}/usr/include -exec touch -r configure.ac {} \;
98find doc/full -exec touch -r configure.ac {} \;
99
100# backwards compatible:
101ln -s /usr/sbin/dellWirelessCtl %{buildroot}/usr/bin/dellWirelessCtl
102
103%clean
104rm -rf %{buildroot}
105
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108
109%files
110%defattr(-,root,root,-)
111%doc COPYING-GPL COPYING-OSL README
112%{_libdir}/libsmbios.so.*
113
114%files devel
115%defattr(-,root,root,-)
116%doc COPYING-GPL COPYING-OSL README bin-unsupported/getopts_LICENSE.txt
117/usr/include/smbios
118%{_libdir}/libsmbios.a
119%{_libdir}/libsmbios.so
120%doc doc/full/html
121
122%files -n smbios-utils
123%defattr(-,root,root,-)
124%doc COPYING-GPL COPYING-OSL README
125%doc bin-unsupported/getopts_LICENSE.txt include/smbios/config/boost_LICENSE_1_0_txt
126%{_sbindir}/assetTag
127%{_sbindir}/dellBiosUpdate
128%{_sbindir}/getSystemId
129%{_sbindir}/propertyTag
130%{_sbindir}/serviceTag
131%{_sbindir}/verifySmiPassword
132%{_sbindir}/wakeupCtl
133%{_sbindir}/dellLcdBrightness
134
135# used by HAL in old location, so keep it around until HAL is updated.
136%{_sbindir}/dellWirelessCtl
137%{_bindir}/dellWirelessCtl
138
139# community supported stuff...
140# may or may not work
141%{_sbindir}/dellLEDCtl
142%{_sbindir}/activateCmosToken
143%{_sbindir}/ascii2enUS_scancode
144%{_sbindir}/createUnitTestFiles
145%{_sbindir}/disable_console_redir
146%{_sbindir}/dumpCmos
147%{_sbindir}/getPasswordFormat
148%{_sbindir}/isCmosTokenActive
149%{_sbindir}/probes
150%{_sbindir}/smitest
151%{_sbindir}/stateByteCtl
152%{_sbindir}/upBootCtl
153%{_sbindir}/dumpSmbios
154
155# ./ChangeLog is appended by configure
156%changelog
157* Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-3
158- initial build for Vine Linux
159
160* Mon Apr 21 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2.1
161- obsolete libsmbios-libs as well
162
163* Mon Mar 3 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2
164- properly obsolete older versions
165
166* Wed Feb 13 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1
167- Fixup GCC 4.3 compile issues.
168
169* Wed Jan 9 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.0
170- ABI incompatible, minor API changes
171- sync up libsmbios soname with version #
172- move binaries to /usr/sbin as they are only runnable by root
173- drop libsmbiosxml lib as it was mostly unused.
174- drop autotools generated files out of git and add autogen.sh
175- drop tokenCtl binary-- pysmbios has a *much* improved version
176
177* Wed Aug 22 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.9
178- Fix a couple of failure-to-check-return on fopen. most were unit-test code
179  only, but two or three were in regular code.
180- Add hinting to the memory class, so that it can intelligently close /dev/mem
181  file handle when it is not needed (which is most of the time). it only
182  leaves it open when it is scanning, so speed is not impacted.
183
184* Tue Aug 6 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.8
185- new upstream
186
187* Tue Apr 3 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.6
188- critical bugfix for dellBiosUpdate utility for packet mode
189- autoconf/automake support for automatically building docs
190- more readable 'make' lines by splitting out env vars
191- remove run_cppunit option... always run unit tests.
192- update autoconf/automake utilities to latest version
193- fix LDFLAGS to not overwrite user entered LDFLAGS
194- add automatic doxygen build of docs
195- fix urls of public repos
196- remove yum repo page in favor of official page from docs
197- split dmi table entry point from smbios table entry point
198- support legacy _DMI_ tables
199- fix support for EFI-based imacs without proper _SM_ anchor
200
201* Tue Mar 20 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.5
202- rpmlint cleanups
203- Add dellLEDCtl binary
204- update AUTHORS file to add credit for dellLEDCtl
205- update doc/DellToken.txt to add a few more useful tokens.
206- updated build system to create documentation
207- skip cppunit dep on .elX builds (not in EPEL yet)
208
209* Mon Mar 12 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.4-1
210- Added dellWirelessCtl binary
211- Added 'static' makefile target to build static binaries and clean them as well
212- fix for signed/unsigned bug in probes binary. CPU temp misreported
213- simplify interface for DELL_CALLING_INTERFACE_SMI, autodetect Port/Magic
214- document all of the tokens for controlling wireless on dell notebooks
215- enums for SMI args/res to make code match docs better (cbRES1 = res[0], which
216  was confusing.
217- helper functions isTokenActive() and activateToken() to simplify token API.
218- Added missing windows .cpp files to the dist tarball for those who compile
219  windows from dist tarball vs source control
220- Add support for EFI based machines without backwards compatible smbios table
221  entry point in 0xF0000 block.
222- Added wirelessSwitchControl() and wirelessRadioControl() API for newer
223  laptops.
224- fixed bug in TokenDA activate() code where it wasnt properly using SMI
225  (never worked, but apparently wasnt used until now.)
226
227* Tue Oct 3 2006 Michael E Brown <Michael_E_Brown@Dell.com> - 0.13.0-1
228- autotools conversion
229- add Changelog
230
231* Tue Sep 26 2006 Michael E Brown <michael_e_brown at dell.com> - 0.12.4-1
232- Changes per Fedora Packaging Guidelines to prepare to submit to Extras.
233- Add in a changelog entry per Fedora Packaging Guidelines...
234
Note: See TracBrowser for help on using the repository browser.