source: projects/specs/trunk/lib/libs/libsmbios/libsmbios-vl.spec @ 9381

Revision 9381, 14.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-24 Ryoichi INAGAKI <ryo1@…>

  • libmal, libsmbios, libwvstreams: rebuilt
  • libsieve, libxdg-basedir: updated


Line 
1# pkg/libsmbios.spec.  Generated from libsmbios.spec.in by configure.
2# required by suse build system
3# norootforbuild
4
5# these are all substituted by autoconf
6%define major 2
7%define minor 2
8%define micro 28
9%define extra %{nil}
10%define pot_file  libsmbios
11%define lang_dom  libsmbios-2.2-x86_64
12%define release_version 2.2.28
13
14%define release_name libsmbios
15
16Name: %{release_name}
17Version: %{release_version}
18Release: 2%{?_dist_release}
19Summary: Libsmbios C/C++ shared libraries
20Summary(ja): Libsmbios C/C++ 共有ライブラリ
21
22License: GPLv2+ or OSL 2.1
23Group: System Environment/Libraries
24URL: http://linux.dell.com/libsmbios/main
25
26Source: http://linux.dell.com/libsmbios/download/libsmbios/libsmbios-%{version}/libsmbios-%{version}.tar.bz2
27Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: strace libxml2-devel gcc-c++ gettext doxygen cppunit-devel pkgconfig python-devel
29
30# libsmbios only ever makes sense on intel compatible arches
31# no DMI tables on ppc, s390, etc.
32ExclusiveArch: x86_64 ia64 %{ix86}
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: shaolin, daisuke
37
38
39%description
40Libsmbios is a library and utilities that can be used by client programs to get
41information from standard BIOS tables, such as the SMBIOS table.
42
43This package provides the C-based libsmbios library, with a C interface.
44
45This package also has a C++-based library, with a C++ interface. It is not
46actively maintained, but provided for backwards compatibility. New programs
47should use the libsmbios C interface.
48
49
50%package -n python-smbios
51Summary: Python interface to Libsmbios C library
52Summary(ja): libsmbios C ライブラリへの Python インターフェース
53Group: System Environment/Libraries
54Requires: %{release_name} = %{version}-%{release}
55Requires: python
56
57%description -n python-smbios
58This package provides a Python interface to libsmbios
59
60%package -n smbios-utils
61Summary: Meta-package that pulls in all smbios binaries and python scripts
62Summary(ja): すべての smbios プログラムと python スクリプトをインストールするための仮想パッケージ
63Group: Applications/System
64Requires: smbios-utils-bin
65Requires: smbios-utils-python
66
67%description -n smbios-utils
68This is a meta-package that pulls in the binary libsmbios executables as well
69as the python executables.
70
71%package -n smbios-utils-bin
72Summary: Binary utilities that use libsmbios
73Summary(ja): libsmbios を用いたユーティリティ集
74Group: Applications/System
75Requires: %{release_name} = %{version}-%{release}
76
77%description -n smbios-utils-bin
78Get BIOS information, such as System product name, product id, service tag and
79asset tag.
80
81%package -n smbios-utils-python
82Summary: Python executables that use libsmbios
83Summary(ja): libsmbios を用いた Python スクリプト集
84Group: Applications/System
85Requires: python-smbios = %{version}-%{release}
86
87%description -n smbios-utils-python
88Get BIOS information, such as System product name, product id, service tag and
89asset tag. Set service and asset tags on Dell machines. Manipulate wireless
90cards/bluetooth on Dell laptops. Set BIOS password on select Dell systems.
91Update BIOS on select Dell systems. Set LCD brightness on select Dell laptops.
92
93# name the devel package libsmbios-devel regardless of package name, per suse/fedora convention
94%package -n libsmbios-devel
95Summary: Development headers and archives
96Summary(ja): libsmbios の開発用ヘッダファイルとライブラリ
97Group: Development/Libraries
98Requires: %{release_name} = %{version}-%{release}
99
100%description -n libsmbios-devel
101Libsmbios is a library and utilities that can be used by client programs to get
102information from standard BIOS tables, such as the SMBIOS table.
103
104This package contains the headers and .a files necessary to compile new client
105programs against libsmbios.
106
107%prep
108
109%setup -q -n libsmbios-%{version}
110find . -type d -exec chmod -f 755 {} \;
111find doc src -type f -exec chmod -f 644 {} \;
112chmod 755 src/cppunit/*.sh
113
114%build
115# this line lets us build an RPM directly from a git tarball
116# and retains any customized version information we might have
117[ -e ./configure ] || ./autogen.sh --no-configure
118
119mkdir _build
120cd _build
121echo '../configure "$@"' > configure
122chmod +x ./configure
123
124%configure
125
126mkdir -p out/libsmbios_c
127mkdir -p out/libsmbios_c++
128make %{?_smp_mflags} 2>&1 | tee build-%{_arch}.log
129
130echo \%doc _build/build-%{_arch}.log > buildlogs.txt
131
132%install
133rm -rf %{buildroot}
134mkdir %{buildroot}
135
136cd _build
137TOPDIR=..
138make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
139mkdir -p %{buildroot}/%{_includedir}
140cp -a $TOPDIR/src/include/*  %{buildroot}/%{_includedir}/
141cp -a out/public-include/*  %{buildroot}/%{_includedir}/
142rm -f %{buildroot}/%{_libdir}/lib*.{la,a}
143find %{buildroot}/%{_includedir} out/libsmbios_c++ out/libsmbios_c -exec touch -r $TOPDIR/configure.ac {} \;
144
145mv out/libsmbios_c++  out/libsmbios_c++-%{_arch}
146mv out/libsmbios_c    out/libsmbios_c-%{_arch}
147
148rename %{pot_file}.mo %{lang_dom}.mo $(find %{buildroot}/%{_datadir} -name %{pot_file}.mo)
149%find_lang %{lang_dom}
150
151touch files-yum-dellsysid
152touch files-smbios-utils-python
153touch files-python-smbios
154
155# backwards compatible:
156ln -s %{_sbindir}/dellWirelessCtl %{buildroot}/%{_bindir}/dellWirelessCtl
157ln -s smbios-sys-info %{buildroot}/%{_sbindir}/getSystemId
158ln -s smbios-wireless-ctl %{buildroot}/%{_sbindir}/dellWirelessCtl
159ln -s smbios-lcd-brightness %{buildroot}/%{_sbindir}/dellLcdBrightness
160ln -s smbios-rbu-bios-update %{buildroot}/%{_sbindir}/dellBiosUpdate
161
162cat > files-python-smbios <<-EOF
163        %doc COPYING-GPL COPYING-OSL README
164        %{python_sitelib}/*
165EOF
166
167cat > files-smbios-utils-python <<-EOF
168        %doc COPYING-GPL COPYING-OSL README
169        %doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
170        %doc doc/pkgheader.sh
171        %dir %{_sysconfdir}/libsmbios
172        %config(noreplace) %{_sysconfdir}/libsmbios/*
173       
174        # python utilities
175        %{_sbindir}/smbios-sys-info
176        %{_sbindir}/smbios-token-ctl
177        %{_sbindir}/smbios-passwd
178        %{_sbindir}/smbios-wakeup-ctl
179        %{_sbindir}/smbios-wireless-ctl
180        %{_sbindir}/smbios-rbu-bios-update
181        %{_sbindir}/smbios-lcd-brightness
182       
183        # symlinks: backwards compat
184        %{_sbindir}/dellLcdBrightness
185        %{_sbindir}/getSystemId
186        %{_sbindir}/dellWirelessCtl
187        %{_sbindir}/dellBiosUpdate
188        # used by HAL in old location, so keep it around until HAL is updated.
189        %{_bindir}/dellWirelessCtl
190       
191        # data files
192        %{_datadir}/smbios-utils
193EOF
194
195%clean
196rm -rf %{buildroot}
197
198%post   -n %{release_name}   -p /sbin/ldconfig
199%postun -n %{release_name}   -p /sbin/ldconfig
200
201%files -f _build/%{lang_dom}.lang
202%defattr(-,root,root,-)
203%{_libdir}/libsmbios_c.so.*
204%{_libdir}/libsmbios.so.*
205
206%files -n libsmbios-devel -f _build/buildlogs.txt
207%defattr(-,root,root,-)
208%doc COPYING-GPL COPYING-OSL README src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
209%{_includedir}/smbios
210%{_includedir}/smbios_c
211%{_libdir}/libsmbios.so
212%{_libdir}/libsmbios_c.so
213%{_libdir}/pkgconfig/*.pc
214%doc _build/out/libsmbios_c++-%{_arch}
215%doc _build/out/libsmbios_c-%{_arch}
216
217%files -n smbios-utils
218# opensuse 11.1 enforces non-empty file list :(
219%defattr(-,root,root,-)
220%doc COPYING-GPL COPYING-OSL README
221# no other files.
222
223%files -n smbios-utils-bin
224%defattr(-,root,root,-)
225%doc COPYING-GPL COPYING-OSL README
226%doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
227%doc doc/pkgheader.sh
228#
229# legacy C++
230%{_sbindir}/dellBiosUpdate-compat
231%{_sbindir}/dellLEDCtl
232%ifnarch ia64
233%{_sbindir}/dellMediaDirectCtl
234%endif
235#
236# new C utilities
237%{_sbindir}/smbios-state-byte-ctl
238%{_sbindir}/smbios-get-ut-data
239%{_sbindir}/smbios-upflag-ctl
240%{_sbindir}/smbios-sys-info-lite
241
242%files -n python-smbios -f _build/files-python-smbios
243%defattr(-,root,root,-)
244
245%files -n smbios-utils-python -f _build/files-smbios-utils-python
246%defattr(-,root,root,-)
247
248
249%changelog
250* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.28-2
251- rebuilt on current VineSeed
252- added Japanese summary
253
254* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.28-1
255- update to 2.2.28
256
257* Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.26-1
258- merged with upstream package
259  * Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-3
260  - initial build for Vine Linux
261
262* Mon Sep 27 2010 Matt Domsch <mdomsch@fedoraproject.org> - 2.2.26-3
263- build for Fedora 15
264
265* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.2.19-2
266- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
267
268* Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.26-1
269- implement CSV export of token settings from smbios-token-ctl
270
271* Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.25-1
272- Fix breakage resulting from improperly fixing up constructors for MemoryAccess/CmosAccess. Fixes CLI utilities.
273
274* Fri Jun 11 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.23-1
275- Fixup ABI break where a couple functions that should have been exported were not marked.
276
277* Thu Jun 10 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.22-1
278- Fixup bug in reading asset and service tag where it A) read checksum from wrong location and B) used wrong comparison check to validate it
279- enable service tag SET for machines that still set service tag in CMOS
280- ABI/API - change to -fvisibility=hidden for libsmbios_c.so.*, mark public api's. This removes all non-public symbols that were not formerly part of the ABI from the dynamic link table.
281
282* Mon May 18 2009 Matt Domsch <Matt_Domsch@dell.com> - 2.2.16-3
283- split yum plugin into yum-dellsysid package
284
285* Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.16-1
286- add gcc 4.4 support
287
288* Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.15-1
289- update to lastest upstream.
290- fixes bug in bios update on systems with versions like x.y.z.
291
292* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.13-2
293- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
294
295* Tue Feb 3 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
296- Add feature to turn on debugging printf()'s without recompiling by setting
297  certain environment variables:
298    LIBSMBIOS_C_DEBUG_OUTPUT_ALL    -- all debugging output
299        or, per module:
300    LIBSMBIOS_C_DEBUG_CONSTRUCTOR_C
301    LIBSMBIOS_C_DEBUG_SYSINFO_C
302    LIBSMBIOS_C_DEBUG_SMBIOS_C
303    LIBSMBIOS_C_DEBUG_TOKEN_C
304    LIBSMBIOS_C_DEBUG_MEMORY_C
305    LIBSMBIOS_C_DEBUG_CMOS_C
306    LIBSMBIOS_C_DEBUG_SMI_C
307
308* Mon Feb 2 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
309- Add pkgconfig files to -devel
310- fixup yum plugin to not parse certain data that causes a crash on some machines (Optiplex 755, others may be affected)
311
312* Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.8-1
313- revert change in upstream renaming rpm to libsmbios2
314
315* Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.7-1
316- change source to bz2 format
317- Update to latest upstream release. Many changes in the new release:
318  - python interface
319  - libsmbios_c interface almost fully implemented
320  - libsmbios c++ interface deprecated
321
322* Tue Oct 28 2008 Michael E Brown <michael_e_brown at dell.com> - 2.2.0-1
323- Spec updates
324
325* Mon Apr 21 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2.1
326- obsolete libsmbios-libs as well
327
328* Mon Mar 3 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2
329- properly obsolete older versions
330
331* Wed Feb 13 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1
332- Fixup GCC 4.3 compile issues.
333
334* Wed Jan 9 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.0
335- ABI incompatible, minor API changes
336- sync up libsmbios soname with version #
337- move binaries to /usr/sbin as they are only runnable by root
338- drop libsmbiosxml lib as it was mostly unused.
339- drop autotools generated files out of git and add autogen.sh
340- drop tokenCtl binary-- pysmbios has a *much* improved version
341
342* Wed Aug 22 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.9
343- Fix a couple of failure-to-check-return on fopen. most were unit-test code
344  only, but two or three were in regular code.
345- Add hinting to the memory class, so that it can intelligently close /dev/mem
346  file handle when it is not needed (which is most of the time). it only
347  leaves it open when it is scanning, so speed is not impacted.
348
349* Tue Aug 6 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.8
350- new upstream
351
352* Tue Apr 3 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.6
353- critical bugfix for dellBiosUpdate utility for packet mode
354- autoconf/automake support for automatically building docs
355- more readable 'make' lines by splitting out env vars
356- remove run_cppunit option... always run unit tests.
357- update autoconf/automake utilities to latest version
358- fix LDFLAGS to not overwrite user entered LDFLAGS
359- add automatic doxygen build of docs
360- fix urls of public repos
361- remove yum repo page in favor of official page from docs
362- split dmi table entry point from smbios table entry point
363- support legacy _DMI_ tables
364- fix support for EFI-based imacs without proper _SM_ anchor
365
366* Tue Mar 20 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.5
367- rpmlint cleanups
368- Add dellLEDCtl binary
369- update AUTHORS file to add credit for dellLEDCtl
370- update doc/DellToken.txt to add a few more useful tokens.
371- updated build system to create documentation
372- skip cppunit dep on .elX builds (not in EPEL yet)
373
374* Mon Mar 12 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.4-1
375- Added dellWirelessCtl binary
376- Added 'static' makefile target to build static binaries and clean them as well
377- fix for signed/unsigned bug in probes binary. CPU temp misreported
378- simplify interface for DELL_CALLING_INTERFACE_SMI, autodetect Port/Magic
379- document all of the tokens for controlling wireless on dell notebooks
380- enums for SMI args/res to make code match docs better (cbRES1 = res[0], which
381  was confusing.
382- helper functions isTokenActive() and activateToken() to simplify token API.
383- Added missing windows .cpp files to the dist tarball for those who compile
384  windows from dist tarball vs source control
385- Add support for EFI based machines without backwards compatible smbios table
386  entry point in 0xF0000 block.
387- Added wirelessSwitchControl() and wirelessRadioControl() API for newer
388  laptops.
389- fixed bug in TokenDA activate() code where it wasnt properly using SMI
390  (never worked, but apparently wasnt used until now.)
391
392* Tue Oct 3 2006 Michael E Brown <Michael_E_Brown@Dell.com> - 0.13.0-1
393- autotools conversion
394- add Changelog
395
396* Tue Sep 26 2006 Michael E Brown <michael_e_brown at dell.com> - 0.12.4-1
397- Changes per Fedora Packaging Guidelines to prepare to submit to Extras.
398- Add in a changelog entry per Fedora Packaging Guidelines...
399
Note: See TracBrowser for help on using the repository browser.