source: projects/specs/trunk/lib/libs/libsmbios/libsmbios-vl.spec @ 12476

Revision 12476, 8.0 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

createrepo_c-0.16.0-1

dovecot-2.3.11.3-2

libsmbios-2.4.3-2

python-sphinx-3.2.1-2

python-sphinxcontrib-jsmath-1.0.1-10

rspamd-2.5-3

strongswan-5.9.0-1

system-storage-manager-1.4-1

trousers-0.3.14-1

RevLine 
[12371]1Name: libsmbios
2Version: 2.4.3
[12476]3Release: 2%{?_dist_release}
[9381]4Summary: Libsmbios C/C++ shared libraries
5Summary(ja): Libsmbios C/C++ 共有ライブラリ
[12476]6Group: system
[12371]7Vendor: Project Vine
8Distribution: Vine Linux
9Packager: shaolin, daisuke
[9381]10
[12371]11License: GPLv2+ or OSL 2.1
12URL: https://github.com/dell/libsmbios
13Source: https://github.com/dell/libsmbios/archive/v%{version}.tar.gz#/libsmbios-%{version}.tar.gz
14Source100: ChangeLog.fedora
[9381]15Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
[3684]16BuildRequires: strace libxml2-devel gcc-c++ gettext doxygen cppunit-devel pkgconfig python-devel
[12371]17Obsoletes: python-smbios < %{version}-%{release}
[521]18
19# libsmbios only ever makes sense on intel compatible arches
20# no DMI tables on ppc, s390, etc.
21ExclusiveArch: x86_64 ia64 %{ix86}
22
[12371]23# these are all substituted by autoconf
24%define pot_file  libsmbios
25%define lang_dom  libsmbios-2.4-x86_64
[521]26
[12371]27%define major %(echo %{version} | sed -e 's/^\\([0-9]*\\)\..*$/\\1/')
28%define minor %(echo %{version} | sed -e 's/^[0-9]*\\.\\([0-9]*\\).*$/\\1/')
29%define micro %(echo %{version} | sed -e 's/^[0-9]*\\.[0-9]*\\.\\([0-9]*\\).*$/\\1/')
30%define extra %{nil}
[521]31
32%description
[3684]33Libsmbios is a library and utilities that can be used by client programs to get
34information from standard BIOS tables, such as the SMBIOS table.
[521]35
[3684]36This package provides the C-based libsmbios library, with a C interface.
37
38This package also has a C++-based library, with a C++ interface. It is not
39actively maintained, but provided for backwards compatibility. New programs
40should use the libsmbios C interface.
41
42
[12371]43%package -n python3-smbios
[3684]44Summary: Python interface to Libsmbios C library
[9381]45Summary(ja): libsmbios C ライブラリへの Python インターフェース
[12476]46Group: programming
[12371]47BuildRequires: python3-devel python3-setuptools python3-rpm-macros
48Requires: %{name} = %{version}-%{release}
49Requires: python3
[3684]50
[12371]51%description -n python3-smbios
[3684]52This package provides a Python interface to libsmbios
53
[12476]54
[521]55%package -n smbios-utils
[3684]56Summary: Meta-package that pulls in all smbios binaries and python scripts
[9381]57Summary(ja): すべての smbios プログラムと python スクリプトをインストールするための仮想パッケージ
[12476]58Group: admin-tools
[12371]59Requires: smbios-utils-bin = %{version}-%{release}
60Requires: smbios-utils-python3 = %{version}-%{release}
[521]61
[3684]62%description -n smbios-utils
63This is a meta-package that pulls in the binary libsmbios executables as well
64as the python executables.
65
[12476]66
[3684]67%package -n smbios-utils-bin
68Summary: Binary utilities that use libsmbios
[9381]69Summary(ja): libsmbios を用いたユーティリティ集
[12476]70Group: admin-tools
[12371]71Requires: %{name} = %{version}-%{release}
[3684]72
73%description -n smbios-utils-bin
74Get BIOS information, such as System product name, product id, service tag and
75asset tag.
76
[12476]77
[12371]78%package -n smbios-utils-python3
[3684]79Summary: Python executables that use libsmbios
[9381]80Summary(ja): libsmbios を用いた Python スクリプト集
[12476]81Group: admin-tools
[12371]82Requires: python3-smbios = %{version}-%{release}
83Obsoletes: smbios-utils-python < %{version}-%{release}
84Provides: smbios-utils-python = %{version}-%{release}
[3684]85
[12371]86%description -n smbios-utils-python3
[3684]87Get BIOS information, such as System product name, product id, service tag and
88asset tag. Set service and asset tags on Dell machines. Manipulate wireless
89cards/bluetooth on Dell laptops. Set BIOS password on select Dell systems.
90Update BIOS on select Dell systems. Set LCD brightness on select Dell laptops.
91
[12476]92
[3684]93# name the devel package libsmbios-devel regardless of package name, per suse/fedora convention
94%package -n libsmbios-devel
[521]95Summary: Development headers and archives
[9381]96Summary(ja): libsmbios の開発用ヘッダファイルとライブラリ
[12476]97Group: programming
[12371]98Requires: %{name} = %{version}-%{release}
[521]99
[3684]100%description -n libsmbios-devel
101Libsmbios is a library and utilities that can be used by client programs to get
102information from standard BIOS tables, such as the SMBIOS table.
[521]103
[3684]104This package contains the headers and .a files necessary to compile new client
105programs against libsmbios.
[521]106
[12476]107
[3684]108%prep
109%setup -q -n libsmbios-%{version}
[521]110find . -type d -exec chmod -f 755 {} \;
[3684]111find doc src -type f -exec chmod -f 644 {} \;
112chmod 755 src/cppunit/*.sh
[521]113
[12371]114
[521]115%build
[3684]116# this line lets us build an RPM directly from a git tarball
117# and retains any customized version information we might have
118[ -e ./configure ] || ./autogen.sh --no-configure
119
120mkdir _build
121cd _build
122echo '../configure "$@"' > configure
123chmod +x ./configure
124
[12371]125export PYTHON=%{__python3}
[521]126%configure
127
[3684]128mkdir -p out/libsmbios_c
129mkdir -p out/libsmbios_c++
130make %{?_smp_mflags} 2>&1 | tee build-%{_arch}.log
131
132echo \%doc _build/build-%{_arch}.log > buildlogs.txt
133
[12371]134
[521]135%install
136rm -rf %{buildroot}
[3684]137mkdir %{buildroot}
[521]138
[3684]139cd _build
140TOPDIR=..
[521]141make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
[3684]142mkdir -p %{buildroot}/%{_includedir}
[10512]143mkdir -p %{buildroot}/%{_bindir}
[3684]144cp -a $TOPDIR/src/include/*  %{buildroot}/%{_includedir}/
145cp -a out/public-include/*  %{buildroot}/%{_includedir}/
146rm -f %{buildroot}/%{_libdir}/lib*.{la,a}
[12371]147rm -f %{buildroot}/%{_includedir}/Makefile.am
[3684]148find %{buildroot}/%{_includedir} out/libsmbios_c++ out/libsmbios_c -exec touch -r $TOPDIR/configure.ac {} \;
[521]149
[3684]150mv out/libsmbios_c++  out/libsmbios_c++-%{_arch}
151mv out/libsmbios_c    out/libsmbios_c-%{_arch}
152
153rename %{pot_file}.mo %{lang_dom}.mo $(find %{buildroot}/%{_datadir} -name %{pot_file}.mo)
154%find_lang %{lang_dom}
155
156touch files-yum-dellsysid
[12371]157touch files-smbios-utils-python3
158touch files-python3-smbios
[3684]159
[12371]160cat > files-python3-smbios <<-EOF
161        %{python3_sitearch}/*
[3684]162EOF
163
[12371]164cat > files-smbios-utils-python3 <<-EOF
[3684]165        %dir %{_sysconfdir}/libsmbios
166        %config(noreplace) %{_sysconfdir}/libsmbios/*
167       
168        # python utilities
169        %{_sbindir}/smbios-sys-info
170        %{_sbindir}/smbios-token-ctl
171        %{_sbindir}/smbios-passwd
172        %{_sbindir}/smbios-wakeup-ctl
173        %{_sbindir}/smbios-wireless-ctl
174        %{_sbindir}/smbios-lcd-brightness
[10512]175        %{_sbindir}/smbios-keyboard-ctl
176        %{_sbindir}/smbios-thermal-ctl
[12371]177        %{_sbindir}/smbios-battery-ctl
[10512]178
[3684]179        # data files
180        %{_datadir}/smbios-utils
181EOF
182
[12476]183
[521]184%clean
185rm -rf %{buildroot}
186
[12476]187
[12371]188%post   -p /sbin/ldconfig
189%postun -p /sbin/ldconfig
[521]190
[12476]191
[3684]192%files -f _build/%{lang_dom}.lang
[521]193%defattr(-,root,root,-)
[12371]194%license COPYING* src/bin/getopts_LICENSE.txt src/include/smbios_c/config/boost_LICENSE_1_0_txt
195%doc README*
[3684]196%{_libdir}/libsmbios_c.so.*
[521]197
[3684]198%files -n libsmbios-devel -f _build/buildlogs.txt
[521]199%defattr(-,root,root,-)
[3684]200%{_includedir}/smbios
201%{_includedir}/smbios_c
202%{_libdir}/libsmbios_c.so
203%{_libdir}/pkgconfig/*.pc
204%doc _build/out/libsmbios_c++-%{_arch}
205%doc _build/out/libsmbios_c-%{_arch}
[521]206
207%files -n smbios-utils
[3684]208# opensuse 11.1 enforces non-empty file list :(
[521]209%defattr(-,root,root,-)
[12371]210%license COPYING-GPL COPYING-OSL
211%doc README*
[3684]212# no other files.
[521]213
[3684]214%files -n smbios-utils-bin
215%defattr(-,root,root,-)
[12371]216%license COPYING-GPL COPYING-OSL
217%license src/bin/getopts_LICENSE.txt src/include/smbios_c/config/boost_LICENSE_1_0_txt
218%doc README*
[3684]219#
220# new C utilities
221%{_sbindir}/smbios-state-byte-ctl
222%{_sbindir}/smbios-get-ut-data
223%{_sbindir}/smbios-upflag-ctl
224%{_sbindir}/smbios-sys-info-lite
[521]225
[12371]226%files -n python3-smbios -f _build/files-python3-smbios
[3684]227%defattr(-,root,root,-)
[12371]228%license COPYING-GPL COPYING-OSL
229%doc README*
[3684]230
[12371]231%files -n smbios-utils-python3 -f _build/files-smbios-utils-python3
[3684]232%defattr(-,root,root,-)
[12371]233%license COPYING-GPL COPYING-OSL
234%license src/bin/getopts_LICENSE.txt src/include/smbios_c/config/boost_LICENSE_1_0_txt
235%doc README*
[3684]236
237
[521]238%changelog
[12476]239* Tue Aug 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.3-2
240- rebuilt with python3.8.
241
[12371]242* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.3-1
243- new upstream release.
244- dropped python2 support.
245- added python3 support.
246- truncated %%changelog: old logs are ChangeLog.fedora.
247
[10512]248* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
249- new upstream release.
250
[9381]251* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.28-2
252- rebuilt on current VineSeed
253- added Japanese summary
254
[5701]255* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.28-1
256- update to 2.2.28
257
[3684]258* Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.26-1
259- merged with upstream package
260  * Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-3
261  - initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.