source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 12539

Revision 12539, 8.2 KB checked in by tomop, 3 years ago (diff)

updated 6 packages

chrpath-0.16-2

doxygen-1.9.1-1

libsigc++-2.10.6-1

pavucontrol-4.0-1

pulseaudio-14.2-1

xmlto-0.0.28-1

Line 
1%define lib_name sigc++-2.0
2
3Summary: The Typesafe Signal Framework for C++
4Summary(ja): C++ 用の型安全なシグナルフレームワーク
5Name: libsigc++
6Version: 2.10.6
7Release: 1%{?_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: LGPLv2
13URL: https://github.com/libsigcplusplus/libsigcplusplus
14%global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
15Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gcc-c++
19BuildRequires: m4
20BuildRequires: mm-common
21
22%description
23This library implements a full callback system for use in widget libraries,
24abstract interfaces, and general programming. Originally part of the Gtk--
25widget set, %{name} is now a seperate library to provide for more general
26use. It is the most complete library of its kind with the ablity to connect
27an abstract callback to a class method, function, or function object. It
28contains adaptor classes for connection of dissimilar callbacks and has an
29ease of use unmatched by other C++ callback libraries.
30
31Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
32
33
34%package devel
35Summary: development tools for the Typesafe Signal Framework for C++
36Group: programming
37Requires: %{name} = %{version}-%{release}
38Requires: pkgconfig
39
40%description devel
41The %{name}-devel package contains the static libraries and header files
42needed for development with %{name}.
43
44
45%package examples
46Summary: examples and tests for the Typesafe Signal Framework for C++
47Group: programming
48Requires: %{name}-devel = %{version}-%{release}
49
50%description examples
51The %{name}-devel package contains source code of example and test
52programs for %{name}.
53
54
55%debug_package
56
57
58%prep
59%setup -q
60
61
62%build
63./autogen.sh
64%configure --disable-static --enable-silent-rules
65make %{_smp_mflags}
66
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install DESTDIR=$RPM_BUILD_ROOT
71
72# removed unpackage files
73rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
74
75mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
76cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
77find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
78find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
79find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
80        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
81
82for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
83        rm -f $i.*
84done
85
86rm -rf docs-toinstall
87mkdir -p docs-to-install
88cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
89rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
90
91# devhelp path fix
92sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
93#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
94
95
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root,755)
106%license COPYING
107%doc AUTHORS README NEWS ChangeLog TODO
108%attr(755,root,root) %{_libdir}/lib*.so.*
109
110%files devel
111%defattr(-,root,root,755)
112%{_includedir}/*
113%{_libdir}/%{lib_name}/include
114%{_libdir}/pkgconfig/*.pc
115#{_libdir}/lib*.la
116%{_libdir}/lib*.so
117%{_datadir}/devhelp/books/%{name}-2.0/*
118%doc docs-to-install/index.html docs-to-install/images
119%doc docs-to-install/reference docs-to-install/tutorial
120
121%files examples
122%defattr(-,root,root,755)
123%{_libdir}/%{lib_name}/examples
124%{_libdir}/%{lib_name}/tests
125
126
127%changelog
128* Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.6-1
129- new upstream release.
130
131* Sat Aug 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.3-1
132- new upstream release.
133
134* Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.2-1
135- new upstream release.
136
137* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.0-1
138- new upstream release.
139
140* Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
141- new upstream release
142
143* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-2
144- rebuild with gcc-5.4.0
145
146* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
147- new upstream release
148
149* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
150- new upstream release
151
152* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
153- new upstream release
154
155* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
156- new upstream release
157
158* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
159- build with rpm-4.8.1-1 for pkg-config file
160
161* Thu Sep  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
162- new upstream release
163
164* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
165- new upstream release
166- built with new toolchain
167
168* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
169- new upstream release
170- remove static libraries from devel package
171
172* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
173- new upstream release
174- spec in UTF-8
175
176* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
177- removed .la files from devel package
178
179* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
180- new upstream release
181
182* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
183- rebuild with new environment/toolchain
184
185* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
186- new upstream release
187
188* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
189- rebuild with new libtool
190
191* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
192- new upstream release
193
194* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
195- new upstream release
196
197* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
198- new upstream release
199
200* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
201- new upstream release
202- added tutorial to devel package
203
204* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
205- update to 2.0.6
206
207* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
208- update to 1.2.5
209- add Requires: pkgconfig
210
211* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
212- rebuild to remove dependance <5371>
213- add Japanese summary
214- use better macros
215- s/Copyright/License/
216
217* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
218- rebuild with new toolchain
219
220* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
221- 1.0.4-0vl1
222- Build for Vine Linux 2.5
223
224* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
225- packaged for Vine Linux 2.1
226
227* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
228- updated Url and Source fileds
229- 1.0.0 stable release
230
231* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
232- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
233- minor install section cleanup
234
235* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
236- autogen just creates configure, not runs it, so cleaned that up too.
237
238* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
239- minor attr fix
240- removed unnecessary curly braces
241- fixed Herbert's adjustement
242
243* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
244- minor package dependence fix
245
246* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
247- fixed typo of mine
248- added traditional CUSTOM_RELEASE stuff
249- added SMP support
250
251* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
252- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
253
254* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
255- split into three packages: %name, %name-devel and %name-examples
256
257* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
258- updated source field and merged conflicts between revisions.
259
260* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
261- updated Prefix and BuildRoot fields
262
263* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
264- made sure configure works on all alphas
265
266* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
267- Added autoconf macro for sigc.
268
269* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
270- Made into a .in to keep version field up to date
271- Still need to do release by hand
272
273* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
274- added Vendor and Packager fields
275
276* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
277- updated to 0.8.0
278
279* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
280- initial revision
Note: See TracBrowser for help on using the repository browser.