source: projects/specs/trunk/lib/libs/libsigc++12/libsigc++12-vl.spec @ 1901

Revision 1901, 5.8 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define version 1.2.7
2%define release 2%{?_dist_release}
3
4%define lib_name sigc++-1.2
5
6Summary: The Typesafe Signal Framework for C++
7Summary(ja): C++ 用の型安全なシグナルフレームワーク
8Name: libsigc++12
9Version: %{version}
10Release: %{release}
11Source: libsigc++-%{version}.tar.bz2
12License: LGPL
13Group: System Environment/Libraries
14URL: http://libsigc.sourceforge.net/
15
16BuildRequires: gcc-c++ m4
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18
19%description
20This library implements a full callback system for use in widget libraries,
21abstract interfaces, and general programming. Originally part of the Gtk--
22widget set, libsigc++ is now a seperate library to provide for more general
23use. It is the most complete library of its kind with the ablity to connect
24an abstract callback to a class method, function, or function object. It
25contains adaptor classes for connection of dissimilar callbacks and has an
26ease of use unmatched by other C++ callback libraries.
27
28Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
29
30
31%package devel
32Summary: development tools for the Typesafe Signal Framework for C++
33Group: Development/Libraries
34Requires: %{name} = %{version}
35Requires: pkgconfig
36
37%description devel
38The %{name}-devel package contains the static libraries and header files
39needed for development with %{name}.
40
41%package examples
42Summary: examples and tests for the Typesafe Signal Framework for C++
43Group: Development/Libraries
44Requires: %{name}-devel = %{version}
45
46%description examples
47The %{name}-devel package contains source code of example and test
48programs for libsigc++.
49
50%prep
51%setup -q -n libsigc++-%{version}
52
53%build
54%configure
55export tagname=CC
56make %{_smp_mflags} LIBTOOL=/usr/bin/libtool
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61export tagname=CC
62%makeinstall LIBTOOL=/usr/bin/libtool
63
64# Clean up the docs
65find doc -name "Makefile*" | xargs rm -f
66
67mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
68
69cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
70find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
71find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
72        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
73
74for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/examples/Makefile; do
75        rm -f $i.*
76        cp -p scripts/examples.Makefile $i
77done
78for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/tests/Makefile; do
79        rm -f $i.*
80        cp -p scripts/tests.Makefile $i
81done
82
83## remove unuse files
84rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
85
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(-,root,root,755)
96%doc AUTHORS COPYING.LIB README IDEAS NEWS ChangeLog TODO
97%attr(755,root,root) %{_libdir}/lib*.so.*
98
99%files devel
100%defattr(-,root,root,755)
101%doc doc/*
102%{_includedir}/*
103%{_libdir}/%{lib_name}/include
104%{_libdir}/pkgconfig/*.pc
105%attr(755,root,root) %{_libdir}/lib*.so
106%attr(644,root,root) %{_libdir}/*a
107
108%files examples
109%defattr(-,root,root,755)
110%{_libdir}/%{lib_name}/examples
111%{_libdir}/%{lib_name}/tests
112
113%changelog
114* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-2
115- rebuild with rpm-4.8.1 for pkg-config file
116
117* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.7-1vl5
118- applied new versioning policy, spec in utf-8
119- removed *.la
120
121* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl2
122- rebuilt with new toolchain
123
124* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
125- new upstream release
126
127* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl2
128- package name changed to libsigc++12
129
130* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
131- update to 1.2.5
132- add Requires: pkgconfig
133
134* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
135- rebuild to remove dependance <5371>
136- add Japanese summary
137- use better macros
138- s/Copyright/License/
139
140* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
141- rebuild with new toolchain
142
143* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
144- 1.0.4-0vl1
145- Build for Vine Linux 2.5
146
147* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
148- packaged for Vine Linux 2.1
149
150* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
151- updated Url and Source fileds
152- 1.0.0 stable release
153
154* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
155- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
156- minor install section cleanup
157
158* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
159- autogen just creates configure, not runs it, so cleaned that up too.
160
161* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
162- minor attr fix
163- removed unnecessary curly braces
164- fixed Herbert's adjustement
165
166* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
167- minor package dependence fix
168
169* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
170- fixed typo of mine
171- added traditional CUSTOM_RELEASE stuff
172- added SMP support
173
174* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
175- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
176
177* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
178- split into three packages: %name, %name-devel and %name-examples
179
180* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
181- updated source field and merged conflicts between revisions.
182
183* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
184- updated Prefix and BuildRoot fields
185
186* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
187- made sure configure works on all alphas
188
189* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
190- Added autoconf macro for sigc.
191
192* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
193- Made into a .in to keep version field up to date
194- Still need to do release by hand
195
196* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
197- added Vendor and Packager fields
198
199* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
200- updated to 0.8.0
201
202* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
203- initial revision
Note: See TracBrowser for help on using the repository browser.