source: projects/specs/trunk/lib/libs/libsigc++10/libsigc++10-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name libsigc++10
2%define version 1.0.4
3%define release 1%{?_dist_release}
4%define lib_name sigc++-1.0
5
6Summary: The Typesafe Signal Framework for C++
7Summary(ja): C++ 用の型安全なシグナルフレームワーク
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/libsigc++-%{version}.tar.gz
12License: LGPL
13Group: System Environment/Libraries
14URL: http://libsigc.sourceforge.net/
15Vendor: Project Vine
16Distribution: Vine Linux
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18
19%description
20This library implements a full callback system for use in widget libraries,
21abstract interfaces, and general programming. Originally part of the Gtk--
22widget set, %{name} is now a seperate library to provide for more general
23use. It is the most complete library of its kind with the ablity to connect
24an abstract callback to a class method, function, or function object. It
25contains adaptor classes for connection of dissimilar callbacks and has an
26ease of use unmatched by other C++ callback libraries.
27
28Package GTK-- (gtkmm), which is a C++ binding to the GTK+ library,
29starting with version 1.1.2, uses %{name}.
30
31%package devel
32Summary: development tools for the Typesafe Signal Framework for C++
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35
36%description devel
37The %{name}-devel package contains the static libraries and header files
38needed for development with %{name}.
39
40%package examples
41Summary: examples and tests for the Typesafe Signal Framework for C++
42Group: Development/Libraries
43Requires: %{name}-devel = %{version}-%{release}
44
45%description examples
46The %{name}-examples package contains source code of example and test
47programs for %{name}.
48
49%prep
50%setup -q -n libsigc++-%{version}
51
52%build
53%configure
54export tagname=CC
55make %{_smp_mflags} LIBTOOL=/usr/bin/libtool
56
57%install
58rm -rf $RPM_BUILD_ROOT
59export tagname=CC
60%makeinstall LIBTOOL=/usr/bin/libtool
61
62mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
63
64cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
65find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
66find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
67        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
68
69for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/examples/Makefile; do
70        rm -f $i.*
71        cp -p scripts/examples.Makefile $i
72done
73for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/tests/Makefile; do
74        rm -f $i.*
75        cp -p scripts/tests.Makefile $i
76done
77
78## remove unuse files
79rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
80
81
82%post -p /sbin/ldconfig
83
84%postun -p /sbin/ldconfig
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(-,root,root,755)
91%attr(755,root,root) %{_libdir}/lib*.so.*
92%doc AUTHORS COPYING.LIB README IDEAS NEWS ChangeLog TODO
93
94%files devel
95%defattr(-,root,root,755)
96%doc doc/*
97%{_bindir}/*
98%{_includedir}/*
99%attr(755,root,root) %{_libdir}/lib*.so
100%attr(644,root,root) %{_libdir}/*.a
101%{_datadir}/aclocal/*
102
103%files examples
104%defattr(-,root,root,755)
105%{_libdir}/%{lib_name}/examples
106%{_libdir}/%{lib_name}/tests
107
108%changelog
109* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.4-1vl5
110- applied new versioning policy, spec in utf-8
111- removed *.la
112
113* Sun Jun 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl5
114- rebuilt with new toolchain
115
116* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl4
117- renamed libsigc++10 in order to allow 1.2 installation
118
119* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
120- rebuild to remove dependance <5371>
121- add Japanese summary
122- use better macros
123- s/Copyright/License/
124
125* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
126- rebuild with new toolchain
127
128* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
129- 1.0.4-0vl1
130- Build for Vine Linux 2.5
131
132* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
133- packaged for Vine Linux 2.1
134
135* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
136- updated Url and Source fileds
137- 1.0.0 stable release
138
139* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
140- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
141- minor install section cleanup
142
143* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
144- autogen just creates configure, not runs it, so cleaned that up too.
145
146* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
147- minor attr fix
148- removed unnecessary curly braces
149- fixed Herbert's adjustement
150
151* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
152- minor package dependence fix
153
154* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
155- fixed typo of mine
156- added traditional CUSTOM_RELEASE stuff
157- added SMP support
158
159* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
160- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
161
162* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
163- split into three packages: %name, %name-devel and %name-examples
164
165* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
166- updated source field and merged conflicts between revisions.
167
168* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
169- updated Prefix and BuildRoot fields
170
171* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
172- made sure configure works on all alphas
173
174* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
175- Added autoconf macro for sigc.
176
177* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
178- Made into a .in to keep version field up to date
179- Still need to do release by hand
180
181* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
182- added Vendor and Packager fields
183
184* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
185- updated to 0.8.0
186
187* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
188- initial revision
Note: See TracBrowser for help on using the repository browser.