source: projects/specs/trunk/lib/libs/libsigc++/libsigc++-vl.spec @ 6933

Revision 6933, 7.5 KB checked in by Takemikaduchi, 12 years ago (diff)

NEW: gnome-clocks, gnote, grilo-plugins, seahorse-nautilus
glabels: add Patch
others: new upstream release

Line 
1%define name libsigc++
2%define version 2.2.11
3%define release 1%{?_dist_release}
4
5%define lib_name sigc++-2.0
6
7Summary: The Typesafe Signal Framework for C++
8Summary(ja): C++ 用の型安全なシグナルフレームワーク
9Name: %{name}
10Version: %{version}
11Release: %{release}
12
13Group: System Environment/Libraries
14License: LGPLv2
15URL: http://libsigc.sourceforge.net/
16
17Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/%{name}-%{version}.tar.xz
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: gcc-c++
21BuildRequires: m4
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26
27%description
28This library implements a full callback system for use in widget libraries,
29abstract interfaces, and general programming. Originally part of the Gtk--
30widget set, %{name} is now a seperate library to provide for more general
31use. It is the most complete library of its kind with the ablity to connect
32an abstract callback to a class method, function, or function object. It
33contains adaptor classes for connection of dissimilar callbacks and has an
34ease of use unmatched by other C++ callback libraries.
35
36Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
37
38
39%package devel
40Summary: development tools for the Typesafe Signal Framework for C++
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: pkgconfig
44
45%description devel
46The %{name}-devel package contains the static libraries and header files
47needed for development with %{name}.
48
49%package examples
50Summary: examples and tests for the Typesafe Signal Framework for C++
51Group: Development/Libraries
52Requires: %{name}-devel = %{version}-%{release}
53
54%description examples
55The %{name}-devel package contains source code of example and test
56programs for %{name}.
57
58%prep
59%setup -q
60
61%build
62%configure --disable-static --enable-silent-rules
63make %{_smp_mflags}
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69# removed unpackage files
70rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
71
72mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
73cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
74find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
75find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
76find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
77        grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
78
79for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
80        rm -f $i.*
81done
82
83rm -rf docs-toinstall
84mkdir -p docs-to-install
85cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
86rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
87
88# devhelp path fix
89sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
90#sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(-,root,root,755)
101%doc AUTHORS COPYING README NEWS ChangeLog TODO
102%attr(755,root,root) %{_libdir}/lib*.so.*
103
104%files devel
105%defattr(-,root,root,755)
106%{_includedir}/*
107%{_libdir}/%{lib_name}/include
108%{_libdir}/pkgconfig/*.pc
109#{_libdir}/lib*.la
110%{_libdir}/lib*.so
111%{_datadir}/devhelp/books/%{name}-2.0/*
112%doc docs-to-install/index.html docs-to-install/images
113%doc docs-to-install/reference docs-to-install/tutorial
114
115%files examples
116%defattr(-,root,root,755)
117%{_libdir}/%{lib_name}/examples
118%{_libdir}/%{lib_name}/tests
119
120%changelog
121* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
122- new upstream release
123
124* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
125- new upstream release
126
127* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
128- build with rpm-4.8.1-1 for pkg-config file
129
130* Thu Sep  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
131- new upstream release
132
133* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
134- new upstream release
135- built with new toolchain
136
137* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
138- new upstream release
139- remove static libraries from devel package
140
141* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
142- new upstream release
143- spec in UTF-8
144
145* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
146- removed .la files from devel package
147
148* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
149- new upstream release
150
151* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
152- rebuild with new environment/toolchain
153
154* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
155- new upstream release
156
157* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
158- rebuild with new libtool
159
160* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
161- new upstream release
162
163* Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
164- new upstream release
165
166* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
167- new upstream release
168
169* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
170- new upstream release
171- added tutorial to devel package
172
173* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
174- update to 2.0.6
175
176* Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
177- update to 1.2.5
178- add Requires: pkgconfig
179
180* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
181- rebuild to remove dependance <5371>
182- add Japanese summary
183- use better macros
184- s/Copyright/License/
185
186* Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
187- rebuild with new toolchain
188
189* Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
190- 1.0.4-0vl1
191- Build for Vine Linux 2.5
192
193* Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
194- packaged for Vine Linux 2.1
195
196* Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
197- updated Url and Source fileds
198- 1.0.0 stable release
199
200* Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
201- filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
202- minor install section cleanup
203
204* Wed Jan 19 2000 Allan Rae <rae@lyx.org>
205- autogen just creates configure, not runs it, so cleaned that up too.
206
207* Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
208- minor attr fix
209- removed unnecessary curly braces
210- fixed Herbert's adjustement
211
212* Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
213- minor package dependence fix
214
215* Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
216- fixed typo of mine
217- added traditional CUSTOM_RELEASE stuff
218- added SMP support
219
220* Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
221- adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
222
223* Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
224- split into three packages: %name, %name-devel and %name-examples
225
226* Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
227- updated source field and merged conflicts between revisions.
228
229* Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
230- updated Prefix and BuildRoot fields
231
232* Thu Aug  5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
233- made sure configure works on all alphas
234
235* Wed Jul  7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
236- Added autoconf macro for sigc.
237
238* Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
239- Made into a .in to keep version field up to date
240- Still need to do release by hand
241
242* Mon Jun  7 1999 Dmitry V. Levin <ldv@fandra.org>
243- added Vendor and Packager fields
244
245* Sat Jun  5 1999 Dmitry V. Levin <ldv@fandra.org>
246- updated to 0.8.0
247
248* Tue Jun  1 1999 Dmitry V. Levin <ldv@fandra.org>
249- initial revision
Note: See TracBrowser for help on using the repository browser.