source: projects/specs/trunk/lib/libs/libsieve/libsieve-vl.spec @ 521

Revision 521, 5.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A library for parsing, sorting and filtering your mail
2Summary(ja):    メールをパース、ソートまたはフィルタするためのライブラリ
3
4Name:           libsieve
5Version:        2.2.7
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Libraries
9# License says LGPL, but source is a mix of many licenses.  License breakdown:
10# __CMU (MIT)__
11# src/sv_interface/message.c
12# src/sv_interface/message.h
13# src/sv_interface/script.c
14# src/sv_interface/script.h
15# src/sv_interface/tree.c
16# src/sv_interface/tree.h
17# src/sv_parser/addr-lex.l
18# src/sv_parser/addr.y
19# src/sv_parser/comparator.c
20# src/sv_parser/comparator.h
21# src/sv_parser/sieve-lex.l
22# src/sv_parser/sieve.y
23# src/sv_test/example.c
24#
25# __GPLv2+__
26# src/config.guess
27# src/config.sub
28# src/depcomp
29# src/ltmain.sh
30# src/missing
31# src/ylwrap
32# src/sv_parser/addr.c
33# src/sv_parser/addr.h
34# src/sv_parser/header.c
35# src/sv_parser/header.h
36#
37# __LGPLv2__
38# src/sv_include/sieve2_error.h
39# src/sv_include/sieve2.h
40# src/sv_interface/callbacks2.c
41# src/sv_interface/callbacks2.h
42# src/sv_interface/context2.c
43# src/sv_interface/context2.h
44# src/sv_interface/message2.c
45# src/sv_interface/message2.h
46# src/sv_interface/script2.c
47# src/sv_parser/header-lex.l
48# src/sv_parser/header.y
49# src/sv_parser/sieve.c
50# src/sv_parser/sieve.h
51# src/sv_util/util.c
52# src/sv_util/util.h
53#
54# __LGPLv2+__
55# src/sv_regex/regcomp.c
56# src/sv_regex/regex.c
57# src/sv_regex/regexec.c
58# src/sv_regex/regex.h
59# src/sv_regex/regex_internal.c
60# src/sv_regex/regex_internal.h
61#
62# __Public Domain__
63# src/sv_util/exception.c
64# src/sv_util/exception.h
65# src/sv_util/md5.c
66#
67# __MIT__
68# src/install-sh
69#
70License:        GPLv2+ and LGPLv2 and LGPLv2+ and MIT and Public Domain
71URL:            http://libsieve.sourceforge.net/
72Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
73BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
74
75BuildRequires:  flex, bison
76
77%description
78libSieve provides a library to interpret Sieve scripts, and to execute those
79scripts over a given set of messages. The return codes from the libSieve
80functions let your program know how to handle the message, and then it's up to
81you to make it so. libSieve makes no attempt to have knowledge of how SMTP,
82IMAP, or anything else work; just how to parse and deal with a buffer full of
83emails. The rest is up to you!
84
85%package devel
86Summary: Development files for %{name}
87Summary(ja): %{name} の開発用ファイル
88
89Group: Development/Libraries
90
91Requires: libsieve = %{version}-%{release}
92
93%description devel
94libSieve provides a library to interpret Sieve scripts, and to execute those
95scripts over a given set of messages. The return codes from the libSieve
96functions let your program know how to handle the message, and then it's up to
97you to make it so. libSieve makes no attempt to have knowledge of how SMTP,
98IMAP, or anything else work; just how to parse and deal with a buffer full of
99emails. The rest is up to you!
100
101These are the development libraries.
102
103%prep
104%setup -q
105
106%build
107cd src
108
109%configure
110make %{?_smp_mflags}
111
112
113%install
114rm -rf $RPM_BUILD_ROOT
115cd src && make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
116rm -f $RPM_BUILD_ROOT/%{_libdir}/*\.{a,la}
117
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post   -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(-,root,root,-)
127# See license tag section for licensing of binary
128%{_libdir}/libsieve.so.*
129%doc AUTHORS COPYING NEWS README
130
131%files devel
132%defattr(-,root,root,-)
133%{_libdir}/*.so
134%{_libdir}/pkgconfig/%{name}.pc
135%{_includedir}/*
136
137%changelog
138* Mon Sep 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.7-1
139- initial build for Vine Linux
140
141* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.7-3
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
143
144* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.7-2
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
146
147* Wed Jan 28 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.2.7-1
148- v 2.2.7
149- package pkgconfig file
150
151* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.6-3
152- Autorebuild for GCC 4.3
153
154* Sun Oct 26 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.6-2
155- add missing BR: flex, bison
156- remove repotag
157
158* Sun Oct 26 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.6-1
159- 2.2.6
160- license clarification
161
162* Tue Feb 06 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.5-1
163- 2.2.5
164- remove sed surgery since tarball is fixed to pass CFLAGS
165
166* Mon Jan 29 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.4-2
167- add note regarding why license tag is GPL
168- sed surgery on Makefile.in files so that CFLAGS is passed properly
169
170* Sun Jan 28 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.4-1
171- 2.2.4
172- change license to GPL based on https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=216723#c11
173- install files preserving timestamps
174
175* Sat Jan 27 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-4
176- add fully versioned dependency on main package for -devel
177- remove .a library from -devel
178- do not call autoconf, use configure file
179- direct download url for source0
180- remove buildrequires for autoconf and m4
181
182* Mon Dec 11 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-3
183- added repotag for anyone who may want to use it
184- move ldconfig calls to post and postun with -p
185- minor spec file cleanups
186
187* Sat Nov 25 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-2
188- bump release to -2
189- move .so to -devel
190- change %%post command to avoid fork of a shell interpreter
191
192* Sat Nov 18 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-1.1.sc
193- start with fedora extras template for spec file
194
195* Wed Oct 11 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-1.sc
196— Initial package
Note: See TracBrowser for help on using the repository browser.