source: projects/specs/trunk/lib/libs/libsieve/libsieve-vl.spec @ 9381

Revision 9381, 5.9 KB checked in by inagaki, 9 years ago (diff)

2015-02-24 Ryoichi INAGAKI <ryo1@…>

  • libmal, libsmbios, libwvstreams: rebuilt
  • libsieve, libxdg-basedir: updated


Line 
1Summary:        A library for parsing, sorting and filtering your mail
2Summary(ja):    メールをパース、ソートまたはフィルタするためのライブラリ
3
4Name:           libsieve
5Version:        2.3.1
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Libraries
9# License says LGPL, but source is a mix of many licenses.  License breakdown:
10# __CMU (MIT)__
11# src/sv_interface/message.c
12# src/sv_interface/message.h
13# src/sv_interface/script.c
14# src/sv_interface/script.h
15# src/sv_interface/tree.c
16# src/sv_interface/tree.h
17# src/sv_parser/addr-lex.l
18# src/sv_parser/addr.y
19# src/sv_parser/comparator.c
20# src/sv_parser/comparator.h
21# src/sv_parser/sieve-lex.l
22# src/sv_parser/sieve.y
23# src/sv_test/example.c
24#
25# __GPLv2+__
26# src/config.guess
27# src/config.sub
28# src/depcomp
29# src/ltmain.sh
30# src/missing
31# src/ylwrap
32# src/sv_parser/addr.c
33# src/sv_parser/addr.h
34# src/sv_parser/header.c
35# src/sv_parser/header.h
36#
37# __LGPLv2__
38# src/sv_include/sieve2_error.h
39# src/sv_include/sieve2.h
40# src/sv_interface/callbacks2.c
41# src/sv_interface/callbacks2.h
42# src/sv_interface/context2.c
43# src/sv_interface/context2.h
44# src/sv_interface/message2.c
45# src/sv_interface/message2.h
46# src/sv_interface/script2.c
47# src/sv_parser/header-lex.l
48# src/sv_parser/header.y
49# src/sv_parser/sieve.c
50# src/sv_parser/sieve.h
51# src/sv_util/util.c
52# src/sv_util/util.h
53#
54# __LGPLv2+__
55# src/sv_regex/regcomp.c
56# src/sv_regex/regex.c
57# src/sv_regex/regexec.c
58# src/sv_regex/regex.h
59# src/sv_regex/regex_internal.c
60# src/sv_regex/regex_internal.h
61#
62# __Public Domain__
63# src/sv_util/exception.c
64# src/sv_util/exception.h
65# src/sv_util/md5.c
66#
67# __MIT__
68# src/install-sh
69#
70License:        GPLv2+ and LGPLv2 and LGPLv2+ and MIT and Public Domain
71URL:            http://libsieve.sourceforge.net/
72Source0:        https://github.com/downloads/sodabrew/%{name}/%{name}-%{version}.tar.gz
73BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
74
75BuildRequires:  flex, bison
76
77%description
78libSieve provides a library to interpret Sieve scripts, and to execute those
79scripts over a given set of messages. The return codes from the libSieve
80functions let your program know how to handle the message, and then it's up to
81you to make it so. libSieve makes no attempt to have knowledge of how SMTP,
82IMAP, or anything else work; just how to parse and deal with a buffer full of
83emails. The rest is up to you!
84
85%package devel
86Summary: Development files for %{name}
87Summary(ja): %{name} の開発用ファイル
88Group: Development/Libraries
89Requires: libsieve = %{version}-%{release}
90
91%description devel
92libSieve provides a library to interpret Sieve scripts, and to execute those
93scripts over a given set of messages. The return codes from the libSieve
94functions let your program know how to handle the message, and then it's up to
95you to make it so. libSieve makes no attempt to have knowledge of how SMTP,
96IMAP, or anything else work; just how to parse and deal with a buffer full of
97emails. The rest is up to you!
98
99These are the development libraries.
100
101%prep
102%setup -q
103
104%build
105%configure --disable-static
106make %{?_smp_mflags}
107
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
112rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post   -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
119
120%files
121%defattr(-,root,root,-)
122# See license tag section for licensing of binary
123%{_libdir}/libsieve.so.*
124%doc AUTHORS COPYING NEWS README
125
126%files devel
127%defattr(-,root,root,-)
128%{_libdir}/*.so
129%{_libdir}/pkgconfig/%{name}.pc
130%{_includedir}/*
131
132%changelog
133* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.1-1
134- updated to 2.3.1
135
136* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.7-2
137- rebuild with rpm-4.8.1 for pkg-config file
138
139* Mon Sep 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.7-1
140- initial build for Vine Linux
141
142* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.7-3
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
144
145* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.7-2
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
147
148* Wed Jan 28 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.2.7-1
149- v 2.2.7
150- package pkgconfig file
151
152* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.6-3
153- Autorebuild for GCC 4.3
154
155* Sun Oct 26 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.6-2
156- add missing BR: flex, bison
157- remove repotag
158
159* Sun Oct 26 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.6-1
160- 2.2.6
161- license clarification
162
163* Tue Feb 06 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.5-1
164- 2.2.5
165- remove sed surgery since tarball is fixed to pass CFLAGS
166
167* Mon Jan 29 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.4-2
168- add note regarding why license tag is GPL
169- sed surgery on Makefile.in files so that CFLAGS is passed properly
170
171* Sun Jan 28 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.4-1
172- 2.2.4
173- change license to GPL based on https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=216723#c11
174- install files preserving timestamps
175
176* Sat Jan 27 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-4
177- add fully versioned dependency on main package for -devel
178- remove .a library from -devel
179- do not call autoconf, use configure file
180- direct download url for source0
181- remove buildrequires for autoconf and m4
182
183* Mon Dec 11 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-3
184- added repotag for anyone who may want to use it
185- move ldconfig calls to post and postun with -p
186- minor spec file cleanups
187
188* Sat Nov 25 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-2
189- bump release to -2
190- move .so to -devel
191- change %%post command to avoid fork of a shell interpreter
192
193* Sat Nov 18 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-1.1.sc
194- start with fedora extras template for spec file
195
196* Wed Oct 11 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-1.sc
197— Initial package
Note: See TracBrowser for help on using the repository browser.