source: projects/specs/trunk/lib/libs/libserf/libserf-vl.spec @ 8310

Revision 8310, 2.8 KB checked in by kenta, 10 years ago (diff)

new package: libserf

Line 
1%global oname   serf
2
3Name:           libserf
4Version:        1.3.4
5Release:        2%{?dist}
6Summary:        High-Performance Asynchronous HTTP Client Library
7Summary(ja):    高性能な非同期 HTTP クライアントのライブラリ
8License:        ASL 2.0
9Group:          System Environment/Libraries
10Url:            http://code.google.com/p/serf
11Source0:        https://serf.googlecode.com/files/serf-%{version}.tar.bz2
12
13BuildRequires:  apr-util-devel, apr-devel, krb5-devel,
14BuildRequires:  krb5-devel, openssl-devel, zlib-devel
15BuildRequires:  scons, pkgconfig
16
17%description
18The serf library is a C-based HTTP client library built upon the Apache
19Portable Runtime (APR) library. It multiplexes connections, running the
20read/write communication asynchronously. Memory copies and transformations are
21kept to a minimum to provide high performance operation.
22
23%package        devel
24Summary:        Development files for %{name}
25Summary(ja):    %{name} の開発用ファイル群
26Group:          Development/Libraries
27Requires:       %{name}%{?_isa} = %{version}-%{release}
28Requires:       apr-devel%{?_isa}
29
30%description    devel
31The %{name}-devel package contains libraries and header files for
32developing applications that use %{name}.
33
34%prep
35%setup -q -n %{oname}-%{version}
36
37# Shared library versioning support in scons is worse than awful...
38# minimally, here fix the soname to match serf-1.2.x.  Minor version
39# handling should be fixed too; really requires better upstream support:
40# http://scons.tigris.org/issues/show_bug.cgi?id=2869
41sed -i '/SHLIBVERSION/s/MAJOR/0/' SConstruct
42
43%build
44scons \
45      CFLAGS="%{optflags}" \
46      PREFIX=%{_prefix} \
47      LIBDIR=%{_libdir} \
48      GSSAPI=%{_prefix} \
49      %{?_smp_mflags}
50
51%install
52scons install --install-sandbox=%{buildroot}
53find %{buildroot} -name '*.*a' -exec rm -vf {} ';'
54
55%check
56scons %{?_smp_mflags} check || true
57
58%post -p /sbin/ldconfig
59
60%postun -p /sbin/ldconfig
61
62%files
63%doc CHANGES LICENSE NOTICE README design-guide.txt
64%{_libdir}/*.so.*
65
66%files devel
67%{_includedir}/%{oname}-1/
68%{_libdir}/*.so
69%{_libdir}/pkgconfig/%{oname}*.pc
70
71%changelog
72* Sun Mar 16 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 1.3.4-2
73- initial build for Vine Linux
74
75* Mon Feb 17 2014 Joe Orton <jorton@redhat.com> - 1.3.4-1
76- update to 1.3.4
77
78* Tue Dec 10 2013 Joe Orton <jorton@redhat.com> - 1.3.3-1
79- update to 1.3.3
80
81* Wed Nov  6 2013 Joe Orton <jorton@redhat.com> - 1.3.2-1
82- update to 1.3.2
83- require krb5-devel for libgssapi (#1027011)
84
85* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-4
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
87
88* Mon Jun 17 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-3
89- SPEC cleanup.
90
91* Thu Jun 13 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-2
92- Fix the permission of the library.
93
94* Sun Jun 09 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-1
95- Initial Package.
Note: See TracBrowser for help on using the repository browser.