source: projects/specs/trunk/lib/libs/libserf/libserf-vl.spec @ 12320

Revision 12320, 4.1 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

clamav-0.102.2-1

dhcpcd-8.1.1-1

dovecot-2.3.9.3-1

golang-1.13.5-1

llvm-9.0.1-1

libjpeg-turbo-2.0.4-1

libserf-1.3.9-2

libxml2-2.9.10-2

mariadb-10.4.12-1

nodejs-12.16.0-1

php-ext-clearsilver-0.4-15

php73-7.3.14-1

python-pillow-6.2.2-1

rust-1.40.0-1

spamassassin-3.4.4-1

sqlite3-3.31.1-1

squid-4.10-1

sudo-1.8.31-1

Line 
1%global oname   serf
2
3Name:           libserf
4Version:        1.3.9
5Release:        2%{?_dist_release}
6Summary:        High-Performance Asynchronous HTTP Client Library
7Summary(ja):    高性能な非同期 HTTP クライアントのライブラリ
8License:        ASL 2.0
9Group:          System Environment/Libraries
10URL:            http://code.google.com/p/serf
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15Source0:        https://serf.googlecode.com/files/serf-%{version}.tar.bz2
16Source1:        libserf-certs.tar.xz
17Patch0:         %{name}-norpath.patch
18Patch1:         %{name}-python3.patch
19Patch2:         r1712790-serf_bucket_aggregate_prepend-empty-list.patch
20Patch3:         %{name}-1.3.9-openssl111.patch
21
22# fallback to IPv4
23# https://issues.apache.org/jira/browse/SERF-190
24Patch1000:      serf_v6fallback.patch
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27BuildRequires:  apr-devel
28BuildRequires:  apr-util-devel
29BuildRequires:  krb5-devel
30BuildRequires:  openssl-devel
31BuildRequires:  pkgconfig
32BuildRequires:  scons
33BuildRequires:  zlib-devel
34
35%description
36The serf library is a C-based HTTP client library built upon the Apache
37Portable Runtime (APR) library. It multiplexes connections, running the
38read/write communication asynchronously. Memory copies and transformations are
39kept to a minimum to provide high performance operation.
40
41%package        devel
42Summary:        Development files for %{name}
43Summary(ja):    %{name} の開発用ファイル群
44Group:          Development/Libraries
45Requires:       %{name}%{?_isa} = %{version}-%{release}
46Requires:       apr-devel%{?_isa}
47
48%description    devel
49The %{name}-devel package contains libraries and header files for
50developing applications that use %{name}.
51
52%prep
53%autosetup -n serf-%{version} -p1
54
55# Shared library versioning support in scons is worse than awful...
56# minimally, here fix the soname to match serf-1.2.x.  Minor version
57# handling should be fixed too; really requires better upstream support:
58# http://scons.tigris.org/issues/show_bug.cgi?id=2869
59sed -i '/SHLIBVERSION/s/MAJOR/0/' SConstruct
60
61pushd test/server/
62tar xvf %{SOURCE1}
63popd
64
65%build
66scons \
67      CFLAGS="%{optflags}" \
68      PREFIX=%{_prefix} \
69      LIBDIR=%{_libdir} \
70      GSSAPI=%{_prefix} \
71      %{?_smp_mflags}
72
73%install
74scons install --install-sandbox=%{buildroot}
75find %{buildroot} -name '*.*a' -exec rm -vf {} ';'
76
77%check
78export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
79# disable tests temporarily because testcases are openssl-1.0 style
80# and certificates for tests are expired.
81
82scons check || true
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88%files
89%doc CHANGES LICENSE NOTICE README design-guide.txt
90%{_libdir}/*.so.*
91
92%files devel
93%{_includedir}/%{oname}-1/
94%{_libdir}/*.so
95%{_libdir}/pkgconfig/%{oname}*.pc
96
97%changelog
98* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.3.9-2
99- added Patch1000 to fallback to IPv4.
100
101* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.3.9-1
102- updated to 1.3.9.
103- imported Patch0-1 from rawhide.
104- imported Patch2 from upstream.
105- added Patch3 to build with openssl-1.1.1.
106- added Source1 to replace expired certificates.
107
108* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.8-2
109- rebuild with openssl-1.0.2
110
111* Sat Dec 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.3.8-1
112- updated to 1.3.8
113
114* Sun Mar 16 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 1.3.4-2
115- initial build for Vine Linux
116
117* Mon Feb 17 2014 Joe Orton <jorton@redhat.com> - 1.3.4-1
118- update to 1.3.4
119
120* Tue Dec 10 2013 Joe Orton <jorton@redhat.com> - 1.3.3-1
121- update to 1.3.3
122
123* Wed Nov  6 2013 Joe Orton <jorton@redhat.com> - 1.3.2-1
124- update to 1.3.2
125- require krb5-devel for libgssapi (#1027011)
126
127* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-4
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
129
130* Mon Jun 17 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-3
131- SPEC cleanup.
132
133* Thu Jun 13 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-2
134- Fix the permission of the library.
135
136* Sun Jun 09 2013 Christopher Meng <rpm@cicku.me> - 1.2.1-1
137- Initial Package.
Note: See TracBrowser for help on using the repository browser.