source: projects/specs/trunk/lib/libs/libsamplerate/libsamplerate-vl.spec @ 1900

Revision 1900, 7.5 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Audio Sample Rate Converter library
4Summary(ja): 音声サンプリングレート変換ライブラリ
5Name: libsamplerate
6Version: 0.1.7
7Release: 2%{?_dist_release}
8Source0: %{name}-%{version}.tar.gz
9URL: http://www.mega-nerd.com/SRC/index.html
10License: GPLv2
11Group: System Environment/Libraries
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: libsndfile-devel >= 1.0.6
15
16%description
17Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
18audio. One example of where such a thing would be useful is
19converting audio from the CD sample rate of 44.1kHz to the 48kHz
20sample rate used by DAT players.
21
22SRC is capable of arbitrary and time varying conversions ; from
23downsampling by a factor of 12 to upsampling by the same
24factor. Arbitrary in this case means that the ratio of input and
25output sample rates can be an irrational number. The conversion ratio
26can also vary with time for speeding up and slowing down effects.
27
28SRC provides a small set of converters to allow quality to be traded
29off against computation cost. The current best converter provides a
30signal-to-noise ratio of 97dB with -3dB passband extending from DC to
3196% of the theoretical best bandwidth for a given pair of input and
32output sample rates.
33
34%package devel
35Summary: Audio Sample Rate Converter development files
36Summary(ja): 音声サンプリングレート変換ライブラリの開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: pkgconfig
40
41%description devel
42Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
43audio. One example of where such a thing would be useful is
44converting audio from the CD sample rate of 44.1kHz to the 48kHz
45sample rate used by DAT players.
46
47SRC is capable of arbitrary and time varying conversions ; from
48downsampling by a factor of 12 to upsampling by the same
49factor. Arbitrary in this case means that the ratio of input and
50output sample rates can be an irrational number. The conversion ratio
51can also vary with time for speeding up and slowing down effects.
52
53SRC provides a small set of converters to allow quality to be traded
54off against computation cost. The current best converter provides a
55signal-to-noise ratio of 97dB with -3dB passband extending from DC to
5696% of the theoretical best bandwidth for a given pair of input and
57output sample rates.
58
59%package progs
60Summary: Audio Sample Rate Converter
61Summary(ja): 音楽サンプリングレート変換ツール
62Group: Applications/Multimedia
63Requires: %{name} = %{version}
64
65%description progs
66Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
67audio. One example of where such a thing would be useful is
68converting audio from the CD sample rate of 44.1kHz to the 48kHz
69sample rate used by DAT players.
70
71SRC is capable of arbitrary and time varying conversions ; from
72downsampling by a factor of 12 to upsampling by the same
73factor. Arbitrary in this case means that the ratio of input and
74output sample rates can be an irrational number. The conversion ratio
75can also vary with time for speeding up and slowing down effects.
76
77SRC provides a small set of converters to allow quality to be traded
78off against computation cost. The current best converter provides a
79signal-to-noise ratio of 97dB with -3dB passband extending from DC to
8096% of the theoretical best bandwidth for a given pair of input and
81output sample rates.
82
83# compat32
84%package -n compat32-%{name}
85Summary: Audio Sample Rate Converter library
86Summary(ja): 音声サンプリングレート変換ライブラリ
87Group: System Environment/Libraries
88
89%description -n compat32-%{name}
90Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
91audio. One example of where such a thing would be useful is
92converting audio from the CD sample rate of 44.1kHz to the 48kHz
93sample rate used by DAT players.
94
95SRC is capable of arbitrary and time varying conversions ; from
96downsampling by a factor of 12 to upsampling by the same
97factor. Arbitrary in this case means that the ratio of input and
98output sample rates can be an irrational number. The conversion ratio
99can also vary with time for speeding up and slowing down effects.
100
101SRC provides a small set of converters to allow quality to be traded
102off against computation cost. The current best converter provides a
103signal-to-noise ratio of 97dB with -3dB passband extending from DC to
10496% of the theoretical best bandwidth for a given pair of input and
105output sample rates.
106
107%package -n compat32-%{name}-devel
108Summary: Audio Sample Rate Converter development files
109Summary(ja): 音声サンプリングレート変換ライブラリの開発用ファイル
110Group: Development/Libraries
111Requires: compat32-%{name} = %{version}-%{release}
112Requires: %{name}-devel = %{version}-%{release}
113
114%description -n compat32-%{name}-devel
115Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
116audio. One example of where such a thing would be useful is
117converting audio from the CD sample rate of 44.1kHz to the 48kHz
118sample rate used by DAT players.
119
120SRC is capable of arbitrary and time varying conversions ; from
121downsampling by a factor of 12 to upsampling by the same
122factor. Arbitrary in this case means that the ratio of input and
123output sample rates can be an irrational number. The conversion ratio
124can also vary with time for speeding up and slowing down effects.
125
126SRC provides a small set of converters to allow quality to be traded
127off against computation cost. The current best converter provides a
128signal-to-noise ratio of 97dB with -3dB passband extending from DC to
12996% of the theoretical best bandwidth for a given pair of input and
130output sample rates.
131
132%prep
133%setup -q
134
135%build
136%configure
137make
138
139%install
140rm -rf $RPM_BUILD_ROOT
141%makeinstall
142
143rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post -p /sbin/ldconfig
149%postun -p /sbin/ldconfig
150
151%post -n compat32-%{name} -p /sbin/ldconfig
152%postun -n compat32-%{name} -p /sbin/ldconfig
153
154%files
155%defattr(-,root,root)
156%doc AUTHORS ChangeLog COPYING NEWS README
157%doc doc/*.html doc/SRC.*
158%{_libdir}/*.so.*
159
160%files devel
161%defattr(-,root,root)
162%{_libdir}/*.so
163%{_libdir}/pkgconfig/samplerate.pc
164%{_includedir}/samplerate.h
165
166%files progs
167%defattr(-,root,root)
168%{_bindir}/sndfile-resample
169
170# compat32
171%if %{build_compat32}
172%files -n compat32-%{name}
173%defattr(-,root,root)
174%{_libdir}/*.so.*
175
176%files -n compat32-%{name}-devel
177%defattr(-,root,root)
178%{_libdir}/*.so
179%{_libdir}/pkgconfig/samplerate.pc
180%endif
181
182
183%changelog
184* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.7-2
185- rebuild with rpm-4.8.1 for pkg-config file
186
187* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.7-1
188- new upstream release
189
190* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.4-3
191- added compat32 package for x86_64 arch support
192
193* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.4-2
194- spec in utf-8
195- remove static lib
196
197* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.4-1
198- new upstream release
199- applied new versioning policy
200- removed lib*.la files from devel package
201
202* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.2-0vl2
203- rebuilt with libsndfile for VineSeed Plus
204
205* Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 0.1.2-0vl0.1
206- rebuild for VinePlus/3.0
207- added BuildRequires: libsndfile-devel to progs subpackage
208- fixed %%doc section
209
210* Wed Sep 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.2-0vl1
211- new upstream release
212- fixed %doc section
213- fixed spec file encoding
214
215* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-0vl1
216- initial build for Vine Linux
217
Note: See TracBrowser for help on using the repository browser.