source: projects/specs/trunk/lib/libs/libsamplerate/libsamplerate-vl.spec @ 8914

Revision 8914, 7.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Audio Sample Rate Converter library
4Summary(ja): 音声サンプリングレート変換ライブラリ
5Name: libsamplerate
6Version: 0.1.8
7Release: 1%{?_dist_release}
8Source0: %{name}-%{version}.tar.gz
9URL: http://www.mega-nerd.com/SRC/index.html
10License: GPLv2
11Group: System Environment/Libraries
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: libsndfile-devel >= 1.0.6
15
16%description
17Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
18audio. One example of where such a thing would be useful is
19converting audio from the CD sample rate of 44.1kHz to the 48kHz
20sample rate used by DAT players.
21
22SRC is capable of arbitrary and time varying conversions ; from
23downsampling by a factor of 12 to upsampling by the same
24factor. Arbitrary in this case means that the ratio of input and
25output sample rates can be an irrational number. The conversion ratio
26can also vary with time for speeding up and slowing down effects.
27
28SRC provides a small set of converters to allow quality to be traded
29off against computation cost. The current best converter provides a
30signal-to-noise ratio of 97dB with -3dB passband extending from DC to
3196% of the theoretical best bandwidth for a given pair of input and
32output sample rates.
33
34%package devel
35Summary: Audio Sample Rate Converter development files
36Summary(ja): 音声サンプリングレート変換ライブラリの開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: pkgconfig
40
41%description devel
42Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
43audio. One example of where such a thing would be useful is
44converting audio from the CD sample rate of 44.1kHz to the 48kHz
45sample rate used by DAT players.
46
47SRC is capable of arbitrary and time varying conversions ; from
48downsampling by a factor of 12 to upsampling by the same
49factor. Arbitrary in this case means that the ratio of input and
50output sample rates can be an irrational number. The conversion ratio
51can also vary with time for speeding up and slowing down effects.
52
53SRC provides a small set of converters to allow quality to be traded
54off against computation cost. The current best converter provides a
55signal-to-noise ratio of 97dB with -3dB passband extending from DC to
5696% of the theoretical best bandwidth for a given pair of input and
57output sample rates.
58
59%package progs
60Summary: Audio Sample Rate Converter
61Summary(ja): 音楽サンプリングレート変換ツール
62Group: Applications/Multimedia
63Requires: %{name} = %{version}
64
65%description progs
66Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
67audio. One example of where such a thing would be useful is
68converting audio from the CD sample rate of 44.1kHz to the 48kHz
69sample rate used by DAT players.
70
71SRC is capable of arbitrary and time varying conversions ; from
72downsampling by a factor of 12 to upsampling by the same
73factor. Arbitrary in this case means that the ratio of input and
74output sample rates can be an irrational number. The conversion ratio
75can also vary with time for speeding up and slowing down effects.
76
77SRC provides a small set of converters to allow quality to be traded
78off against computation cost. The current best converter provides a
79signal-to-noise ratio of 97dB with -3dB passband extending from DC to
8096% of the theoretical best bandwidth for a given pair of input and
81output sample rates.
82
83%package        docs
84Summary:        Documentation for %{name}
85Summary(ja):    %{name} 用のドキュメント
86Group:          Documentation
87Requires:       %{name} = %{version}-%{release}
88BuildArch:      noarch
89
90%description    docs
91This package contains documentation for %{name}.
92
93# compat32
94%package -n compat32-%{name}
95Summary: Audio Sample Rate Converter library
96Summary(ja): 音声サンプリングレート変換ライブラリ
97Group: System Environment/Libraries
98
99%description -n compat32-%{name}
100Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
101audio. One example of where such a thing would be useful is
102converting audio from the CD sample rate of 44.1kHz to the 48kHz
103sample rate used by DAT players.
104
105SRC is capable of arbitrary and time varying conversions ; from
106downsampling by a factor of 12 to upsampling by the same
107factor. Arbitrary in this case means that the ratio of input and
108output sample rates can be an irrational number. The conversion ratio
109can also vary with time for speeding up and slowing down effects.
110
111SRC provides a small set of converters to allow quality to be traded
112off against computation cost. The current best converter provides a
113signal-to-noise ratio of 97dB with -3dB passband extending from DC to
11496% of the theoretical best bandwidth for a given pair of input and
115output sample rates.
116
117%package -n compat32-%{name}-devel
118Summary: Audio Sample Rate Converter development files
119Summary(ja): 音声サンプリングレート変換ライブラリの開発用ファイル
120Group: Development/Libraries
121Requires: compat32-%{name} = %{version}-%{release}
122Requires: %{name}-devel = %{version}-%{release}
123
124%description -n compat32-%{name}-devel
125Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for
126audio. One example of where such a thing would be useful is
127converting audio from the CD sample rate of 44.1kHz to the 48kHz
128sample rate used by DAT players.
129
130SRC is capable of arbitrary and time varying conversions ; from
131downsampling by a factor of 12 to upsampling by the same
132factor. Arbitrary in this case means that the ratio of input and
133output sample rates can be an irrational number. The conversion ratio
134can also vary with time for speeding up and slowing down effects.
135
136SRC provides a small set of converters to allow quality to be traded
137off against computation cost. The current best converter provides a
138signal-to-noise ratio of 97dB with -3dB passband extending from DC to
13996% of the theoretical best bandwidth for a given pair of input and
140output sample rates.
141
142%prep
143%setup -q
144
145%build
146%configure
147make
148
149%install
150rm -rf $RPM_BUILD_ROOT
151make install DESTDIR=$RPM_BUILD_ROOT
152
153rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post -p /sbin/ldconfig
159%postun -p /sbin/ldconfig
160
161%post -n compat32-%{name} -p /sbin/ldconfig
162%postun -n compat32-%{name} -p /sbin/ldconfig
163
164%files
165%defattr(-,root,root)
166%doc AUTHORS ChangeLog COPYING NEWS README
167%doc doc/*.html doc/SRC.*
168%{_libdir}/*.so.*
169
170%files devel
171%defattr(-,root,root)
172%{_libdir}/*.so
173%{_libdir}/pkgconfig/samplerate.pc
174%{_includedir}/samplerate.h
175
176%files progs
177%defattr(-,root,root)
178%{_bindir}/sndfile-resample
179
180%files docs
181%defattr(-,root,root)
182%{_docdir}/%{name}0-dev
183
184# compat32
185%if %{build_compat32}
186%files -n compat32-%{name}
187%defattr(-,root,root)
188%{_libdir}/*.so.*
189
190%files -n compat32-%{name}-devel
191%defattr(-,root,root)
192%{_libdir}/*.so
193%endif
194
195
196%changelog
197* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.8-1
198- update to 0.1.8
199- create %%{name}-docs subpackage
200
201* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.7-2
202- rebuild with rpm-4.8.1 for pkg-config file
203
204* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.7-1
205- new upstream release
206
207* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.4-3
208- added compat32 package for x86_64 arch support
209
210* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.4-2
211- spec in utf-8
212- remove static lib
213
214* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.4-1
215- new upstream release
216- applied new versioning policy
217- removed lib*.la files from devel package
218
219* Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.2-0vl2
220- rebuilt with libsndfile for VineSeed Plus
221
222* Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 0.1.2-0vl0.1
223- rebuild for VinePlus/3.0
224- added BuildRequires: libsndfile-devel to progs subpackage
225- fixed %%doc section
226
227* Wed Sep 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.2-0vl1
228- new upstream release
229- fixed %doc section
230- fixed spec file encoding
231
232* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-0vl1
233- initial build for Vine Linux
234
Note: See TracBrowser for help on using the repository browser.