source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 9178

Revision 9178, 11.7 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.8
4%define gdk_pixbuf2 2.26.1
5%define gtk3_version 3.4.1
6%define freetype_version 2.4.2
7%define popt_version 1.14
8%define libart_version 2.3.21
9%define cairo_version 1.12.0
10%define dbus_version 1.4.0
11%define dbus_glib_version 0.88
12%define avahi_glib_version 0.6.23
13%define libcroco_version 0.6.2
14%define libgsf_version 1.14.19
15
16Name:    librsvg2
17Summary: An SVG library based on libart.
18Summary(ja): libart ベースの SVG ライブラリ
19Version: 2.40.6
20Release: 1%{?_dist_release}
21License: LGPL
22Group: System Environment/Libraries
23Source: librsvg-%{version}.tar.xz
24
25Requires(post,postun): gtk3 >= %{gtk3_version}
26Requires(post): dbus-glib >= %{dbus_glib_version}
27Requires(post): avahi-glib >= %{avahi_glib_version}
28Requires(post): libgsf, libcroco
29Requires: gtk3 >= %{gtk3_version}
30Requires: libxml2 >= %{libxml2_version}
31Requires: popt >= %{popt_version}
32Requires: freetype2 >= %{freetype_version}
33Requires: libpng
34BuildRequires: libpng-devel
35BuildRequires: gtk3-devel >= %{gtk3_version}
36BuildRequires: gobject-introspection-devel
37BuildRequires: libxml2-devel >= %{libxml2_version}
38BuildRequires: freetype2-devel >= %{freetype_version}
39BuildRequires: cairo-devel >= %{cairo_version}
40BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
41BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
42BuildRequires: libcroco-devel >= %{libcroco_version}
43BuildRequires: libgsf-devel >= %{libgsf_version}
44BuildRequires: autoconf
45BuildRequires: gtk-doc
46BuildRequires: vala-devel
47BuildRequires: vala-tools
48
49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50
51Vendor: Project Vine
52Distribution: Vine Linux
53
54%description
55An SVG library based on libart.
56
57%description -l ja
58libart ベースの SVG ライブラリです
59
60
61%package devel
62Summary: Libraries and include files for developing with librsvg.
63Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
64Group: Development/Libraries
65Requires: %{name} = %{version}
66Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
67Requires: cairo-devel >= %{cairo_version}
68
69%description devel
70This package provides the necessary development libraries and include
71files to allow you to develop with librsvg.
72
73
74%package        docs
75Summary:        Documentation for %{name}
76Summary(ja):    %{name} 用のドキュメント
77Group:          Documentation
78Requires:       %{name} = %{version}-%{release}
79BuildArch:      noarch
80
81%description    docs
82This package contains documentation for %{name}.
83
84
85%package        vala
86Summary:        Vala bindings for %{name}
87Summary(ja):    %{name} の Vala バインディング
88Group:          Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       vala
91
92%description    vala
93Vala bindings for %{name}.
94
95
96%prep
97%setup -q -n librsvg-%{version}
98
99%build
100sed -i "s|0.17.1.26|0.20|" configure.in
101autoreconf -if
102%configure --enable-gtk-doc \
103           --enable-introspection=yes \
104           --enable-vala=yes \
105           --with-svgz \
106           --enable-gtk-theme \
107           --with-croco \
108           --disable-static
109%__make %{?_smp_mflags}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make install DESTDIR=$RPM_BUILD_ROOT
114
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
116rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
117rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post
123/sbin/ldconfig
124if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
125  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
126fi ||:
127
128%postun
129/sbin/ldconfig
130if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
131  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
132fi ||:
133
134%files
135%defattr(-,root,root,-)
136%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
137%{_bindir}/rsvg-convert
138%{_bindir}/rsvg-view-3
139%{_libdir}/librsvg-2.so.*
140%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
141%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
142%{_mandir}/man1/rsvg-convert.1.gz
143
144%files devel
145%defattr(-,root,root,-)
146%{_libdir}/librsvg-2.so
147%{_includedir}/librsvg-2.0/librsvg
148%{_libdir}/pkgconfig/librsvg-2.0.pc
149%{_datadir}/gir-1.0/Rsvg-2.0.gir
150
151%files docs
152%defattr(-,root,root,-)
153%{_datadir}/gtk-doc/html/rsvg-2.0
154
155%files vala
156%defattr(-,root,root,-)
157%{_datadir}/vala/vapi/librsvg-2.0.vapi
158
159
160%changelog
161* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
162- new upstream release
163
164* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
165- new upstream release
166
167* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
168- new upstream release
169
170* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
171- rebuild with libpng-1.6.12
172
173* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
174- new upstream release
175
176* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
177- fix typo
178
179* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
180- new upstream release
181- remove BuildRequires: gtk2-devel
182
183* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
184- add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
185- create %%{name}-docs and %%{name}-vala subpackages
186
187* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
188- new upstream release
189
190* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
191- new upstream release
192
193* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
194- new upstream release
195
196* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
197- new upstream release
198- add BuildRequires: gobject-introspection-devel
199
200* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
201- new upstream release
202- remove Patch0
203
204* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
205- new upstream release
206- add Patch0 (librsvg2-2.34.0-git20110728.patch)
207
208* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
209- new upstream release
210
211* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
212- new upstream release
213- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
214- remove Requires: libart_lgpl
215- add configure option (--disable-static)
216- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
217- fix %install, %files, %post and %postun
218
219* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
220- build with rpm-4.8.1-1 for pkg-config file
221
222* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
223- new upstream release
224
225* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
226- new upstream release
227- remove static libs
228
229* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
230- new upstream release
231- spec in UTF-8
232
233* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
234- new upstream release
235
236* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
237- rebuilt with libgsf-1.14.8
238
239* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
240- new upstream release
241
242* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
243- new upstream release
244- add BuildRequires: dbus-glib-devel, avahi-glib-devel
245- add BuildRequires: libgsf-devel, libcroco-devel
246- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
247- add Requires(post,postun): glib2
248
249* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
250- rebuild with gtk+-2.10
251
252* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
253- rebuilt without libgsf-devel
254
255* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
256- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
257  for biarch support. (TODO: add compat32)
258
259* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
260- rebuild
261
262* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
263- new upstream release
264
265* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
266- new upstream release
267
268* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
269- new upstream release
270
271* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
272- new upstream release
273- added --disable-gtk-doc option
274
275* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
276- new upstream release
277- added gtk-doc to devel package
278
279* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
280- new upstream release
281- added Japanese description
282- added --without-svgz option (because it requires libgsf)
283
284* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
285- new upstream release
286
287* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
288- new upstream release
289
290* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
291- rebuilt to avoid unwanted dependency (libgsf)
292
293* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
294- add gdk-pixbuf-query-loaders to post/postun script.
295
296* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
297- rebuild with gtk+-2.4.0
298
299* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
300- new upstream release
301
302* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
303- fix kanji code of spec file
304- fix file entry, add missing files
305
306* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
307- new upstream release
308
309* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
310- added --without-svgz and --without-gimp to %configure
311
312* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
313- new upstream release
314- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
315- added %{_libdir}/gtk-2.0/* to devel package
316
317* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
318- new upstream release
319
320* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
321- new upstream release
322
323* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
324- new upstream release
325
326* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
327- build for Vine Linux
328- new upstream release from gnome-2.1.4
329
330* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
331- 2.0.1
332
333* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
334- automated rebuild
335
336* Sun May 26 2002 Tim Powers <timp@redhat.com>
337- automated rebuild
338
339* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
340- rebuild in different environment
341
342* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
343- rebuild in different environment
344
345* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
346- 1.1.6
347
348* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
349- Update to 1.1.3
350
351* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
352- automated rebuild
353
354* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
355- new CVS snap 1.1.0.91
356- remove automake/autoconf calls
357
358* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
359- convert to librsvg2 RPM
360
361* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
362- 1.0.2
363
364* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
365- Add a patch that moves the includes to librsvg-1/librsvg
366- in preparation for a later librsvg 2 library.
367
368* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
369- build requires gnome-libs-devel, #49509
370
371* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
372- own /usr/include/librsvg
373
374* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
375- fixed the linefeed problem in multibyte environment. (Bug#49310)
376
377* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
378- put .la file back in package
379
380* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
381- Put changelog at the end
382- Move .so files to devel subpackage
383- Don't mess with ld.so.conf
384- Don't use %%{prefix}, this isn't a relocatable package
385- Don't define a bad docdir
386- Add BuildRequires
387- Use %%{_tmppath}
388- Don't define name, version etc. on top of the file (why do so many do that?)
389- s/Copyright/License/
390
391* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
392- Put into Red Hat Build system
393
394* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
395- removed obsoletes from sub packages and added mozilla and trilobite
396subpackages
397
398* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
399- created this thing
400
Note: See TracBrowser for help on using the repository browser.