source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 8173

Revision 8173, 11.2 KB checked in by Takemikaduchi, 10 years ago (diff)

qt4: fix BTS:2677
librsvg2: fix typo
others: rebuild

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.8
4%define gdk_pixbuf2 2.26.1
5%define gtk3_version 3.4.1
6%define freetype_version 2.4.2
7%define popt_version 1.14
8%define libart_version 2.3.21
9%define cairo_version 1.12.0
10%define dbus_version 1.4.0
11%define dbus_glib_version 0.88
12%define avahi_glib_version 0.6.23
13%define libcroco_version 0.6.2
14%define libgsf_version 1.14.19
15
16Name:    librsvg2
17Summary: An SVG library based on libart.
18Summary(ja): libart ベースの SVG ライブラリ
19Version: 2.40.1
20Release: 2%{?_dist_release}
21License: LGPL
22Group: System Environment/Libraries
23Source: librsvg-%{version}.tar.xz
24
25Requires(post,postun): gtk3 >= %{gtk3_version}
26Requires(post): dbus-glib >= %{dbus_glib_version}
27Requires(post): avahi-glib >= %{avahi_glib_version}
28Requires(post): libgsf, libcroco
29Requires: gtk3 >= %{gtk3_version}
30Requires: libxml2 >= %{libxml2_version}
31Requires: popt >= %{popt_version}
32Requires: freetype2 >= %{freetype_version}
33Requires: libpng
34BuildRequires: libpng-devel
35BuildRequires: gtk3-devel >= %{gtk3_version}
36BuildRequires: gobject-introspection-devel
37BuildRequires: libxml2-devel >= %{libxml2_version}
38BuildRequires: freetype2-devel >= %{freetype_version}
39BuildRequires: cairo-devel >= %{cairo_version}
40BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
41BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
42BuildRequires: libcroco-devel >= %{libcroco_version}
43BuildRequires: libgsf-devel >= %{libgsf_version}
44BuildRequires: autoconf
45BuildRequires: gtk-doc
46BuildRequires: vala-devel
47BuildRequires: vala-tools
48
49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50
51Vendor: Project Vine
52Distribution: Vine Linux
53
54%description
55An SVG library based on libart.
56
57%description -l ja
58libart ベースの SVG ライブラリです
59
60
61%package devel
62Summary: Libraries and include files for developing with librsvg.
63Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
64Group: Development/Libraries
65Requires: %{name} = %{version}
66Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
67Requires: cairo-devel >= %{cairo_version}
68
69%description devel
70This package provides the necessary development libraries and include
71files to allow you to develop with librsvg.
72
73
74%package        docs
75Summary:        Documentation for %{name}
76Summary(ja):    %{name} 用のドキュメント
77Group:          Documentation
78Requires:       %{name} = %{version}-%{release}
79BuildArch:      noarch
80
81%description    docs
82This package contains documentation for %{name}.
83
84
85%package        vala
86Summary:        Vala bindings for %{name}
87Summary(ja):    %{name} の Vala バインディング
88Group:          Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       vala
91
92%description    vala
93Vala bindings for %{name}.
94
95
96%prep
97%setup -q -n librsvg-%{version}
98
99%build
100sed -i "s|0.17.1.26|0.20|" configure.in
101autoreconf -if
102%configure --enable-gtk-doc \
103           --enable-introspection=yes \
104           --enable-vala=yes \
105           --with-svgz \
106           --enable-gtk-theme \
107           --with-croco \
108           --disable-static
109%__make %{?_smp_mflags}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make install DESTDIR=$RPM_BUILD_ROOT
114
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
116rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
117rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post
123/sbin/ldconfig
124if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
125  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
126fi ||:
127
128%postun
129/sbin/ldconfig
130if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
131  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
132fi ||:
133
134%files
135%defattr(-,root,root,-)
136%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
137%{_bindir}/rsvg-convert
138%{_bindir}/rsvg-view-3
139%{_libdir}/librsvg-2.so.*
140%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
141%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
142%{_mandir}/man1/rsvg-convert.1.gz
143
144%files devel
145%defattr(-,root,root,-)
146%{_libdir}/librsvg-2.so
147%{_includedir}/librsvg-2.0/librsvg
148%{_libdir}/pkgconfig/librsvg-2.0.pc
149%{_datadir}/gir-1.0/Rsvg-2.0.gir
150
151%files docs
152%defattr(-,root,root,-)
153%{_datadir}/gtk-doc/html/rsvg-2.0
154
155%files vala
156%defattr(-,root,root,-)
157%{_datadir}/vala/vapi/librsvg-2.0.vapi
158
159
160%changelog
161* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
162- fix typo
163
164* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
165- new upstream release
166- remove BuildRequires: gtk2-devel
167
168* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
169- add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
170- create %%{name}-docs and %%{name}-vala subpackages
171
172* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
173- new upstream release
174
175* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
176- new upstream release
177
178* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
179- new upstream release
180
181* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
182- new upstream release
183- add BuildRequires: gobject-introspection-devel
184
185* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
186- new upstream release
187- remove Patch0
188
189* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
190- new upstream release
191- add Patch0 (librsvg2-2.34.0-git20110728.patch)
192
193* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
194- new upstream release
195
196* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
197- new upstream release
198- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
199- remove Requires: libart_lgpl
200- add configure option (--disable-static)
201- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
202- fix %install, %files, %post and %postun
203
204* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
205- build with rpm-4.8.1-1 for pkg-config file
206
207* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
208- new upstream release
209
210* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
211- new upstream release
212- remove static libs
213
214* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
215- new upstream release
216- spec in UTF-8
217
218* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
219- new upstream release
220
221* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
222- rebuilt with libgsf-1.14.8
223
224* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
225- new upstream release
226
227* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
228- new upstream release
229- add BuildRequires: dbus-glib-devel, avahi-glib-devel
230- add BuildRequires: libgsf-devel, libcroco-devel
231- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
232- add Requires(post,postun): glib2
233
234* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
235- rebuild with gtk+-2.10
236
237* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
238- rebuilt without libgsf-devel
239
240* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
241- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
242  for biarch support. (TODO: add compat32)
243
244* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
245- rebuild
246
247* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
248- new upstream release
249
250* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
251- new upstream release
252
253* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
254- new upstream release
255
256* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
257- new upstream release
258- added --disable-gtk-doc option
259
260* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
261- new upstream release
262- added gtk-doc to devel package
263
264* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
265- new upstream release
266- added Japanese description
267- added --without-svgz option (because it requires libgsf)
268
269* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
270- new upstream release
271
272* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
273- new upstream release
274
275* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
276- rebuilt to avoid unwanted dependency (libgsf)
277
278* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
279- add gdk-pixbuf-query-loaders to post/postun script.
280
281* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
282- rebuild with gtk+-2.4.0
283
284* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
285- new upstream release
286
287* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
288- fix kanji code of spec file
289- fix file entry, add missing files
290
291* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
292- new upstream release
293
294* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
295- added --without-svgz and --without-gimp to %configure
296
297* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
298- new upstream release
299- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
300- added %{_libdir}/gtk-2.0/* to devel package
301
302* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
303- new upstream release
304
305* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
306- new upstream release
307
308* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
309- new upstream release
310
311* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
312- build for Vine Linux
313- new upstream release from gnome-2.1.4
314
315* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
316- 2.0.1
317
318* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
319- automated rebuild
320
321* Sun May 26 2002 Tim Powers <timp@redhat.com>
322- automated rebuild
323
324* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
325- rebuild in different environment
326
327* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
328- rebuild in different environment
329
330* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
331- 1.1.6
332
333* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
334- Update to 1.1.3
335
336* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
337- automated rebuild
338
339* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
340- new CVS snap 1.1.0.91
341- remove automake/autoconf calls
342
343* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
344- convert to librsvg2 RPM
345
346* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
347- 1.0.2
348
349* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
350- Add a patch that moves the includes to librsvg-1/librsvg
351- in preparation for a later librsvg 2 library.
352
353* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
354- build requires gnome-libs-devel, #49509
355
356* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
357- own /usr/include/librsvg
358
359* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
360- fixed the linefeed problem in multibyte environment. (Bug#49310)
361
362* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
363- put .la file back in package
364
365* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
366- Put changelog at the end
367- Move .so files to devel subpackage
368- Don't mess with ld.so.conf
369- Don't use %%{prefix}, this isn't a relocatable package
370- Don't define a bad docdir
371- Add BuildRequires
372- Use %%{_tmppath}
373- Don't define name, version etc. on top of the file (why do so many do that?)
374- s/Copyright/License/
375
376* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
377- Put into Red Hat Build system
378
379* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
380- removed obsoletes from sub packages and added mozilla and trilobite
381subpackages
382
383* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
384- created this thing
385
Note: See TracBrowser for help on using the repository browser.