source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 7633

Revision 7633, 11.2 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.8
4%define gtk2_version 2.22.1
5%define gdk_pixbuf2 2.26.1
6%define gtk3_version 3.4.1
7%define freetype_version 2.4.2
8%define popt_version 1.14
9%define libart_version 2.3.21
10%define cairo_version 1.12.0
11%define dbus_version 1.4.0
12%define dbus_glib_version 0.88
13%define avahi_glib_version 0.6.23
14%define libcroco_version 0.6.2
15%define libgsf_version 1.14.19
16
17Name:    librsvg2
18Summary: An SVG library based on libart.
19Summary(ja): libart ベースの SVG ライブラリ
20Version: 2.36.4
21Release: 2%{?_dist_release}
22License: LGPL
23Group: System Environment/Libraries
24Source: librsvg-%{version}.tar.xz
25
26Requires(post,postun): gtk2 >= %{gtk2_version}
27Requires(post): dbus-glib >= %{dbus_glib_version}
28Requires(post): avahi-glib >= %{avahi_glib_devel}
29Requires(post): libgsf, libcroco
30Requires: gtk2 >= %{gtk2_version}
31Requires: gtk3 >= %{gtk3_version}
32Requires: libxml2 >= %{libxml2_version}
33Requires: popt >= %{popt_version}
34Requires: freetype2 >= %{freetype_version}
35Requires: libpng
36BuildRequires: libpng-devel
37BuildRequires: gtk2-devel >= %{gtk2_version}
38BuildRequires: gtk3-devel >= %{gtk3_version}
39BuildRequires: gobject-introspection-devel
40BuildRequires: libxml2-devel >= %{libxml2_version}
41BuildRequires: freetype2-devel >= %{freetype_version}
42BuildRequires: cairo-devel >= %{cairo_version}
43BuildRequires: dbus-glib-devel >= %{dbus_glib_devel}
44BuildRequires: avahi-glib-devel >= %{avahi_glib_devel}
45BuildRequires: libcroco-devel >= %{libcroco_version}
46BuildRequires: libgsf-devel >= %{libgsf_version}
47BuildRequires: autoconf
48BuildRequires: gtk-doc
49BuildRequires: vala-devel
50BuildRequires: vala-tools
51
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53
54Vendor: Project Vine
55Distribution: Vine Linux
56
57%description
58An SVG library based on libart.
59
60%description -l ja
61libart ベースの SVG ライブラリです
62
63
64%package devel
65Summary: Libraries and include files for developing with librsvg.
66Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
67Group: Development/Libraries
68Requires: %{name} = %{version}
69Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
70Requires: cairo-devel >= %{cairo_version}
71
72%description devel
73This package provides the necessary development libraries and include
74files to allow you to develop with librsvg.
75
76
77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:      noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88%package        vala
89Summary:        Vala bindings for %{name}
90Summary(ja):    %{name} の Vala バインディング
91Group:          Development/Libraries
92Requires:       %{name} = %{version}-%{release}
93Requires:       vala
94
95%description    vala
96Vala bindings for %{name}.
97
98
99%prep
100%setup -q -n librsvg-%{version}
101
102%build
103sed -i "s|0.17.1.26|0.20|" configure.in
104autoreconf -if
105%configure --enable-gtk-doc \
106           --enable-introspection=yes \
107           --enable-vala=yes \
108           --with-svgz \
109           --enable-gtk-theme \
110           --with-croco \
111           --disable-static
112%__make %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116make install DESTDIR=$RPM_BUILD_ROOT
117
118rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
119rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/libsvg.*a
120rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
121rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%post
127/sbin/ldconfig
128if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
129  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
130fi ||:
131
132%postun
133/sbin/ldconfig
134if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
135  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
136fi ||:
137
138%files
139%defattr(-,root,root,-)
140%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
141%{_bindir}/*
142%{_libdir}/*.so.*
143%{_libdir}/gtk-2.0/*/engines/*.so
144%{_libdir}/gdk-pixbuf-2.0/*/loaders/*.so
145%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
146%{_mandir}/man1/*
147%{_datadir}/themes/bubble/gtk-2.0/*
148
149%files devel
150%defattr(-,root,root,-)
151%{_libdir}/*.so
152%{_includedir}/librsvg-2.0/librsvg
153%{_libdir}/pkgconfig/librsvg-2.0.pc
154%{_datadir}/gir-1.0/Rsvg-2.0.gir
155
156%files docs
157%defattr(-,root,root,-)
158%{_datadir}/gtk-doc/html/rsvg-2.0
159
160%files vala
161%defattr(-,root,root,-)
162%{_datadir}/vala/vapi/librsvg-2.0.vapi
163
164
165%changelog
166* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
167- add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
168- create %%{name}-docs and %%{name}-vala subpackages
169
170* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
171- new upstream release
172
173* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
174- new upstream release
175
176* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
177- new upstream release
178
179* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
180- new upstream release
181- add BuildRequires: gobject-introspection-devel
182
183* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
184- new upstream release
185- remove Patch0
186
187* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
188- new upstream release
189- add Patch0 (librsvg2-2.34.0-git20110728.patch)
190
191* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
192- new upstream release
193
194* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
195- new upstream release
196- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
197- remove Requires: libart_lgpl
198- add configure option (--disable-static)
199- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
200- fix %install, %files, %post and %postun
201
202* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
203- build with rpm-4.8.1-1 for pkg-config file
204
205* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
206- new upstream release
207
208* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
209- new upstream release
210- remove static libs
211
212* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
213- new upstream release
214- spec in UTF-8
215
216* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
217- new upstream release
218
219* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
220- rebuilt with libgsf-1.14.8
221
222* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
223- new upstream release
224
225* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
226- new upstream release
227- add BuildRequires: dbus-glib-devel, avahi-glib-devel
228- add BuildRequires: libgsf-devel, libcroco-devel
229- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
230- add Requires(post,postun): glib2
231
232* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
233- rebuild with gtk+-2.10
234
235* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
236- rebuilt without libgsf-devel
237
238* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
239- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
240  for biarch support. (TODO: add compat32)
241
242* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
243- rebuild
244
245* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
246- new upstream release
247
248* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
249- new upstream release
250
251* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
252- new upstream release
253
254* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
255- new upstream release
256- added --disable-gtk-doc option
257
258* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
259- new upstream release
260- added gtk-doc to devel package
261
262* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
263- new upstream release
264- added Japanese description
265- added --without-svgz option (because it requires libgsf)
266
267* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
268- new upstream release
269
270* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
271- new upstream release
272
273* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
274- rebuilt to avoid unwanted dependency (libgsf)
275
276* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
277- add gdk-pixbuf-query-loaders to post/postun script.
278
279* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
280- rebuild with gtk+-2.4.0
281
282* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
283- new upstream release
284
285* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
286- fix kanji code of spec file
287- fix file entry, add missing files
288
289* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
290- new upstream release
291
292* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
293- added --without-svgz and --without-gimp to %configure
294
295* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
296- new upstream release
297- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
298- added %{_libdir}/gtk-2.0/* to devel package
299
300* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
301- new upstream release
302
303* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
304- new upstream release
305
306* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
307- new upstream release
308
309* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
310- build for Vine Linux
311- new upstream release from gnome-2.1.4
312
313* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
314- 2.0.1
315
316* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
317- automated rebuild
318
319* Sun May 26 2002 Tim Powers <timp@redhat.com>
320- automated rebuild
321
322* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
323- rebuild in different environment
324
325* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
326- rebuild in different environment
327
328* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
329- 1.1.6
330
331* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
332- Update to 1.1.3
333
334* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
335- automated rebuild
336
337* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
338- new CVS snap 1.1.0.91
339- remove automake/autoconf calls
340
341* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
342- convert to librsvg2 RPM
343
344* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
345- 1.0.2
346
347* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
348- Add a patch that moves the includes to librsvg-1/librsvg
349- in preparation for a later librsvg 2 library.
350
351* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
352- build requires gnome-libs-devel, #49509
353
354* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
355- own /usr/include/librsvg
356
357* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
358- fixed the linefeed problem in multibyte environment. (Bug#49310)
359
360* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
361- put .la file back in package
362
363* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
364- Put changelog at the end
365- Move .so files to devel subpackage
366- Don't mess with ld.so.conf
367- Don't use %%{prefix}, this isn't a relocatable package
368- Don't define a bad docdir
369- Add BuildRequires
370- Use %%{_tmppath}
371- Don't define name, version etc. on top of the file (why do so many do that?)
372- s/Copyright/License/
373
374* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
375- Put into Red Hat Build system
376
377* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
378- removed obsoletes from sub packages and added mozilla and trilobite
379subpackages
380
381* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
382- created this thing
383
Note: See TracBrowser for help on using the repository browser.