source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 12321

Revision 12321, 12.7 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

bash-5.0.16-1

gtk-doc-1.32-3

libmariadb-3.1.7-1

libpq-12.2-1

librsvg2-2.46.4-1

postgresql-12.2-1

python-pygments-2.5.2-1

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.8
4%define gdk_pixbuf2 2.26.1
5%define gtk3_version 3.4.1
6%define freetype_version 2.4.2
7%define popt_version 1.14
8%define libart_version 2.3.21
9%define cairo_version 1.12.0
10%define dbus_version 1.4.0
11%define dbus_glib_version 0.88
12%define avahi_glib_version 0.6.23
13%define libcroco_version 0.6.2
14%define libgsf_version 1.14.19
15
16Name:           librsvg2
17Summary:        An SVG library based on libart.
18Summary(ja):    libart ベースの SVG ライブラリ
19Version:        2.46.4
20Release:        1%{?_dist_release}
21License:        LGPL
22Group:          System Environment/Libraries
23%global         shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
24Source:         https://download.gnome.org/sources/librsvg/%{shortver}/librsvg-%{version}.tar.xz
25
26Requires(post,postun): gtk3 >= %{gtk3_version}
27Requires(post): dbus-glib >= %{dbus_glib_version}
28Requires(post): avahi-glib >= %{avahi_glib_version}
29Requires(post): libgsf, libcroco
30Requires: gtk3 >= %{gtk3_version}
31Requires: libxml2 >= %{libxml2_version}
32Requires: popt >= %{popt_version}
33Requires: freetype2 >= %{freetype_version}
34Requires: libpng
35BuildRequires: libpng-devel
36BuildRequires: gtk3-devel >= %{gtk3_version}
37BuildRequires: gobject-introspection-devel
38BuildRequires: libxml2-devel >= %{libxml2_version}
39BuildRequires: freetype2-devel >= %{freetype_version}
40BuildRequires: cairo-devel >= %{cairo_version}
41BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
42BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
43BuildRequires: libcroco-devel >= %{libcroco_version}
44BuildRequires: libgsf-devel >= %{libgsf_version}
45BuildRequires: autoconf
46BuildRequires: gtk-doc
47BuildRequires: vala-devel
48BuildRequires: vala-tools
49BuildRequires: rust
50BuildRequires: cargo
51
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53
54Vendor: Project Vine
55Distribution: Vine Linux
56
57%description
58An SVG library based on libart.
59
60%description -l ja
61libart ベースの SVG ライブラリです
62
63
64%package devel
65Summary: Libraries and include files for developing with librsvg.
66Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
67Group: Development/Libraries
68Requires: %{name} = %{version}
69Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
70Requires: cairo-devel >= %{cairo_version}
71
72%description devel
73This package provides the necessary development libraries and include
74files to allow you to develop with librsvg.
75
76
77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:      noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88%package        vala
89Summary:        Vala bindings for %{name}
90Summary(ja):    %{name} の Vala バインディング
91Group:          Development/Libraries
92Requires:       %{name} = %{version}-%{release}
93Requires:       vala
94
95%description    vala
96Vala bindings for %{name}.
97
98
99%prep
100%setup -q -n librsvg-%{version}
101
102%build
103%configure --enable-gtk-doc \
104           --enable-introspection=yes \
105           --enable-vala=yes \
106           --with-svgz \
107           --enable-gtk-theme \
108           --with-croco \
109           --disable-static
110%__make %{?_smp_mflags}
111
112%install
113rm -rf %{buildroot}
114make install DESTDIR=%{buildroot}
115
116rm -f %{buildroot}%{_libdir}/*.{a,la}
117rm -f %{buildroot}%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
118rm -f %{buildroot}%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
119
120rm -rf %{buildroot}%{_docdir}/librsvg
121
122%find_lang librsvg
123
124%clean
125rm -rf %{buildroot}
126
127%post
128/sbin/ldconfig
129if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
130  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
131fi ||:
132
133%postun
134/sbin/ldconfig
135if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
136  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
137fi ||:
138
139%files -f librsvg.lang
140%defattr(-,root,root,-)
141%license COPYING.LIB
142%doc AUTHORS NEWS README.md
143%{_bindir}/rsvg-convert
144%{_libdir}/librsvg-2.so.*
145%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
146%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
147%dir %{_datadir}/thumbnailers
148%{_datadir}/thumbnailers/librsvg.thumbnailer
149%{_mandir}/man1/rsvg-convert.1.gz
150
151%files devel
152%defattr(-,root,root,-)
153%{_libdir}/librsvg-2.so
154%{_includedir}/librsvg-2.0/librsvg
155%{_libdir}/pkgconfig/librsvg-2.0.pc
156%{_datadir}/gir-1.0/Rsvg-2.0.gir
157
158%files docs
159%defattr(-,root,root,-)
160%{_datadir}/gtk-doc/html/rsvg-2.0
161
162%files vala
163%defattr(-,root,root,-)
164%{_datadir}/vala/vapi/librsvg-2.0.vapi
165
166
167%changelog
168* Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.46.4-1
169- new upstream release.
170
171* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.16-1
172- new upstream release
173
174* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.12-1
175- new upstream release
176
177* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.11-1
178- new upstream release
179- remove Patch0
180
181* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.10-1
182- new upstream release
183- add Patch0 (librsvg-2.40.10-git20150811.patch)
184
185* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.9-1
186- new upstream release
187
188* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.8-1
189- new upstream release
190
191* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.7-1
192- new upstream release
193
194* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
195- new upstream release
196
197* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
198- new upstream release
199
200* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
201- new upstream release
202
203* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
204- rebuild with libpng-1.6.12
205
206* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
207- new upstream release
208
209* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
210- fix typo
211
212* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
213- new upstream release
214- remove BuildRequires: gtk2-devel
215
216* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
217- add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
218- create %%{name}-docs and %%{name}-vala subpackages
219
220* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
221- new upstream release
222
223* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
224- new upstream release
225
226* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
227- new upstream release
228
229* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
230- new upstream release
231- add BuildRequires: gobject-introspection-devel
232
233* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
234- new upstream release
235- remove Patch0
236
237* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
238- new upstream release
239- add Patch0 (librsvg2-2.34.0-git20110728.patch)
240
241* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
242- new upstream release
243
244* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
245- new upstream release
246- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
247- remove Requires: libart_lgpl
248- add configure option (--disable-static)
249- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
250- fix %install, %files, %post and %postun
251
252* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
253- build with rpm-4.8.1-1 for pkg-config file
254
255* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
256- new upstream release
257
258* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
259- new upstream release
260- remove static libs
261
262* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
263- new upstream release
264- spec in UTF-8
265
266* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
267- new upstream release
268
269* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
270- rebuilt with libgsf-1.14.8
271
272* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
273- new upstream release
274
275* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
276- new upstream release
277- add BuildRequires: dbus-glib-devel, avahi-glib-devel
278- add BuildRequires: libgsf-devel, libcroco-devel
279- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
280- add Requires(post,postun): glib2
281
282* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
283- rebuild with gtk+-2.10
284
285* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
286- rebuilt without libgsf-devel
287
288* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
289- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
290  for biarch support. (TODO: add compat32)
291
292* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
293- rebuild
294
295* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
296- new upstream release
297
298* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
299- new upstream release
300
301* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
302- new upstream release
303
304* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
305- new upstream release
306- added --disable-gtk-doc option
307
308* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
309- new upstream release
310- added gtk-doc to devel package
311
312* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
313- new upstream release
314- added Japanese description
315- added --without-svgz option (because it requires libgsf)
316
317* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
318- new upstream release
319
320* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
321- new upstream release
322
323* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
324- rebuilt to avoid unwanted dependency (libgsf)
325
326* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
327- add gdk-pixbuf-query-loaders to post/postun script.
328
329* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
330- rebuild with gtk+-2.4.0
331
332* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
333- new upstream release
334
335* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
336- fix kanji code of spec file
337- fix file entry, add missing files
338
339* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
340- new upstream release
341
342* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
343- added --without-svgz and --without-gimp to %configure
344
345* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
346- new upstream release
347- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
348- added %{_libdir}/gtk-2.0/* to devel package
349
350* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
351- new upstream release
352
353* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
354- new upstream release
355
356* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
357- new upstream release
358
359* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
360- build for Vine Linux
361- new upstream release from gnome-2.1.4
362
363* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
364- 2.0.1
365
366* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
367- automated rebuild
368
369* Sun May 26 2002 Tim Powers <timp@redhat.com>
370- automated rebuild
371
372* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
373- rebuild in different environment
374
375* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
376- rebuild in different environment
377
378* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
379- 1.1.6
380
381* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
382- Update to 1.1.3
383
384* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
385- automated rebuild
386
387* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
388- new CVS snap 1.1.0.91
389- remove automake/autoconf calls
390
391* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
392- convert to librsvg2 RPM
393
394* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
395- 1.0.2
396
397* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
398- Add a patch that moves the includes to librsvg-1/librsvg
399- in preparation for a later librsvg 2 library.
400
401* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
402- build requires gnome-libs-devel, #49509
403
404* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
405- own /usr/include/librsvg
406
407* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
408- fixed the linefeed problem in multibyte environment. (Bug#49310)
409
410* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
411- put .la file back in package
412
413* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
414- Put changelog at the end
415- Move .so files to devel subpackage
416- Don't mess with ld.so.conf
417- Don't use %%{prefix}, this isn't a relocatable package
418- Don't define a bad docdir
419- Add BuildRequires
420- Use %%{_tmppath}
421- Don't define name, version etc. on top of the file (why do so many do that?)
422- s/Copyright/License/
423
424* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
425- Put into Red Hat Build system
426
427* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
428- removed obsoletes from sub packages and added mozilla and trilobite
429subpackages
430
431* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
432- created this thing
433
Note: See TracBrowser for help on using the repository browser.