source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 6890

Revision 6890, 10.1 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define __libtoolize :
2
3%define libxml2_version 2.7.8
4%define gtk2_version 2.22.1
5%define gdk_pixbuf2 2.26.1
6%define gtk3_version 3.4.1
7%define freetype_version 2.4.2
8%define popt_version 1.14
9%define libart_version 2.3.21
10%define cairo_version 1.12.0
11%define dbus_version 1.4.0
12%define dbus_glib_version 0.88
13%define avahi_glib_version 0.6.23
14%define libcroco_version 0.6.2
15%define libgsf_version 1.14.19
16
17Name:    librsvg2
18Summary: An SVG library based on libart.
19Summary(ja): libart ベースの SVG ライブラリ
20Version: 2.36.3
21Release: 1%{?_dist_release}
22License: LGPL
23Group: System Environment/Libraries
24Source: librsvg-%{version}.tar.xz
25
26Requires(post,postun): gtk2 >= %{gtk2_version}
27Requires(post): dbus-glib >= %{dbus_glib_version}
28Requires(post): avahi-glib >= %{avahi_glib_devel}
29Requires(post): libgsf, libcroco
30Requires: gtk2 >= %{gtk2_version}
31Requires: gtk3 >= %{gtk3_version}
32Requires: libxml2 >= %{libxml2_version}
33Requires: popt >= %{popt_version}
34Requires: freetype2 >= %{freetype_version}
35Requires: libpng
36BuildRequires: libpng-devel
37BuildRequires: gtk2-devel >= %{gtk2_version}
38BuildRequires: gtk3-devel >= %{gtk3_version}
39BuildRequires: gobject-introspection-devel
40BuildRequires: libxml2-devel >= %{libxml2_version}
41BuildRequires: freetype2-devel >= %{freetype_version}
42BuildRequires: cairo-devel >= %{cairo_version}
43BuildRequires: dbus-glib-devel >= %{dbus_glib_devel}
44BuildRequires: avahi-glib-devel >= %{avahi_glib_devel}
45BuildRequires: libcroco-devel >= %{libcroco_version}
46BuildRequires: libgsf-devel >= %{libgsf_version}
47BuildRoot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53An SVG library based on libart.
54
55%description -l ja
56libart ベースの SVG ライブラリです
57
58
59%package devel
60Summary: Libraries and include files for developing with librsvg.
61Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
62Group: Development/Libraries
63Requires: %{name} = %{version}
64Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
65Requires: cairo-devel >= %{cairo_version}
66
67%description devel
68This package provides the necessary development libraries and include
69files to allow you to develop with librsvg.
70
71%prep
72%setup -q -n librsvg-%{version}
73
74%build
75%configure --disable-gtk-doc \
76           --enable-introspection \
77           --with-svgz \
78           --enable-gtk-theme \
79           --with-croco \
80           --disable-static
81%__make %{?_smp_mflags}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
88rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/libsvg.*a
89rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
90rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post
96/sbin/ldconfig
97if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
98  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
99fi ||:
100
101%postun
102/sbin/ldconfig
103if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
104  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
105fi ||:
106
107%files
108
109%defattr(-, root, root)
110%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
111%{_bindir}/*
112%{_libdir}/*.so.*
113%{_libdir}/gtk-2.0/*/engines/*.so
114%{_libdir}/gdk-pixbuf-2.0/*/loaders/*.so
115%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
116%{_mandir}/man1/*
117%{_datadir}/themes/bubble/gtk-2.0/*
118
119%files devel
120%defattr(-, root, root)
121%{_libdir}/*.so
122%{_includedir}/librsvg-2.0/librsvg
123%{_libdir}/pkgconfig/librsvg-2.0.pc
124%{_datadir}/gtk-doc/html/rsvg-2.0
125%{_datadir}/gir-1.0/Rsvg-2.0.gir
126
127%changelog
128* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
129- new upstream release
130
131* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
132- new upstream release
133
134* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
135- new upstream release
136- add BuildRequires: gobject-introspection-devel
137
138* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
139- new upstream release
140- remove Patch0
141
142* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
143- new upstream release
144- add Patch0 (librsvg2-2.34.0-git20110728.patch)
145
146* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
147- new upstream release
148
149* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
150- new upstream release
151- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
152- remove Requires: libart_lgpl
153- add configure option (--disable-static)
154- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
155- fix %install, %files, %post and %postun
156
157* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
158- build with rpm-4.8.1-1 for pkg-config file
159
160* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
161- new upstream release
162
163* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
164- new upstream release
165- remove static libs
166
167* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
168- new upstream release
169- spec in UTF-8
170
171* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
172- new upstream release
173
174* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
175- rebuilt with libgsf-1.14.8
176
177* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
178- new upstream release
179
180* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
181- new upstream release
182- add BuildRequires: dbus-glib-devel, avahi-glib-devel
183- add BuildRequires: libgsf-devel, libcroco-devel
184- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
185- add Requires(post,postun): glib2
186
187* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
188- rebuild with gtk+-2.10
189
190* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
191- rebuilt without libgsf-devel
192
193* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
194- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
195  for biarch support. (TODO: add compat32)
196
197* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
198- rebuild
199
200* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
201- new upstream release
202
203* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
204- new upstream release
205
206* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
207- new upstream release
208
209* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
210- new upstream release
211- added --disable-gtk-doc option
212
213* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
214- new upstream release
215- added gtk-doc to devel package
216
217* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
218- new upstream release
219- added Japanese description
220- added --without-svgz option (because it requires libgsf)
221
222* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
223- new upstream release
224
225* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
226- new upstream release
227
228* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
229- rebuilt to avoid unwanted dependency (libgsf)
230
231* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
232- add gdk-pixbuf-query-loaders to post/postun script.
233
234* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
235- rebuild with gtk+-2.4.0
236
237* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
238- new upstream release
239
240* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
241- fix kanji code of spec file
242- fix file entry, add missing files
243
244* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
245- new upstream release
246
247* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
248- added --without-svgz and --without-gimp to %configure
249
250* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
251- new upstream release
252- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
253- added %{_libdir}/gtk-2.0/* to devel package
254
255* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
256- new upstream release
257
258* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
259- new upstream release
260
261* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
262- new upstream release
263
264* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
265- build for Vine Linux
266- new upstream release from gnome-2.1.4
267
268* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
269- 2.0.1
270
271* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
272- automated rebuild
273
274* Sun May 26 2002 Tim Powers <timp@redhat.com>
275- automated rebuild
276
277* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
278- rebuild in different environment
279
280* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
281- rebuild in different environment
282
283* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
284- 1.1.6
285
286* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
287- Update to 1.1.3
288
289* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
290- automated rebuild
291
292* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
293- new CVS snap 1.1.0.91
294- remove automake/autoconf calls
295
296* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
297- convert to librsvg2 RPM
298
299* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
300- 1.0.2
301
302* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
303- Add a patch that moves the includes to librsvg-1/librsvg
304- in preparation for a later librsvg 2 library.
305
306* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
307- build requires gnome-libs-devel, #49509
308
309* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
310- own /usr/include/librsvg
311
312* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
313- fixed the linefeed problem in multibyte environment. (Bug#49310)
314
315* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
316- put .la file back in package
317
318* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
319- Put changelog at the end
320- Move .so files to devel subpackage
321- Don't mess with ld.so.conf
322- Don't use %%{prefix}, this isn't a relocatable package
323- Don't define a bad docdir
324- Add BuildRequires
325- Use %%{_tmppath}
326- Don't define name, version etc. on top of the file (why do so many do that?)
327- s/Copyright/License/
328
329* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
330- Put into Red Hat Build system
331
332* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
333- removed obsoletes from sub packages and added mozilla and trilobite
334subpackages
335
336* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
337- created this thing
338
Note: See TracBrowser for help on using the repository browser.