source: projects/specs/trunk/lib/libr/librsvg2/librsvg2-vl.spec @ 9475

Revision 9475, 11.9 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

RevLine 
[521]1%define __libtoolize :
2
[6078]3%define libxml2_version 2.7.8
4%define gdk_pixbuf2 2.26.1
5%define gtk3_version 3.4.1
[2041]6%define freetype_version 2.4.2
7%define popt_version 1.14
8%define libart_version 2.3.21
[6078]9%define cairo_version 1.12.0
[2041]10%define dbus_version 1.4.0
11%define dbus_glib_version 0.88
[521]12%define avahi_glib_version 0.6.23
[2041]13%define libcroco_version 0.6.2
14%define libgsf_version 1.14.19
[521]15
16Name:    librsvg2
17Summary: An SVG library based on libart.
18Summary(ja): libart ベースの SVG ライブラリ
[9475]19Version: 2.40.9
[8912]20Release: 1%{?_dist_release}
[521]21License: LGPL
22Group: System Environment/Libraries
[4812]23Source: librsvg-%{version}.tar.xz
[521]24
[8173]25Requires(post,postun): gtk3 >= %{gtk3_version}
[521]26Requires(post): dbus-glib >= %{dbus_glib_version}
[8173]27Requires(post): avahi-glib >= %{avahi_glib_version}
[521]28Requires(post): libgsf, libcroco
[4616]29Requires: gtk3 >= %{gtk3_version}
[521]30Requires: libxml2 >= %{libxml2_version}
31Requires: popt >= %{popt_version}
32Requires: freetype2 >= %{freetype_version}
33Requires: libpng
34BuildRequires: libpng-devel
[4616]35BuildRequires: gtk3-devel >= %{gtk3_version}
[5168]36BuildRequires: gobject-introspection-devel
[521]37BuildRequires: libxml2-devel >= %{libxml2_version}
38BuildRequires: freetype2-devel >= %{freetype_version}
39BuildRequires: cairo-devel >= %{cairo_version}
[8173]40BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
41BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
[521]42BuildRequires: libcroco-devel >= %{libcroco_version}
43BuildRequires: libgsf-devel >= %{libgsf_version}
[7633]44BuildRequires: autoconf
45BuildRequires: gtk-doc
46BuildRequires: vala-devel
47BuildRequires: vala-tools
48
[521]49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50
[4616]51Vendor: Project Vine
52Distribution: Vine Linux
53
[521]54%description
55An SVG library based on libart.
56
57%description -l ja
58libart ベースの SVG ライブラリです
59
60
61%package devel
62Summary: Libraries and include files for developing with librsvg.
63Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
64Group: Development/Libraries
65Requires: %{name} = %{version}
[4616]66Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
67Requires: cairo-devel >= %{cairo_version}
[521]68
69%description devel
70This package provides the necessary development libraries and include
71files to allow you to develop with librsvg.
72
[7633]73
74%package        docs
75Summary:        Documentation for %{name}
76Summary(ja):    %{name} 用のドキュメント
77Group:          Documentation
78Requires:       %{name} = %{version}-%{release}
79BuildArch:      noarch
80
81%description    docs
82This package contains documentation for %{name}.
83
84
85%package        vala
86Summary:        Vala bindings for %{name}
87Summary(ja):    %{name} の Vala バインディング
88Group:          Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       vala
91
92%description    vala
93Vala bindings for %{name}.
94
95
[521]96%prep
97%setup -q -n librsvg-%{version}
98
99%build
[7633]100%configure --enable-gtk-doc \
101           --enable-introspection=yes \
102           --enable-vala=yes \
[521]103           --with-svgz \
104           --enable-gtk-theme \
105           --with-croco \
[2041]106           --disable-static
[521]107%__make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
[2041]111make install DESTDIR=$RPM_BUILD_ROOT
112
[521]113rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
[2041]114rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
[521]115rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post
121/sbin/ldconfig
122if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
[2041]123  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
[521]124fi ||:
125
126%postun
127/sbin/ldconfig
128if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
[2041]129  /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
[521]130fi ||:
131
132%files
[7633]133%defattr(-,root,root,-)
[521]134%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
[8011]135%{_bindir}/rsvg-convert
136%{_bindir}/rsvg-view-3
137%{_libdir}/librsvg-2.so.*
138%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
[5168]139%{_libdir}/girepository-1.0/Rsvg-2.0.typelib
[8011]140%{_mandir}/man1/rsvg-convert.1.gz
[521]141
142%files devel
[7633]143%defattr(-,root,root,-)
[8011]144%{_libdir}/librsvg-2.so
[2041]145%{_includedir}/librsvg-2.0/librsvg
[521]146%{_libdir}/pkgconfig/librsvg-2.0.pc
[5168]147%{_datadir}/gir-1.0/Rsvg-2.0.gir
[521]148
[7633]149%files docs
150%defattr(-,root,root,-)
151%{_datadir}/gtk-doc/html/rsvg-2.0
152
153%files vala
154%defattr(-,root,root,-)
155%{_datadir}/vala/vapi/librsvg-2.0.vapi
156
157
[521]158%changelog
[9475]159* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.9-1
160- new upstream release
161
[9415]162* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.8-1
163- new upstream release
164
[9398]165* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.7-1
166- new upstream release
167
[9178]168* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
169- new upstream release
170
[9073]171* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
172- new upstream release
173
[8912]174* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
175- new upstream release
176
[8806]177* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
178- rebuild with libpng-1.6.12
179
[8353]180* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
181- new upstream release
182
[8173]183* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
184- fix typo
185
[8011]186* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
187- new upstream release
188- remove BuildRequires: gtk2-devel
189
[7633]190* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
191- add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
192- create %%{name}-docs and %%{name}-vala subpackages
193
[6951]194* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
195- new upstream release
196
[6890]197* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
198- new upstream release
199
[6078]200* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
[6011]201- new upstream release
202
[5168]203* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
204- new upstream release
205- add BuildRequires: gobject-introspection-devel
206
[4812]207* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
208- new upstream release
209- remove Patch0
210
[4616]211* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
212- new upstream release
213- add Patch0 (librsvg2-2.34.0-git20110728.patch)
214
[2219]215* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
216- new upstream release
217
[2041]218* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
219- new upstream release
220- remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
221- remove Requires: libart_lgpl
222- add configure option (--disable-static)
223- remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
224- fix %install, %files, %post and %postun
225
[1867]226* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
227- build with rpm-4.8.1-1 for pkg-config file
228
[926]229* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
230- new upstream release
231
[521]232* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
233- new upstream release
234- remove static libs
235
236* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
237- new upstream release
238- spec in UTF-8
239
240* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
241- new upstream release
242
243* Sat Mar  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
244- rebuilt with libgsf-1.14.8
245
246* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
247- new upstream release
248
249* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
250- new upstream release
251- add BuildRequires: dbus-glib-devel, avahi-glib-devel
252- add BuildRequires: libgsf-devel, libcroco-devel
253- add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
254- add Requires(post,postun): glib2
255
256* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
257- rebuild with gtk+-2.10
258
259* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
260- rebuilt without libgsf-devel
261
262* Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
263- update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
264  for biarch support. (TODO: add compat32)
265
266* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
267- rebuild
268
269* Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
270- new upstream release
271
272* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
273- new upstream release
274
275* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
276- new upstream release
277
278* Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
279- new upstream release
280- added --disable-gtk-doc option
281
282* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
283- new upstream release
284- added gtk-doc to devel package
285
286* Sun Oct  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
287- new upstream release
288- added Japanese description
289- added --without-svgz option (because it requires libgsf)
290
291* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
292- new upstream release
293
294* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
295- new upstream release
296
297* Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
298- rebuilt to avoid unwanted dependency (libgsf)
299
300* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
301- add gdk-pixbuf-query-loaders to post/postun script.
302
303* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
304- rebuild with gtk+-2.4.0
305
306* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
307- new upstream release
308
309* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
310- fix kanji code of spec file
311- fix file entry, add missing files
312
313* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
314- new upstream release
315
316* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
317- added --without-svgz and --without-gimp to %configure
318
319* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
320- new upstream release
321- added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
322- added %{_libdir}/gtk-2.0/* to devel package
323
324* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
325- new upstream release
326
327* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
328- new upstream release
329
330* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
331- new upstream release
332
333* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
334- build for Vine Linux
335- new upstream release from gnome-2.1.4
336
337* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
338- 2.0.1
339
340* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
341- automated rebuild
342
343* Sun May 26 2002 Tim Powers <timp@redhat.com>
344- automated rebuild
345
346* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
347- rebuild in different environment
348
349* Thu May 02 2002 Havoc Pennington <hp@redhat.com>
350- rebuild in different environment
351
352* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
353- 1.1.6
354
355* Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
356- Update to 1.1.3
357
358* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
359- automated rebuild
360
361* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
362- new CVS snap 1.1.0.91
363- remove automake/autoconf calls
364
365* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
366- convert to librsvg2 RPM
367
368* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
369- 1.0.2
370
371* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
372- Add a patch that moves the includes to librsvg-1/librsvg
373- in preparation for a later librsvg 2 library.
374
375* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
376- build requires gnome-libs-devel, #49509
377
378* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
379- own /usr/include/librsvg
380
381* Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
382- fixed the linefeed problem in multibyte environment. (Bug#49310)
383
384* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
385- put .la file back in package
386
387* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
388- Put changelog at the end
389- Move .so files to devel subpackage
390- Don't mess with ld.so.conf
391- Don't use %%{prefix}, this isn't a relocatable package
392- Don't define a bad docdir
393- Add BuildRequires
394- Use %%{_tmppath}
395- Don't define name, version etc. on top of the file (why do so many do that?)
396- s/Copyright/License/
397
398* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
399- Put into Red Hat Build system
400
401* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
402- removed obsoletes from sub packages and added mozilla and trilobite
403subpackages
404
405* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
406- created this thing
407
Note: See TracBrowser for help on using the repository browser.